VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or buy Replay Video Capture or PlayON and record Netflix, HBO, etc! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 40
Thread
  1. Can anyone here help me?

    I have a 30 min video file from around 2009 that I cannot get to play. It used to play fine on my Mac, but not any more.

    I have tried multiple players (Flipformac, VLC, DivX etc) on a Mac and a PC, and different codecs etc but it will not play. The best I have got is picture, but no sound. The problem seems to be it has been encoded with WMA3 and WMV3 codecs (The error I keep getting in VLC is - "Codec not Supported").

    I have tried downloading and installing old version of Windows Media Player and VLC - still no good.

    I have pasted in the information below that the MediaInfo application gives me

    If anyone could get this working and send me a copy I would be willing to pay them

    if you can help, please send me a message and I will send you the file via DropBox

    Thanks all


    -------------------------
    * * * MediaInfo Mac 0.7.36.0 file analysis report.
    * * * MediaInfo Mac is 2010 by Diego Massanti - http://mediainfo.massanti.com
    * * * MediaInfoLib by Jerome Martinez - http://mediainfo.sourceforge.net
    Created on: 3 May 2017, 15:38:18 BST
    Report for file: oil and gas video.mov

    General / Container Stream #1
    Total Video Streams for this File.................1
    Total Audio Streams for this File.................1
    Video Codecs Used.................................WMV3
    Audio Codecs Used.................................WMA3
    File Format.......................................MPEG-4
    Play Time.........................................30mn 31s
    Total File Size...................................72.4 MiB
    Total Stream BitRate..............................331 Kbps
    Encoding Library..................................Apple QuickTime
    Video Stream #1
    Codec (Human Name)................................WMV3
    Codec (FourCC)....................................WMV3
    Frame Width.......................................238 pixels
    Frame Height......................................134 pixels
    Frame Rate........................................12.500 fps
    Total Frames......................................22898
    Display Aspect Ratio..............................16:9
    QF (like Gordian Knot)............................0.664
    Video Stream Length...............................30mn 31s 865ms
    Video Stream BitRate..............................265 Kbps
    Video Stream BitRate Mode.........................VBR
    Video Stream Size.................................57.8 MiB (80%)
    Video Stream Language.............................English
    Date of Original Encoding.........................UTC 2010-08-24 08:06:55
    Audio Stream #1
    Codec............................................. WMA3
    Codec (FourCC)....................................WMA3
    Audio Stream Length...............................30mn 31s 865ms
    Audio Stream BitRate..............................65.2 Kbps
    Audio Stream BitRate Mode.........................CBR
    Number of Audio Channels..........................2
    Sampling Rate.....................................44.1 KHz
    Bit Depth.........................................16 bits
    Audio Stream Size.................................14.2 MiB (20%)
    Audio Stream Language.............................English
    Date of Original Encoding.........................UTC 2010-08-24 08:06:55
    Quote Quote  
  2. I don't think so, as it used to play find on my Mac a few years ago, but now (after many OS and Software updates) it does not
    Quote Quote  
  3. Originally Posted by ds99 View Post
    I don't think so, as it used to play find on my Mac a few years ago, but now (after many OS and Software updates) it does not
    Still sounds like DRM. Or a corrupt file. Is this a video you purchased?

    And what do you mean by "will not play"? What exactly happens when you try to play it? Do you get an error message? Garbled picture? Sound?

    Players like VLC have WMV3 and WMA3 decoders built in. So it's not a codec problem.
    Quote Quote  
  4. A week ago it would play with the picture fine, but no sound.

    Then I tried installing/updating different video players and codecs, and now all I get is either a blank screen, or an error message that says "Codec not supported, VLC could not decode the format WMA3" and "Codec not supported, VLC could not decode the format WMV3"

    I have tried it on a Mac (OS 1.11.6) and on a Win 7 PC

    I have tried:

    VLC
    Windows Media Player/Flip4mac
    DivX
    Realplayer
    Quicktime
    Elmedia player
    Quote Quote  
  5. Try re-wrapping into the proper asf/wmv container format , maybe with ffmpeg

    WMV in MOV probably isn't very stable or compatible with many things
    Quote Quote  
  6. err, any advice how I do that?

    Try re-wrapping into the proper asf/wmv container format , maybe with ffmpeg
    WMV in MOV probably isn't very stable or compatible with many things
    Quote Quote  
  7. ffmpeg -i "input.mov" -map 0 -c copy -f asf "output.asf"


    P.S.: Your MediaInfo version looks very outdated.
    Quote Quote  
  8. err, sorry to be thick here, but i tried that line in terminal and it says

    -bash: ffmpeg: command not found
    Quote Quote  
  9. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    Have you installed FFmpeg? Is it in your path?
    Quote Quote  
  10. yes, i have downloaded ffpgeg, but i still cant get it to work

    i am running the command from the ffmpeg folder

    sorry, this is all new to me
    Quote Quote  
  11. ok, i have downloaded FFmpeg, but i have no idea how to install it. i have two folders on my desktop, one called "ffmpeg-3.3" and "ffmpeg-3-1.3"

    what else do i have to do to get ffmpeg working?
    Quote Quote  
  12. ok,i have got ffmpeg installed and ran the following (input.mov is my movie)

    ffmpeg -i "input.mov" -map 0 -c copy -f asf "output.asf"


    i get this:

    Could not find codec parameters for stream 0 (Audio: none (WMA3 / 0x33414D57), 44100 Hz, 2 channels, 65 kb/s): unknown codec
    Consider increasing the value for the 'analyzeduration' and 'probesize' options
    Guessed Channel Layout for Input Stream #0.0 : stereo
    Quote Quote  
  13. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    I would say your audio stream (and perhaps the whole file) is corrupt.
    Quote Quote  
  14. ok thanks. this is very frustrating as i have seen the video in the past and have had no problems with my hard disk since
    Quote Quote  
  15. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    You could try ffmpeg -codecs to get a list. I'm not sure it reads WMA3.
    Quote Quote  
  16. i just tried that and the only WMA that appear is

    D.A..S wmalossless Windows Media Audio Lossless
    D.A.L. wmapro Windows Media Audio 9 Professional
    DEA.L. wmav1 Windows Media Audio 1
    DEA.L. wmav2 Windows Media Audio 2
    D.A.L. wmavoice Windows Media Audio Voice
    Quote Quote  
  17. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    Wikipedia tells me that WMA went from Version 2 to Version 7. MPlayer tells me that 0x33414D57 is the ID for WMA Pro Audio. Sounds like you have a corrupt or obsolete stream header. You could try going into the file (a copy!) with a byte editor and changing the FourCC to "WMA2" or "WMA9" and see what happens.
    Quote Quote  
  18. any suggestions for a byte editor i can use?
    Quote Quote  
  19. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    I use HxD.
    Quote Quote  
  20. Hxd doesnt work on a mac

    i downloaded and tried "Hex Fiend" but couldnt find anything in my movie file called "FourCC"

    thanks all. i have given up now.
    Quote Quote  
  21. 33414D57 is the code for 3AMW (reverse WMA3). So JVRaines suggested changing it to 32414D57 and/or 39414D57. (I have no idea if that will work.)

    If you send me the file I can test it.
    Quote Quote  
  22. 33414D57

    i cant find that hex code anywhere in the file
    Quote Quote  
  23. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    My suggestion was to search for the text string "WMA3" in the file and change it wherever it occurs.
    Quote Quote  
  24. i have changed all instances of "WMA" to "WMA2" - same problem

    and

    i have changed all instances of "WMA" to "WMA9" - same problem
    Quote Quote  
  25. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    Hmm. I find very few references to "WMA3" on the 'net and they point to WMA Pro and Version 9. Maybe your file is stuck in versioning hell; I know that Microsoft monkeyed around with the version numbers quite a bit. Have you tried playing your file on a Windows machine with Windows Media Player? In particular, an older version of WMP? You might also give Windows Media Encoder a try.
    Quote Quote  
  26. Have you tried playing your file on a Windows machine with Windows Media Player?
    yep. tried that. no joy...
    Quote Quote  
  27. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    If this is not a sensitive file, could you post it to the forum?
    Quote Quote  
  28. I verified that VLC can't play WMV and WMA2 in a MOV container (I don't have any WMA3 to test) even though it has no problems playing them from a WMV or MKV container.

    There is no WMA7 or WMA9 fourcc. The WMA library went from version 2 to 7 (and later to 9) but the fourcc didn't change to those numbers.
    Quote Quote  
  29. here it is...

    if anyone can get it working i would be very pleased

    https://www.dropbox.com/s/hr4301fgw1zabxa/oil.mov?dl=0
    Quote Quote  



Similar Threads