VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 8 of 8
  1. I use megui to encode files to x264. most of the files I get are in an mkv container.

    untill I updated megui this morning everything worked fine using the one click encoder I pull in an mkv file and have it do its thing and kick out as mp4.

    But now I have updated megui to 2715 and I get a "No container type could be found that matches the list of acceptable types in your chosen one click profile. Your restrictions are now being ignored." error

    I checked mp4box and mkvtools are there all be it updated.

    The only way I could get rid of the erro was to either reencode it into mkv again or use file index option and manually tell it to reencode to mp4 container.

    Anyone any clue as to what might be wrong?

    There is no error listed in the log if any one asks... it just ignores my mp4 setting and reencodes to mkv.
    Quote Quote  
  2. Open the One Click Encoder. On the bottom-right click "Config" (right side of the profile). Open the "output" tab. Is "mp4" activated?
    Quote Quote  
  3. Yes I did that already.... But if i do not have mkv option ticked in there as well I get said error above...
    Quote Quote  
  4. Can you post MediaInfo of your file?

    It it has e.g. PGS subtitles (that don't fit into mp4) MeGUI will fail to select MP4. In the profile config go to the "Language" tab and remove all subtitle languages (move to right >>) and set "Languages to select ... " to "none". In "Audio" select an audio encoder that's compatible with mp4, like AC3 or QAAC.
    Last edited by sneaker; 17th Apr 2017 at 17:31. Reason: maybe not a bug after all
    Quote Quote  
  5. What are PGS subtitles? The subtitles inside the mkv are ass ones. Could that be the issue? I usually see srt there
    Quote Quote  
  6. I forgot you asked for info sorry.....

    Unique ID : 203291093337588349959760810397545536497 (0x98F070BE9E590DF9E500D0E992DC1BF1)
    Complete name : G:\Video.mkv
    Format : Matroska
    Format version : Version 2
    File size : 318 MiB
    Duration : 43 min 5 s
    Overall bit rate : 1 031 kb/s
    Writing application : HandBrake 0.10.1 2015030800
    Writing library : Lavf55.12.0 / Lavf55.12.0

    ID : 1
    Format : HEVC
    Format/Info : High Efficiency Video Coding
    Format profile : Main@L4@Main
    Duration : 43 min 5 s
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 23.976 (24000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Writing library : x265 1.5:[Windows][GCC 4.9.0][64 bit]
    Encoding settings : wpp / ctu=64 / tu-intra-depth=1 / tu-inter-depth=1 / me=1 / subme=2 / merange=57 / no-rect / no-amp / max-merge=2 / temporal-mvp / no-early-skip / no-fast-cbf / rdpenalty=0 / no-tskip / no-tskip-fast / strong-intra-smoothing / no-lossless / no-cu-lossless / no-constrained-intra / fast-intra / open-gop / interlace=0 / keyint=240 / min-keyint=24 / scenecut=40 / rc-lookahead=15 / bframes=4 / bframe-bias=0 / b-adapt=0 / ref=2 / weightp / no-weightb / aq-mode=1 / aq-strength=1.00 / cbqpoffs=0 / crqpoffs=0 / rd=2 / psy-rd=0.30 / psy-rdoq=0.00 / signhide / lft / sao / no-sao-non-deblock / b-pyramid / cutree / rc=2 / pass / bitrate=900 / qcomp=0.60 / qpmin=0 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ipratio=1.40 / pbratio=1.30
    Default : Yes
    Forced : No
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : HE-AAC / LC
    Codec ID : A_AAC
    Duration : 43 min 5 s
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 kHz / 24.0 kHz
    Frame rate : 23.438 FPS (1024 spf)
    Compression mode : Lossy
    Delay relative to video : -105 ms
    Title : Stereo
    Language : English
    Default : Yes
    Forced : No

    ID : 3
    Format : ASS
    Codec ID : S_TEXT/ASS
    Codec ID/Info : Advanced Sub Station Alpha
    Compression mode : Lossless
    Language : English
    Default : No
    Forced : No

    I am converting it from x265/mkv to x264/mp4 so I can play it on my WD TV live.
    Last edited by ZenMystic; 17th Apr 2017 at 21:17. Reason: typos
    Quote Quote  
  7. For the moment, you might want to try downgrading MeGUI. If it's not set to delete old files straight away, there'll be an "MeGUI.exe.backup" file in the MeGUI folder. Move the current MeGUI.exe to somewhere safe and rename the old file, then give it a spin.

    Or I've attached a couple of slightly older versions if you'd care to try them. You should be able to stick them in the MeGUI folder, although maybe backup the whole MeGUI folder first, just in case something odd happens. If the problem goes away it's probably a bug in the latest version.
    Image Attached Files
    Quote Quote  
  8. Originally Posted by ZenMystic View Post
    The subtitles inside the mkv are ass ones. Could that be the issue?
    Yes. Probably the only subtitles MeGUI accepts for MP4 output are SRT (simple text).

    You have several options:
    A.) Activate .mkv in the list (see post #2) as well. As far as I know wdtv live does support mkv, just not with H.265/HEVC video. MeGUI can convert H.265/HEVC-in-mkv to H.264/AVC-in-mkv.
    B.) Convert the subtitles to .srt using a different program (e.g. SubtitleEdit) and try again. But all ASS stylings (font, color, animations ...) will be lost.
    C.) Burn-in using MeGUI's AVS Script creator (complicated)
    D.) Use a program that makes burning in ASS subtitles simpler than MeGUI. For example VidCoder. Then you can output to mp4. (VidCoder can also convert to H.264/AVC-in-mkv without burning in the subtitles.)

    I don't know if going back to an older MeGUI version helps. We don't even know which version you had before.
    Quote Quote  

Similar Threads