VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Member
    Join Date
    Aug 2001
    Location
    The Netherlands
    Search PM
    Hi,

    Until recently I was perfectly happy being able to decode/transcode blu-ray material using AVCHDCoder 15.12.27 on my Windows 10 (32-bit) machine.

    But after a recent Windows 10 update encoding video using AVCHDCoder failes.

    I used the encoder test and found out that encoding H264 and MPEG2 material failes. I have made no changes to any setting in AVCHDCoder, so to me it seems that the problem was caused by something that was changed on the computer by the update that was installed (and forced me to reboot after installation of the update).

    I think it's this update:
    KB3150513: Update for Windows 10 Version 1607

    I have found no information yet about a possible cause of the decoding failure related to this update.

    Do any of you have the same issue/problem?
    And if so, have you found a solution or workaround?

    Thanks.
    Quote Quote  
  2. Member
    Join Date
    Aug 2001
    Location
    The Netherlands
    Search PM
    I found the solution to my problem and would like to share it with you...

    After having searched online and found not much helpful information, I started looking into some of AVCHDCoder's settings.

    Changing 'ffdshow' settings didn't help.

    So I decided to run the Preferred DirectShow Filter Tweaker for Windows 7 (menu "Help" > "Installers" > "Old way (ffdshow with Haali Media Splitter)" > "4. Run Preferred DirectShow Filter Tweaker for Windows 7").

    It turned out that the settings for H264, VC1 and MPEG2 had been changed to "Microsoft" instead of "ffdshow" (the original values and also advised setting by the author of the program).

    After changing these settings back to "ffdshow" the Encoder Test in AVCHDCoder passed all tests successfully.
    Quote Quote  
  3. Member
    Join Date
    Aug 2017
    Location
    Portugal
    Search Comp PM
    I have the same problem.

    After a clean installation of Windows pro x64 version 1703 I have the same problem, the Test failed.

    Before having the same version (1703) but updated from the version 1607 there was no problem.

    As I say the problem appears only when a made a Clean Installation.

    I also tried to changed to "Microsoft" instead of "ffdshow" (the original values and also advised setting by the author of the program), but the test is also failing.

    Is not only with the AVCHDCoder that I have problems also, now, the BD3D2MK3D software is not properly working.

    It seems that something is missing on Windows 10.

    Suggestions???
    Quote Quote  
  4. Originally Posted by madipav View Post
    Is not only with the AVCHDCoder that I have problems also, now, the BD3D2MK3D software is not properly working.
    Hi. I'm the author of BD3D2MK3D, but I use it only under Windows 7. I have a Win10 partition, so I can test it, but I don't use it often. Can you briefly explain what is wrong with BD3D2MK3D and Win10, or write me at pgcedit * at * gmail * dot * com?
    Thanks in advance!
    r0lZ - PgcEdit homepage Hosted by VideoHelp (Thanks Baldrick)
    - BD3D2MK3D A tool to convert 3D BD to 3D SBS/T&B/FS MKV
    Quote Quote  
  5. Member
    Join Date
    Aug 2017
    Location
    Portugal
    Search Comp PM
    Dear Sir,

    Thank you to your email concerning my problem with the correct working with your BD3D2MK3D software.

    During the process I have a Avisynth error, as you can see on the “BD3D2MK3D 3” image.

    I’m trying to understand what is happens on my PC, because before it was properly working, but not now, and I don’t understand why?

    I don’t find a solution.


    Click image for larger version

Name:	BD3D2MK3D 1.jpg
Views:	100
Size:	98.6 KB
ID:	43035Click image for larger version

Name:	BD3D2MK3D 2.jpg
Views:	72
Size:	17.2 KB
ID:	43036Click image for larger version

Name:	BD3D2MK3D 3.jpg
Views:	115
Size:	134.4 KB
ID:	43037Click image for larger version

Name:	BD3D2MK3D 4 Working File.jpg
Views:	72
Size:	78.9 KB
ID:	43038
    Quote Quote  
  6. Thanks for the information.

    I wonder if the problem could be caused by the accented character in your name. Windows has 3 different ways to encode the accented characters (yes, 3!), and it is often a pain to mix regular programs (like BD3D2MK3D itself) and CLI programs running in a command prompt window (like avs2yuv, x264 or mkvtoolnix), because they don't use the same character encoding scheme, and they cannot pass the arguments to each other correctly.

    Can you confirm that you did not save the projects in a folder with the same path name under your old version of Windows (or at least, confirm that the path did not contain accented characters)?

    Can you also try to move the project folder elsewhere, in a path without accented characters, and launch __ENCODE_3D_LAUNCHER.cmd from there? If that doesn't work, can you move the BD3D2MK3D's installation folder elsewhere (again in a path without accented characters) and generate a new project from scratch? You may also have to change the two paths in the "Go!" frame of the last tab of BD3D2MK3D. Please tell me if one of these suggestions has solved the problem.

    In the meantime, I will do some tests here. But anyway, I suggest to change your user name and use a name without accented characters, such as Antonio instead of António. You may have to create a new user for Windows, but I strongly recommend doing it, as otherwise other programs may also fail. That may be the case of AVCHDCoder, I don't know.

    @vtpeters: Do you have also accented characters in a path related to AVCHDCoder?
    Last edited by r0lZ; 4th Sep 2017 at 10:22.
    r0lZ - PgcEdit homepage Hosted by VideoHelp (Thanks Baldrick)
    - BD3D2MK3D A tool to convert 3D BD to 3D SBS/T&B/FS MKV
    Quote Quote  
  7. Member
    Join Date
    Aug 2017
    Location
    Portugal
    Search Comp PM
    Thanks very much for your precious help.

    Finally my problems as finished.

    The problem it was the accented character on my User PC Name.

    Now, both software are working correctly.

    Thank you again.
    Quote Quote  
  8. Thanks to you too! I will try to modify BD3D2MK3D so that that problem will not occur again, even when the path names contain accented characters, but I'm not sure it's possible. AFAIK, there are no problems under Windows 7 and 8, and I wonder what has changed in Windows 10. But thanks to your help, I know where to look...
    r0lZ - PgcEdit homepage Hosted by VideoHelp (Thanks Baldrick)
    - BD3D2MK3D A tool to convert 3D BD to 3D SBS/T&B/FS MKV
    Quote Quote  
  9. Done. I've found a workaround for the Avisynth foreign characters in path bug. BD3D2MK3D v1.2 (to be released soon) should work correctly even when path to the toolset folder contains non-ASCII characters. However, I cannot certify that the new version will work with all forks of Avisynth. At least, it works with the latest official Avisynth version (v2.60 for x86).
    r0lZ - PgcEdit homepage Hosted by VideoHelp (Thanks Baldrick)
    - BD3D2MK3D A tool to convert 3D BD to 3D SBS/T&B/FS MKV
    Quote Quote  



Similar Threads