VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 16 of 16
  1. I always watch movie files in limited user mode to keep my comp clean.

    The checkbox for MPC restart from last position IS checked in this mode, but doesn't do jack

    When I play as admin it works.

    Any fix for this apart from just be admin ?
    Quote Quote  
  2. Try to disable "Store settings in .ini file".
    Quote Quote  
  3. Thanks, but I cannot toggle that nor uncheck Remember File position in limited user mode (not that I want to but just sayin).
    Quote Quote  
  4. Then manually delete the .ini file via Windows Explorer.
    Quote Quote  
  5. Sorry where would I find it ? I looked under the installed dir & %(every user)%/AppData/Roaming/MPC-HC

    I did delete and re-do the registry settings earlier btw (based on another thread)
    Quote Quote  
  6. It should be in the install dir. You said you cannot toggle "Store settings in .ini file", i.e. it is greyed out. But is the box ticked or not ticked? If the box isn't ticked it means the .ini file doesn't exist.
    Quote Quote  
  7. Not in installed dir and it is not greyed out, they are just not enabled (not allowing me to change its value)

    Settings.ini box is not ticked

    Remember File position box is ticked but doesnt work
    Quote Quote  
  8. Not grayed out but also not allows you to change the value? That's strange. What version of MPC are you using?
    Quote Quote  
  9. latest, I am an MPC born-again - 1.7.10 (d911f14)
    Quote Quote  
  10. I don't understand this. That's not how it should work. Either the .ini option is grayed out or you have to be able to toggle it.

    To explain what I thought what the problem is: recently used files and file positions are stored in the settings. Often the .ini file is somewhere in c:\program files\... along with the mpc-hc.exe. That folder is usually not writable without admin rights so file positions aren't saved when using the .ini file. Solution would be to delete the .ini file and have MPC-HC use the registry instead. So I'd delete the .ini file and maybe all registry settings and then assume it should work. I don't know why this isn't working for you in the same way. Does not make sense to me. Or maybe you have multiple installations of MPC-HC? Something is preventing MPC-HC from writing to the registry? Hopefully someone else has an idea...
    Quote Quote  
  11. As expected, it works as designed on another computer with limited user.
    I will try another clean up.
    Quote Quote  
  12. Yes, delete everything.
    The install dir,
    AppData\Roaming\Media Player Classic

    Also read the following. Maybe the registry permissions got messed up for some reason.
    Quote Quote  
  13. Hi I forgot to do the Gabest, but searched registry for mpc-hc and removed all, then rebooted and installed when logged in as admin and all went well even with limited user after that. Thanks so much for your help...much obliged !
    Quote Quote  
  14. Hi, so since I had to go through the whole rigmarole of settings again, I tried checking 'save to ini' and it is greyed out even in admin mode.
    Is settings.ini even recommended or will it blotch things up ?
    Whats the best way to export the registry settings ?
    Quote Quote  
  15. Settings.ini is not recommended. It is mainly intended for portable use. Exporting settings should be as simple as exporting HKEY_CURRENT_USER\Software\MPC-HC using Windows' registry editor or in MPC-HC go Options>Miscellaneous>Export. (Even though I listed them I believe Gabest and MPC-HC64 are deprecated.)
    Quote Quote  
  16. Awesome, thanks ! I was looking for that option within MPC but some things are hard to find within the menu system. Cheers !
    Quote Quote  

Similar Threads