VideoHelp Forum

Try DVDFab and copy Ultra HD Blu-rays and DVDs! Or rip iTunes movies and music! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date
    Jan 2004
    Location
    United States
    Search Comp PM
    So before posting on the forum, I searched google and found various articles on the topic. Using Windows 7.

    I used powercfg /lastwake to determine which device brought the computer out of sleep and here's what I got:

    Code:
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 1
      Wake Source [0]
        Type: Device
        Instance Path: USB\ROOT_HUB20\4&36206eee&0
        Friendly Name:
        Description: USB Root Hub
        Manufacturer: (Standard USB Host Controller)
    I do have a USB 3.0 powered hub connected so I went to the Device Manager and in addition to everything else, I see 4 "USB Root Hub" items. I went to the power management tab of all 4 of those. They all have "allow the computer to turn off this device to save power" checked. And none of them have "allow this device to wake the computer" checked. Also, that option is grayed out so I couldn't check it if I wanted to.

    The instance path in the info above matches the device instance path of the second USB Root Hub in the device manager

    Any suggestions on what to do? Could the option to turn off the device to save power be what is causing it to come out of sleep mode?

    I've also attached a screenshot from the device manager of all my USB devices.
    Image Attached Thumbnails Click image for larger version

Name:	usb devices.PNG
Views:	133
Size:	21.5 KB
ID:	40823  

    Quote Quote  
  2. Member Budman1's Avatar
    Join Date
    Jul 2012
    Location
    NORTHWEST ILLINOIS, USA
    Search Comp PM
    There may be a problem with the usb 3.0 hub. I have had problems with USB 3.0 devices, including hubs, causing more than just waking up. You might try unplugging that hub and see what happens. Also other devices which normally wake a PC like mouse, keyboard and lan (disable).
    Quote Quote  
  3. Member awgie's Avatar
    Join Date
    Sep 2008
    Location
    Lanarkshire, Scotland
    Search PM
    The Roothub devices refer to your internal USB ports. So they shouldn't (in theory) have anything to do with your external powered hub.

    If you try (as Budman suggested) unplugging the external hub and it still does the same thing, then you know it's the internal port. There could be a glitch in the configuration settings.
    Try uninstalling and reinstalling the offending device.
    • In Device Manager, right click on the USB Root Hub and hit Uninstall.
    • Restart your computer and it should automatically detect the device and reinstall it.

    If you try unplugging the external hub and it fixes the problem, try connecting it to a different port and see if it wakes up again.
    If it does, check if the instance path in /lastwake changes.
    • If so, then you know it's the external hub, and your internal ports are allowing the wake signal to get through. Look in Device Manager for a "Generic USB Hub" (that's the external hub) and make sure that does not have "Allow this device to wake the computer" checked.
    • Try un/re-installing the Generic USB Hub device.
      1. With the external hub plugged in,
      2. In Device Manager, right click on the Generic USB Hub and hit Uninstall. If it gives you the option to also remove the drivers, click Yes.
      3. Unplug the hub from the computer while it is uninstalling the drivers (to prevent the computer from trying to re-install it before you have rebooted).
      4. Restart the computer.
      5. Plug the hub back in, and it should re-install it.
    If it doesn't wake with it in the second port, then try it in the first port again.
    • If that makes it wake up again, then again, it is the first port that is the problem, and you should try to un/re-install the USB Root Hub as I mentioned above.
    If you discover that it's the external hub that's waking it up, and reinstalling it in Device Manager doesn't solve it, try connecting a different powered hub to the computer and see if that also wakes it up. If it does not, then you've narrowed it down to a hardware problem with the first powered hub.
    Do or do not. There is no "try." - Yoda
    Quote Quote  
  4. Member
    Join Date
    Jan 2004
    Location
    United States
    Search Comp PM
    Thank you for the information. I think I may have solved the issue. Not sure how I missed it, but in the power settings, allow wake timers was set to enable instead of disable. I set to disable, and the computer was still asleep this morning. Will wait and see if it continues to work, otherwise I'll refer back to your post
    Quote Quote  



Similar Threads