VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. When I'm at Twitter, I always get the message "The media cannot be played." I have installed AC3, K-Lite Codec Pack, DivX, XVID, MPCHC, VLC Media Player, AviSynth 2.5, DVD Decrypter, FairUse Wizard 2, Gabest VobSub, Movie Maker, AVI-MPEG-ASF-WMV Splitter, Easy Video Splitter, MPEG4Modifier, MPEG Streamclip 1.2, VirtualDub 1.9.5 x64 (AMD64), and other joiners/splitters. I think I have all codecs installed.

    When I open the Twitter console, I get this:

    Cannot play media. No decoders for requested formats: video/mp4; codecs="avc1.42E01E mp4a.40.2", video/quicktime; codecs="avc1.42E01E mp4a.40.2", video/x-m4v; codecs="avc1.42E01E mp4a.40.2" 825032700172107776
    Content Security Policy: Directive ‘frame-src’ has been deprecated. Please use directive ‘child-src’ instead. (unknown)
    Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src https://twitter.com http://localhost:* http://localhost.twitter.com:* https://*.twitter.com https://*.twimg.com https://vine.co https://*.vine.co”). Source: onfocusin attribute on DIV element. 825032700172107776
    HTTP “Content-Type” of “application/x-mpegurl” is not supported. Load of media resource https://video.twimg.com/ext_tw_video/825032628646600704/pu/pl/PXVd6EwXPhaTM-rW.m3u8 failed. 825032700172107776
    Cannot play media. No decoders for requested formats: video/mp4; codecs="avc1.42E01E mp4a.40.2", application/x-mpegurl 825032700172107776

    I have Windows XP X64 installed.

    Can anyone help? What do I need to install, where do I get it?

    Thanks, Hart
    Quote Quote  
  2. Since the https://video.twimg.com/ext_tw_video/825032628646600704/pu/pl/PXVd6EwXPhaTM-rW.m3u8
    is the playlist for the video you want to watch, I can only assume the browser you are using doesn't play HLS streaming
    hence the ((HTTP “Content-Type” of “application/x-mpegurl” is not supported) message), at least, not from that source.
    The link itself, reports as a 'stream not found' when I try to play it. The link may be dead.

    EDIT: On a hunch I came back after checking your operating system. Not good news for you.
    I suspect you're using Firefox. Please read:

    https://support.mozilla.org/en-US/questions/1135096

    Most confusing is the Microsoft site which lists XP (with service pack 3) as acceptable system requirements
    http://www.microsoft.com/en-us/download/details.aspx?id=8279&e6b34bbe-475b-1abd-2c51-b...34bcdd6d2=True
    Perhaps you need .NET Framework, or you have the wrong Framework and Visual Studio combination (see link for details).
    I would definitely look to upgrade to at least Windows 7.
    Last edited by transporterfan; 28th Jan 2017 at 11:41.
    Quote Quote  
  3. Hi Transporterfan,

    Thanks for responding.

    Since I have the same problem playing all videos, I think it may be Firefox (which I forgot to mention that I use) that's causing the problem. IE x64 doesn't work either though. I installed QuickTime but it didn't help either. My daughter has a Mac laptop and they play on it. I'm surprised Twitter makes it so difficult to play videos on it's site.

    Thanks again, appreciate it.

    Hart
    Quote Quote  
  4. All may not be lost!
    Download and try installing the sdk (all components).
    Note::: it is IMPORTANT you delete any installed Microsoft Redistribution C++ 2010 packages. If you don't, the install will fail...every time.
    It will install its own C++ 2010 packages. After you (hopefully manage to) install the sdk, you can update them again to the latest version if you wish or need to.

    Good luck.
    Quote Quote  
  5. Should I uninstall Redistribution C++ 2010 and then install sdk from here: https://www.microsoft.com/en-us/download/details.aspx?id=13521

    Right now, I have installed Microsoft Visual C++ 2010 X86 Redistributable 10.0.40219 and
    ****************************************Microsoft Visual C++ 2010 X64 Redistributalbe 10.0.30319
    Plus I have C++ 2005 Redistributable
    *****************C++ 2005 Redistributable (X64)
    *****************C++ 2008 Redistributable X86 9.0.30729.4148
    *****************C++ 2008 Redistributable X86 9.0.21002
    *****************C++ 2013 Redistributable (X86) 12.0.30501

    Which ones should I remove?

    Oftentimes, I get things from MS for both X86 and X64 and I need them both.

    Hart
    Last edited by HartsVideo; 29th Jan 2017 at 00:42. Reason: I wasn't finished but accidentally clicked Save
    Quote Quote  
  6. Which ones should I remove?
    You can try All in One Runtimes
    Quote Quote  
  7. Sorry, been researching this all day.
    What I have discovered is this: don't bother with the sdk packages. I honestly don't think it will make a blind bit of difference.
    It works for some on later operating systems, and there is an alteration to the about:config settings which work for others.
    The fact is, it is the browser developers (slow to make changes) and Twitter (making changes without consideration for users) who are at fault.
    Because your operating system is effectively defunct it will prove impossible to upgrade to the latest (or later) Firefox or Explorer
    capable of processing HLS streaming. As far as I can see, your only hope is to use an older version of Google Chrome.
    It has to be an old version because (same as other developers) they have dropped support for XP and Vista.
    I am pretty sure Chrome Version 37.0.2062.120 will still work for you but to be safe use Version 36.0.1941.0 (Dev).
    You can get it here http://www.oldapps.com/google_chrome.php
    Sorry I can't be of more help. Hope it works out for you.
    Last edited by transporterfan; 29th Jan 2017 at 19:42.
    Quote Quote  
  8. Hi sysanin and transporterfan,

    Thanks for your help. I tried All in One Runtimes but it didn't help. I also tried to install Google Chrome 36.0.1941.0 (Dev) but I got a message that said that "No update is available" and it wouldn't install.

    I appreciate your thoughts.

    Hart
    Quote Quote  
  9. Don't you just love big corporate? See your PM.
    Quote Quote  
  10. Check your PM too.
    Quote Quote  



Similar Threads