VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Member
    Join Date
    Jan 2017
    Location
    Kentucky, USA
    Search Comp PM
    I don't know why I'm getting this.

    I'm just wanting to change the container and DAR (Display Aspect Ratio) of my file.

    I used Reaper to cut the video, edit the audio, and export (via FFmpeg) to the destination format I want which is for YouTube, MP4, H.264 (95% Quality?), AAC Stereo 384 kbps. The only problem is that Reaper does not preserve the DAR, so what should be displayed as SD (720x480), wide screen 16:9 is output as 4:3 aspect ratio. Additionally, the output option in Reaper is a combination QT/MOV/MP4, meaning you cannot select between these containers, so the output file is MOV when selecting H264/AAC.

    Essentially, I want Video To Video to pass through (Copy) the actual video and apply the correct DAR and change the container from MOV to MP4. I want the audio to pass though as well since it is already the correct codec/bitrate.

    I modified the conversion preset "MP4" to these settings:
    Video Options
    Video Codec = Copy
    Video Aspect = 16:9
    Video Bitrate = 4000

    Audio Options
    Audio Codec = Copy
    Audio Bitrate = 384

    Advanced
    Keep Aspect (letterbox) = No

    Please advise, thanks.
    I doubt that it is very import to change the container at all, but I do want to correct the DAR at least. Right now the video is 4:3 and looks vertically stretched.

    P.S. I'm using the portable version of Video To Video v2.9
    Quote Quote  
  2. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    That error indicates that Video To Video is passing a bad command line to FFmpeg. It should be easy enough to do it yourself at a command prompt.

    Code:
    <path to/>ffmpeg -i myfile.mov -c copy -aspect 16:9 myfile.mp4
    Quote Quote  
  3. Member
    Join Date
    Jan 2017
    Location
    Kentucky, USA
    Search Comp PM
    Ok, thanks you all.

    I'll give it a try, though, I've never used FFmpeg from the Command Prompt before.

    Reaper utilizes the FFmpeg libraries by copying the DLLs into its install folder and uses VLC for playback. I've been using Video To Video since a GUI is preferable to me and there was a portable version.

    I tried WinFF, but it altered the actual video aspect ratio and the resultant file was about 1/3 the original. I don't know what else it compressed to reduce the file size so much. The resulting aspect ratio was 704x386 which was not what I had expected. It definitely looks blurrier than the original MOV file.

    I found some directions for using command line FFmpeg here:
    http://www.wikihow.com/Install-FFmpeg-on-Windows
    And, there are some warnings regarding the manual Registry edits that need to occur. I don't think my boss would be too happy if I bricked my work laptop.

    Thank you for your assistance.
    Maybe I should be in the Newbie forum area, but this seemed like the appropriate place for this question.
    Quote Quote  
  4. Member
    Join Date
    Aug 2010
    Location
    San Francisco, California
    Search PM
    You got bad advice. There's no need to edit the Registy to install and use FFmpeg. Just download it here and run from a Command Prompt.
    Quote Quote  
  5. Member
    Join Date
    Jan 2017
    Location
    Kentucky, USA
    Search Comp PM
    Thank you all a lot!

    I used WinFF and created a new preset using the parameters you gave me. I had a lot of files to convert, so I thought using WinFF was easier than learning to batch process the files from the Command Prompt considering that the file location was pretty lengthy.

    Creating my own preset in WinFF wasn't quite as straightforward as I expected, but I was able to get it. These are the steps in case anyone stumbling upon this thread wants to know.

    Edit > Presets...
    From the Presets dialog box I selected Category=MPEG-4, Preset=MP4 Widescreen
    Changed the Preset Name & Preset Label to new, custom names
    Changed the Preset Command Line Parameters to: -f mp4 -vcodec copy -aspect 16:9 -acodec copy
    Left the Output File Extension the same and the Category the same and clicked Add/Update > OK, then Save

    Once the custom preset was made I was able to Add all my files and they were converted in no time.

    There was this warning in Yellow in the Command Prompt window that pops up as the files are converted:
    Overriding aspect ratio with stream copy may produce invalid files
    Although, the files play just fine in VLC.

    Again, I really appreciate your help!
    Quote Quote  
  6. Member
    Join Date
    Feb 2012
    Location
    Ireland
    Search Comp PM
    Hi guys, was trying to download a video on the Express.

    https://www.express.co.uk/news/uk/938824/Germany-news-duisburg-state-of-emergency-figh...-riot-machetes

    I was using this code:

    Code:
    ffmpeg -re -i https://secure.brightcove.com/services/mobile/streaming/index/rendition.m3u8?assetId=5760345216001&secure=true&pubId=2540076170001&videoId=5760343636001 -c copy -bsf:a aac_adtstoasc video.mp4
    Usually works on other sites but I keep getting the warning:

    At least one output file must be specified

    Anyone know what I'm doing wrong?
    Quote Quote  
  7. Use quotation marks around your url.

    Code:
    ffmpeg -re -i "https://secure.brightcove.com/services/mobile/streaming/index/rendition.m3u8?assetId=5760345216001&secure=true&pubId=2540076170001&videoId=5760343636001" -c copy -bsf:a aac_adtstoasc video.mp4
    Quote Quote  
  8. Member
    Join Date
    Feb 2012
    Location
    Ireland
    Search Comp PM
    Originally Posted by videobruger View Post
    Use quotation marks around your url.

    Code:
    ffmpeg -re -i "https://secure.brightcove.com/services/mobile/streaming/index/rendition.m3u8?assetId=5760345216001&secure=true&pubId=2540076170001&videoId=5760343636001" -c copy -bsf:a aac_adtstoasc video.mp4
    That works, much appreciated!
    Quote Quote  



Similar Threads