VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. I have an access to a paid video content site (sports instruction, not indecent stuff). Videos are mp4, and in the past I have downloaded some of them and they play fine on my desktop. Recently, after a long break, I downloaded some videos and they won't play (I tried several players). So I went to a couple of videos I had downloaded last year (and still had on my desktop). Sure enough, the ones I downloaded last year are just fine. The ones I downloaded recently don't work. Of course, they play fine online.

    It seems that site owners added some kind of security feature to the videos so that if users downloaded them they don't work. What could it be?
    Gspot has very limited information on the file.

    I have uploaded 2 files: one that plays fine, and the other that doesn't. They are supposed to be the same video. They are slightly different in size.
    Image Attached Files
    Quote Quote  
  2. the one that will not play.mp4 plays fine for me using Potplayer
    Quote Quote  
  3. Thank you. That was quick! I guess my players are outdated? They both seem to have same codecs, but different container information.

    Edit: the problem video seems to freeze and glitch a lot.
    Last edited by minidanas; 29th Dec 2016 at 02:07.
    Quote Quote  
  4. Plays fine using MPC-HC. No freezing or glitches.
    Quote Quote  
  5. If you try MPC-HC and it still is not satisfactory to you, you can reencode the files to mp4 again with handbrake and they will be less demanding on your computer resources. This is the one that will not play.mp4 re-encoded, it will be less demanding on your computer resources. It was re-encoded preset fast crf 17:
    Image Attached Files
    Quote Quote  
  6. Remux.
    Image Attached Files
    Last edited by ponens; 29th Dec 2016 at 14:22.
    Quote Quote  
  7. ezcaper, my MPC-HC can't play the original. The handbrake-d version that you offered does play in MPC-HC, but it's not very responsive, like when I move the slider or jump back or forward, it takes about half a second before it resumes play. The same thing happens when I play the original using Potplayer.

    ponens, the remuxed version that you sent plays great. I know that remuxing is something about removing or changing metadata that is attached to the video. what should I remove or change? Will I be taking it out of the container and put it back together using a different iso/handler utility
    Quote Quote  
  8. Why bother? Wouldn't it be easier to update your MPC-HC/LAV? Make sure it is using the latest LAV Splitter (Play>Filters>LAV Splitter (Source), latest version is 0.69.0).
    Quote Quote  
  9. Originally Posted by minidanas View Post
    Will I be taking it out of the container and put it back together using a different iso/handler utility
    Process/remux the file:

    "one that will not play.mp4"

    using mkvmerge GUI.

    Then, take resulting output file, "one that will not play.mkv", and remux with ffmpeg back to mp4:
    Code:
    ffmpeg -i "one that will not play.mkv" -vcodec copy -acodec copy "one that will not play_remuxed.mp4"
    Something about the audio bitstream prevents ffmpeg from working on the original input file directly, but it works if remuxed through mkvmerge GUI first. There is likely an easier way.
    Quote Quote  
  10. Originally Posted by sneaker View Post
    Why bother? Wouldn't it be easier to update your MPC-HC/LAV? Make sure it is using the latest LAV Splitter (Play>Filters>LAV Splitter (Source), latest version is 0.69.0).
    my MPC-HC is 1.6.8.7417 version from 2013. Updating that will probably solve it.

    Thanks to everyone. You guys updated my knowledge of digital videos by a few years.
    Quote Quote  
  11. Originally Posted by sneaker View Post
    Why bother?
    One reason to bother is that the iso container header of the subject file is in a funky non-standard format. Various info tools don't properly report header data. Windows OS won't show a preview frame in windows explorer.

    Originally Posted by sneaker View Post
    Wouldn't it be easier to update your MPC-HC/LAV?
    It would be easier, but then you'd still have the funky non-standard mp4 file. But the file could always be "fixed" later if some playback solution is sufficient.
    Quote Quote  



Similar Threads