VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 16 of 16
Thread
  1. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    Solved
    Solution in this reply.

    Long time no post.

    I would say I'm intermediate in the video editing and Capture department.
    Debugmode Frameserver and I had a lot of good times on my old Windows XP system; as well as my old Canopus DV Capture Box.

    But... now...

    I'm running Windows 7 64bit Professional
    SATA HD (Plenty of space)
    With the Diamond VC500 capture device (just got it yesterday).

    I have the driver installed.
    I did not install the other software (I think Virtualdub should work fine).

    I have Virtualdub 1.10.4 Virtual Dub 32-bit installed
    I have HuffYUV 32-bit installed (followed the correct installation instructions)

    I have a simple stereo VCR.
    Composit Video, Stereo Output

    My issue is this:

    I'm not sure how to get the settings right in Virtualdub capture.

    The audio either:

    Increases in pitch over time (to compensate, I assume) or
    Goes out of sync over time

    Not sure what settings to use for the USB capture hardware and Virtualdub to get just basic results.

    What Framerate should I capture in? (I'm assuming 29.97 (NTSC-M))
    What audio settings (I'm assuming 48.8KHz, 16bit)

    Am I missing some settings?
    I've tried standard def (ala DV settings 768x480 I think), and the smaller 360x240.

    Getting a lot of dropped frames, inserted frames, etc. Audio sounds fine, just out of synch over time (like 5 minutes).

    I have an Intel i5-3330 at 3.00Ghz, 8GB RAM

    Here's a screen shot of what I'm seeing in Virtualdub:
    Last edited by Tolwyn; 8th Sep 2016 at 11:35. Reason: Solved.
    Quote Quote  
  2. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    Last test I did...

    The video finishes WAAAY before the audio catches up.

    My guess is the sync issues is video framerate; with dropped frames not being made up for.
    OR

    ?
    Quote Quote  
  3. Formerly 'vaporeon800' Brad's Avatar
    Join Date
    Apr 2001
    Location
    Vancouver, Canada
    Search PM
    You said plenty of HDD space but the screenshot shows 0 bytes free...?

    Do you still get 1000s of drops if you use the Test Video Capture option?
    Quote Quote  
  4. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    I have over half a terabyte free on Drive D: and 300GB free on Drive C:. Capturing to Drive D:.
    Not sure why Virtualdub is reporting 0 Bytes.

    I haven't tried Test Video Capture yet. I will do that soon and report back.
    Quote Quote  
  5. Do not let VirtualDub play the audio while capturing: turn Audio -> Enable Audio Playback off.

    Do not compress the audio while capturing.

    Go to Capture -> Timing and turn off resync mode (set it to Do not resync...). Also try the other options there.

    Capture NTSC video at 29.97 fps interlaced, 720x480 or 704x480.
    Quote Quote  
  6. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    Well, much better results. With seemingly 0 (zero) dropped frames around 1.5 hours of capture.

    The audio still does DRIFT however, where the video gets about .5 seconds ahead of the audio (the audio lags behind).

    I'm truly assuming I don't need to install any of the software that shipped with the VC500, and using Virtualdub with its built-in Capture, if I can find the magic settings should work.

    I'm used to using Scenalizer with Canopus and my DV Firewire camera, but this is just analogue VCR capture stuff. Still, though... I feel I'm getting closer; but if anyone has some more suggestions?

    Here's some more screenshots:



    Quote Quote  
  7. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    Good lord. What is the point of test capture?
    I have a 400GB file on my computer.
    Quote Quote  
  8. Try enabling Sync Audio to Video...
    Quote Quote  
  9. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    Hmmm. One post suggesting I DO sync, another suggesting I DO NOT sync.

    Gah!

    BUT I will say this...

    If I tuncate the audio file by maybe a half of a second in an audio editing program and then use that WAV file as the audio source, it stays in sync throughout the capture.

    So... the audio is consistently inconsistent by about .3 seconds or so.

    Is there a way or a setting I should try to compensate for that?
    Quote Quote  
  10. Originally Posted by Tolwyn View Post
    Hmmm. One post suggesting I DO sync, another suggesting I DO NOT sync.
    The point is to try different things until you find what works.

    Originally Posted by Tolwyn View Post
    If I tuncate the audio file by maybe a half of a second in an audio editing program and then use that WAV file as the audio source, it stays in sync throughout the capture.
    Then all you have to do is set the audio delay (a negative delay is an advance). I'm not sure how to do that in the capture module but you could always remux with the audio delay in VirtualDub's editor. Audio -> Interleaving -> Audio skew correction -> Delay audio by X ms. Or just remember to adjust the audio delay when you do your final edit.
    Quote Quote  
  11. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    I have it working close to perfect now. The setting of the Audio offset in the Interleving menu does the trick. Mixed results actually "interleving" the audio, though. Over time, the audio still does drift, so it's best if I do smaller chunks of video (like 30 minutes each).

    Thanks for the help.
    Any knowledge or idea why the drift occurs?
    Quote Quote  
  12. I stopped using VirtualDub because sync never seemed consistent even with good hardware/setup. I use AmarecTV and it's never shown me a sync issue for the dozens of captures I've used with it, and will pull those captures into VirtualDub if additional editing is needed.
    Quote Quote  
  13. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    Update.
    Using the Daimond Capture USB thing.

    When capturing, I set the thing to sync to audio by adjusting video framerate; making sure it added frames and deleted frames.

    The drift is almost non-existent; however, with LONG clips, you should cut it up into ~20 minute clips and adjust audio timing in MS.

    Works fine for me.
    Quote Quote  
  14. Do you manually break up the. Clips? I.e. by starting / stopping the source and recording - or does software handle it?
    Quote Quote  
  15. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    I manually break up the clips by using the markers and Edit - Crop to Selection; and then only working on that small section; I seem to be able to mitigate the drift that way; now, overall, the drift still happens across the full recording; but in only working on 20 minutes at a time, seems to be better.



    Not sure if the inserting and removing frames is helping. The key for me was changing the video frame rate to keep the audio in sync.

    Audio needs its sample rate to be fixed; while video frames can change a bit to keep up or fall behind without an impact on the overall recording (to me).

    Stretching audio (either direction) didn't work for me with good results.
    Quote Quote  
  16. Member
    Join Date
    Oct 2003
    Location
    United States
    Search Comp PM
    It's worth repeating on installing HuffyUV 32bit on a 64bit system:

    Run these commands to install BOTH 32bit and 64bit on the same Windows 64bit machine:

    32bit huffyuv:
    rundll32 C:\Windows\SysWOW64\setupapi.dll,InstallHinfSectio n DefaultInstall 0 C:\huffyuv-2.1.1\huffyuv.inf


    64bit huffyuv:
    rundll32 C:\Windows\System32\setupapi.dll,InstallHinfSectio n DefaultInstall 0 C:\huffyuv64\huffyuv.inf

    Ensure paths point to correct huffyuv version. Now both VirtualDub (32bit) and Premiere CS6 (64bit) works for me.

    Hope that helps someone.
    Quote Quote  



Similar Threads