VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. I got some clips I can only decode with mencoder (due to it's vfw interface), when I use:
    Code:
    mencoder -lavdopts threads=8 -really-quiet -of rawvideo -o - -ovc raw -noskip -vf scale,format=i420,scale,format=444p -nosub -nosound -mc 0 "F:\TESTCL~1\test.avi" | ffplay -an -sn -pixel_format yuv444p -video_size 640x352 -f rawvideo -
    there is some color space mixup and I end with blue smurf like humans.

    Problem seems to be with the 444p handling, because when I use:
    Code:
    mencoder -lavdopts threads=8 -really-quiet -of rawvideo -o - -ovc raw -noskip -vf scale,format=i420 -nosub -nosound -mc 0 "test.avi" | ffplay -an -sn -pixel_format yuv420p -video_size 640x352 -f rawvideo -
    colors are as they are supposed to.

    Since I want/need 444p output the question is:
    Does anyone know what pixel_format do I need to use in ffplay to handle the output or mencoder properly?

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  2. Okay, got it the y&v planes got swapped somewhere and using:
    Code:
    mencoder -lavdopts threads=8 -really-quiet -of rawvideo -o - -ovc raw -noskip -vf scale,format=i420,scale,format=444p -nosub -nosound -mc 0 "F:\TESTCL~1\test.avi" | ffplay -an -sn -pixel_format yuv444p -video_size 640x352 -f rawvideo -vf swapuv -
    fixes the issue.

    So new question is:
    Is this a bug in mencoder or ffplay/ffmpeg ?

    Cu Selur
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  3. Originally Posted by Selur View Post
    So new question is:
    Is this a bug in mencoder or ffplay/ffmpeg ?
    be or le? (this is first thing coming to me) - use yuv4mpegpipe in future - less problems
    Quote Quote  
  4. be or le?
    should be le.
    use yuv4mpegpipe in future
    How do you output yuv4mpegpipe using mencoder? (I know of the '-vo'-option in mplayer, but no clue how to use yuv4mpegpipe in mencoder)
    users currently on my ignore list: deadrats, Stears555
    Quote Quote  
  5. Originally Posted by Selur View Post
    be or le?
    should be le.
    use yuv4mpegpipe in future
    How do you output yuv4mpegpipe using mencoder? (I know of the '-vo'-option in mplayer, but no clue how to use yuv4mpegpipe in mencoder)
    Sorry haven't use mencoder for few years... blindly assumed that yuv4mpegpipe is implemented...
    Quote Quote  



Similar Threads