VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    May 2016
    Location
    India
    Search Comp PM
    I'm using this below MeGui command line to convert my vido files to h264 mp4:

    program --level 4.1 --bluray-compat --preset veryslow --tune film --pass 2 --bitrate 6000 --stats ".stats" --open-gop --b-adapt 1 --ref 4 --slices 4 --vbv-bufsize 14000 --vbv-maxrate 14000 --subme 9 --no-fast-pskip --tff --colorprim bt709 --transfer bt709 --colormatrix bt709 --pulldown 32 --min-keyint 25 --sar 1:1 --output "output" "input"

    But I'm having problems in making the GOP settings to work & coz of that I'm having trouble in seeking/skipping the converted video file. So i would really appreciate if someone could give me the FFMPEG version of the above command line of MeGui, coz I'm quite baffled with FFmpeg's script. Please help.
    Quote Quote  
  2. Example bellow (you need to modify and maybe add few things if you insist to use some settings):

    Code:
    @SET x264opts="crf=20:vbv_maxrate=62500:vbv_bufsize=62500:level=4.1:keyint=250:cabac=1:threads=auto:sliced_threads=0:slices=-1:no_psnr=1:no_ssim=1:bluray_compat=1:open-gop=0:pic_struct=1:aud=1:nal_hrd=vbr:force_cfr=1:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=off"
    @ffmpeg.exe -y -hide_banner -loglevel 8 -stats -i "%1" -c:v libx264 -preset veryslow -tune film -profile:v high -level:v 4.1 -x264opts %x264opts% -x264-params %x264opts% -c:a copy -movflags faststart -y -f mp4 "%~n1_.mp4"
    Not sure about your settings, crf is better than 2 pass, keyint_min=25 for ?
    Quote Quote  
  3. Originally Posted by yukukuhi View Post
    I'm using this below MeGui command line to convert my vido files to h264 mp4:

    program --level 4.1 --bluray-compat --preset veryslow --tune film --pass 2 --bitrate 6000 --stats ".stats" --open-gop --b-adapt 1 --ref 4 --slices 4 --vbv-bufsize 14000 --vbv-maxrate 14000 --subme 9 --no-fast-pskip --tff --colorprim bt709 --transfer bt709 --colormatrix bt709 --pulldown 32 --min-keyint 25 --sar 1:1 --output "output" "input"

    But I'm having problems in making the GOP settings to work & coz of that I'm having trouble in seeking/skipping the converted video file. So i would really appreciate if someone could give me the FFMPEG version of the above command line of MeGui, coz I'm quite baffled with FFmpeg's script. Please help.
    Even if you translated those to ffmpeg libx264 it would give you problems. Many of your settings are conflicting or don't make sense

    --pulldown 32 isn't supported by some muxers , that could be the cause of skipping. Why would you need 3:2 pulldown anyways when native progressive is supported by BD, unlesss this is for SD encode ? And if it's for SD encode - you wouldn't flag it with bt709.

    If this is for BD compatibility (why else would you use --bluray-compat?) , you still need to specify --keyint (max keyframe interval) it's not inclued in --bluray-compat switch. For "24p" a 1 sec GOP is --keyint 24 , so you wouldn't use --min-keyint 25. But you are using 2sec GOP settings (VBV <15,000) so you're allowed to use --keyint 48
    Quote Quote  
  4. Member
    Join Date
    May 2016
    Location
    India
    Search Comp PM
    ok forget the above command


    please give a ffmpeg script for this below command


    program --level 4.1 --preset veryslow --tune film --pass 2 --bitrate 6000 --stats ".stats" --bframes 3 --b-adapt 1 --b-pyramid strict --ref 4 --weightp 1 --vbv-bufsize 14500 --vbv-maxrate 14000 --subme 9 --psy-rd 1.0:0.00 --no-fast-pskip --tff --pulldown 32 --sar 1:1 --output "output" "input"
    Quote Quote  
  5. Originally Posted by yukukuhi View Post
    ok forget the above command


    please give a ffmpeg script for this below command


    program --level 4.1 --preset veryslow --tune film --pass 2 --bitrate 6000 --stats ".stats" --bframes 3 --b-adapt 1 --b-pyramid strict --ref 4 --weightp 1 --vbv-bufsize 14500 --vbv-maxrate 14000 --subme 9 --psy-rd 1.0:0.00 --no-fast-pskip --tff --pulldown 32 --sar 1:1 --output "output" "input"


    If you used those new settings and still have problems, translating them to ffmpeg won't help. libx264 is based on the same library

    Very likely the --pulldown 32 is your problem. For progressive video, you should be removing the pulldown before encoding, not adding it back

    And the most common problem for device seeking is a very long GOP interval . lower the --keyint value
    Quote Quote  



Similar Threads