VideoHelp Forum

+ Reply to Thread
Results 1 to 15 of 15
Thread
  1. before
    http://i.imgur.com/sd61qpa.jpg
    after
    http://i.imgur.com/BwZcc8H.jpg

    one is 480p version and the other is up scaled 720p version
    Last edited by zanzar; 16th Feb 2016 at 10:14.
    Quote Quote  
  2. The two links/pictures are identical. And it looks like a simple resize from 480p to 1080p.
    Quote Quote  
  3. Originally Posted by jagabo View Post
    The two links/pictures are identical. And it looks like a simple resize from 480p to 1080p.
    sorry i am just retarded i uploaded the same picture

    this is the second picture
    http://i.imgur.com/BwZcc8H.jpg
    Quote Quote  
  4. Without having the actual source it's hard to say for sure but try something like:

    Code:
    WhateverSource()
    FastLineDarkenMod()
    aWarpSharp(depth=3)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1280, fheight=720)
    aWarpSharp(depth=3)
    Sharpen(0.2)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1920, fheight=1080)
    aWarpSharp(depth=3)
    Sharpen(0.2)
    Quote Quote  
  5. Originally Posted by jagabo View Post
    Without having the actual source it's hard to say for sure but try something like:

    Code:
    WhateverSource()
    FastLineDarkenMod()
    aWarpSharp(depth=3)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1280, fheight=720)
    aWarpSharp(depth=3)
    Sharpen(0.2)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1920, fheight=1080)
    aWarpSharp(depth=3)
    Sharpen(0.2)
    is up scaling it to 1080p is necessary ? a found out its looks the same and just weights
    should i just delete the nnedi 1080p line?

    thanks by the way
    Quote Quote  
  6. Well the images were 1920x1080 so I upscaled to the same size. If you want 1280x720 remove the last three lines. If you do that you might want to increase the remaining aWarpSharp and Sharpen values a bit too.
    Quote Quote  
  7. Originally Posted by jagabo View Post
    Well the images were 1920x1080 so I upscaled to the same size. If you want 1280x720 remove the last three lines. If you do that you might want to increase the remaining aWarpSharp and Sharpen values a bit too.
    http://i.imgur.com/9khferJ.jpg

    http://i.imgur.com/mAbxfD1.jpg

    do you think to add anything else or is this "perfect" balance?

    huge improvement tough
    Quote Quote  
  8. Oh, assuming your source is rec.601 (almost all SD is rec.601) you should convert to rec.709 (almost all HD is rec.709) with ColorMatrix(mode="rec.601->rec.709").

    You might look into applying some deringing to reduce the noise around the dark lines. If your source is DVD use Mpeg2Source("source.d2v", CPU=6) or CPU2="ooooxx"). The former applies deringing and deblocking, the latter only deringing. Mpeg2Source's deblocking is a little too strong for some video but should be fine with anime.

    Sharpening the chroma more than the luma usually helps too. Change the last aWarpSharps to MergeChroma(aWarpSharp(depth=3), aWarpSharp(depth=10)).
    Quote Quote  
  9. Originally Posted by jagabo View Post
    Oh, assuming your source is rec.601 (almost all SD is rec.601) you should convert to rec.709 (almost all HD is rec.709) with ColorMatrix(mode="rec.601->rec.709").

    You might look into applying some deringing to reduce the noise around the dark lines. If your source is DVD use Mpeg2Source("source.d2v", CPU=6) or CPU2="ooooxx"). The former applies deringing and deblocking, the latter only deringing. Mpeg2Source's deblocking is a little too strong for some video but should be fine with anime.

    Sharpening the chroma more than the luma usually helps too. Change the last aWarpSharps to MergeChroma(aWarpSharp(depth=3), aWarpSharp(depth=10)).
    LWLibavVideoSource("d:\4.mp4", fpsnum=30000, fpsden=1001)
    ConvertToYV12(matrix="rec709")
    FastLineDarkenMod()
    aWarpSharp(depth=3)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1280, fheight=720)
    aWarpSharp(depth=10)
    Sharpen(0.4)


    http://i.imgur.com/VZqpHzQ.png
    http://i.imgur.com/85EZgrZ.jpg

    what do you think go with this script?
    Quote Quote  
  10. Formerly 'vaporeon800' Brad's Avatar
    Join Date
    Apr 2001
    Location
    Vancouver, Canada
    Search PM
    The ConvertToYV12 line in your script is either doing nothing, or only doing half of what you think it's doing unless the source filter is outputting RGB. And it definitely shouldn't be.
    Quote Quote  
  11. Originally Posted by vaporeon800 View Post
    The ConvertToYV12 line in your script is either doing nothing, or only doing half of what you think it's doing unless the source filter is outputting RGB. And it definitely shouldn't be.
    so use "ColorMatrix(mode="rec.601->rec.709) instead?"
    Quote Quote  
  12. Originally Posted by zanzar View Post
    Originally Posted by vaporeon800 View Post
    The ConvertToYV12 line in your script is either doing nothing, or only doing half of what you think it's doing unless the source filter is outputting RGB. And it definitely shouldn't be.
    so use "ColorMatrix(mode="rec.601->rec.709) instead?"
    Yes, notice how the laptop has changed color from red to orange in the images in post #7. That's what you're trying to fix.
    Quote Quote  
  13. Originally Posted by jagabo View Post
    Originally Posted by zanzar View Post
    Originally Posted by vaporeon800 View Post
    The ConvertToYV12 line in your script is either doing nothing, or only doing half of what you think it's doing unless the source filter is outputting RGB. And it definitely shouldn't be.
    so use "ColorMatrix(mode="rec.601->rec.709) instead?"
    Yes, notice how the laptop has changed color from red to orange in the images in post #7. That's what you're trying to fix.
    thank you that fixed that
    the result is great
    http://i.imgur.com/BZXSqqX.jpg
    http://i.imgur.com/fWYTq02.jpg

    LWLibavVideoSource("d:\4.mp4", fpsnum=30000, fpsden=1001)
    ColorMatrix(mode="Rec.601->Rec.709")
    FastLineDarkenMod()
    aWarpSharp(depth=3)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1280, fheight=720)
    aWarpSharp(depth=10)
    Sharpen(0.4)

    i am new to this stuff but the end result is soundless can you explain in simple terms how to rip it from the other video and place it into the new one
    also i came across a problem that at some points with the video(not the current one , other file i tried) and some times a flickering green screen appeared what can cause that?

    thanks!
    Quote Quote  
  14. LWLibavVideoSource() only gives you the video. If you want audio too you need to use LWLibavAudioSource() to get it:

    Code:
    v = LWLibavVideoSource("filename.ext")
    a = LWLibavAudioSource("filename.ext")
    AudioDub(a,v) # join them togehter into one stream
    But I usually mux the original audio with the new video after encoding.

    The flickering green screen is probably a decoding error. If you remove all the filtering do you still get it?
    Quote Quote  
  15. Originally Posted by jagabo View Post
    LWLibavVideoSource() only gives you the video. If you want audio too you need to use LWLibavAudioSource() to get it:

    Code:
    v = LWLibavVideoSource("filename.ext")
    a = LWLibavAudioSource("filename.ext")
    AudioDub(a,v) # join them togehter into one stream
    But I usually mux the original audio with the new video after encoding.

    The flickering green screen is probably a decoding error. If you remove all the filtering do you still get it?

    v = LWLibavVideoSource("d:\4.mp4", fpsnum=30000, fpsden=1001)
    a = LWLibavAudioSource("d:\4.mp4")
    AudioDub(a,v)
    ColorMatrix(mode="Rec.601->Rec.709")
    FastLineDarkenMod()
    aWarpSharp(depth=3)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1280, fheight=720)
    aWarpSharp(depth=10)
    Sharpen(0.4)

    here how it looks it flikers i variant of colors also happened to a certain videos not all although they are all mp4

    http://imgur.com/a/OMgmx
    Last edited by zanzar; 24th Feb 2016 at 11:20.
    Quote Quote  



Similar Threads