VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Hello and sorry in advance if I'm asking in the wrong place.

    Up until recently I used a 5.1 surround sound system, but since it started to go bad, I switched to a 2.1 system (Logiteck Z323). It should be configured correctly both from Control Panel -> Sound -> Speakers -> Configure (2.0 Stereo), and from the Realtek HD Audio Manager (the drivers).

    My problem is when I play files (.mkv in this case) with 5.1 audio streams in MPC-HC, some audio channel is not correctly downmixed apparently, because in some cases I don't hear voices (I only notice this because I watch with subtitles). In a file that has both 5.1 and 2.1/2.0 audio streams, switching to 2.1/2.0 I can hear the missing voices, but on files that only has 5.1 this is a problem. An example - watching Hannibal, during scenes when they are talking on the phone, I hear their voices when the camera is on the person talking, but if the other party starts talking (and the scene doesn't move to them) - silence, and I know they are talking from the subtitles and the flow of conversation. Some music/sound effects are also lost (if hearing impaired subtitles are to be believed).

    I've come across this problem from all kinds of encodes, so I'm positive it's not a bad encode problem.

    I use AC3 filter for audio decoding, have it set up on 2.1 Surround under Output Format, tried switching to ffdshow Audio and LAV Audio with all kinds of setting tweaking (both on my own and from looking on the net), didn't fix it.

    And this is the most strange thing - I tried going to MPC-HC Audio Switcher and enabled Custom Channel Mapping and tried all kinds of variations that should have made the lost channel play, but still couldn't hear it (and the voices/effects with it).

    Any help would be greatly appreciated.

    Windows 7 x64.
    Last edited by asw3; 13th Feb 2016 at 15:39.
    Quote Quote  
  2. MPCHC has it's own audio downmixer/switcher. Maybe you have that switched on and misconfigured? View -> Options -> Internal Filters -> Audio Switcher. I suspect the rear channels aren't being included in the downmix.

    This post contains an AC3 test file you might find useful:
    https://forum.videohelp.com/threads/369908-5-1-Test-setup-file?p=2371488&viewfull=1#post2371488
    Quote Quote  
  3. MPC's downmixer was turned off when I first had this problem, I turned it on for testing purposes but had no results, and turned it back off.

    That 11sec file seems to be playing correctly. I tried going to some old files that I know also had the missing channel problem and it seems that they work fine as well.

    Hannibal might indeed be a bad encode though, since it's not playing there, though I can't be sure.

    Seems some of my settings tweaking must have worked (or it only works partially?).

    I guess if I come across a new file that definitively shows bad downmixing, I'll revive the thread, for I hope it's fixed/bad encode.

    Thanks for your post.
    Quote Quote  
  4. You could load the audio into Audacity. You'll probably need to download ffmpeg for Audacity to import it.
    http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown
    When it imports into Audacity, it should import using the default 5.1ch layout for wave files (thinking about it, with ffmpeg "installed" you should be able to import the audio into Audacity by opening an MKV rather than having to extract it first). The layout should be visually obvious. From the top down you'll have front left, front right, center, LFE, rear left and rear right. If the channel layout looks any different there's probably something wrong with the source file. Different audio formats use different layouts, but they should always be imported using the 5.1ch wave file layout.

    You could also try ffdshow's volume filter. Enable it and you'll be able to visually see the output level for each channel. You might have to increase their volumes to see the levels, but you should be able to visually tell if the correct audio is in the correct channel. You can mute/solo them individually in order to listen. If ffdshow's mixer filter is before the volume filter (you can re-order the filters by dragging and dropping) make sure it's disabled or the volume filter will display the downmixed audio instead of the decoded source.
    Quote Quote  



Similar Threads