VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 1 of 1
Thread
  1. Member
    Join Date
    Dec 2015
    Location
    USA, Illinois
    Search PM
    Hi, for some time I've been having problems getting video recorded in mp4 format on a Moto X smartphone to re-encode properly via Handbrake (partly to cut the size down a bit through software re-encoding, but also because I'm pretty sure I'd already found that some, at least, of the native video from the Moto X would not play back on the blu-ray player in question) to reliably work correctly on this LG BD590 component blu-ray player, which definitely can play some mp4 1080p content fine.

    I suspect my problem is bitrate, as the total bitrate on some of the videos exceeds 10,000kpbs, and I'd read that, at least when playing off of DVD-R blanks, many blu-ray players cannot play video exceeding 10,000kpbs or so (let's call that 10Mbps to shorten it, I guess).

    My original tests were of these same videos on DVD-Rs, so when I'd read the above on another videohelp post from years ago, I though "oh great, I'll just buy some blu-ray BD-R discs, and use the burner I've already got that supports those and put the same videos on them". Unfortunately, this alone at least did not entirely (or maybe at all) fix the problems I was having. Many 1080p videos from the Moto X, encoded in Handbrake with some fairly basic settings, do not play properly on the LG.

    I get reports (this is for someone else, on an offsite blu-ray that I only occasionally have access to) that the main symptom is the video playback slows down and the audio cuts out, maybe sometimes they won't play at all, but I know at least that one problem is slowed playback and no audio.

    To me, without much experience with this, I can see how that might be caused by something being too high of a bitrate for the player hardware to handle.

    It seems like maybe videos that are well under 10Mbps play okay, but I would expect to be able to get much higher playback, especially off of a BD-R disc. Can anyone help me out with some other things to check out? I don't want to noticeably reduce the quality of the videos, as I fear I might if I try to force all of the Mbps down to under 9 or something (which *might* do the trick, I guess), and I also want to avoid burning too many other useless BD-Rs.

    I believe this is the full command line I was using on Handbrake to do these encodes:

    "c:\Program Files\Handbrake\HandBrakeCLI.exe" -i input.mp4 -t 1 --angle 1 -c 1 -o output.mp4 -f mp4 --decomb -w 1920 --crop 0:0:0:0 --loose-anamorphic --modulus 2 -e x264 -q 20 --cfr --rate 29.97 -a 1,1 -E av_aac,copy:ac3 -6 dpl2,none -R Auto,Auto -B 160,0 -D 0,0 --gain 0,0 --audio-fallback ac3 --encoder-level="4.1" --encoder-profile=high --verbose=1
    One weird thing I noticed about these (that may've been some kind of Handbrake default I guess) is that I have two audio streams, AAC and AC-3, I don't know if that could be contributing or not (I'd doubt it, based on the total % of the whole bitrate those are).

    Also, I'd heard that having too high of an encoder level might cause problems on some players, but this is 4.1 high, which I gather is pretty well supported.

    Could it be the constant frame rate (--cfr --rate 29.97) that I thought at one time I really needed for this LG player to work correctly?

    Thanks for reading and I appreciate hearing from anyone with some useful suggestions.

    See attached txt file for MediaInfo output from one of the files that was reported as not properly playing.
    Image Attached Files
    Quote Quote  



Similar Threads