VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Hello,

    VLC is a great software, but there's one behaviour I don't understand:
    When creating mkv-Files from DVB-S2 HD recordings, while preserving the subtitles, sometimes the resulting mkv-Files don't start playing video at zero seconds, but instead only after some seconds. MPlayer doesn't show this behaviour.

    I have attached a sample file.

    My questions:
    1. Can you reproduced this behaviour with the sample file?
    2. Why does VLC act this way?
    3. What can I do to get VLC to play this immediately?

    Kind regards!
    Image Attached Files
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Yep. Same problem here. I'm not sure if you can change any setting to avoid this.

    Have you searched or asked in https://forum.videolan.org/ ?
    Quote Quote  
  3. Thanks for your reply and testing, Baldrick!

    I haven't searched/asked there yet, but I'll do.
    Quote Quote  
  4. I have VLC 1.0.5 and it won't play a ts video file if there is a srt subtitle file in the same folder. Remove the subtitle file and then the video will play just fine. In these cases I just use Media Player Classic Home Cinema.
    Quote Quote  
  5. Originally Posted by jimdagys View Post
    I have VLC 1.0.5 and it won't play a ts video file if there is a srt subtitle file in the same folder.
    I also noticed this annoying behaviour. But this is not the case in my request.
    Quote Quote  
  6. MPCHC shows the same 3 second delay. I used MkvToolnix-gui to remux the audio and video (no subs) from the original MKV into a new MKV file and that new file shows the same 3 second delay in VLC, but not MPCHC.

    I demuxed the h264, ac3, idx, and sub tracks with MkvExtractGui, then muxed them back together with MkvToolnix-gui. Both VLC and MPCHC played the new video without the 3 second delay. But the subs were 3 seconds behind the video. So I muxed the elementary streams again, adding a -3000 ms delay to the subtitles. VLC now plays the video right away with the subs at the right time.
    Last edited by jagabo; 29th Dec 2015 at 17:50.
    Quote Quote  
  7. Originally Posted by jagabo View Post
    MPCHC shows the same 3 second delay. I used MkvToolnix-gui to remux the audio and video (no subs) from the original MKV into a new MKV file and that new file shows the same 3 second delay in VLC, but not MPCHC.

    I demuxed the h264, ac3, vob, and sub tracks with MkvExtractGui, then muxed them back together with MkvToolnix-gui. Both VLC and MPCHC played the new video without the 3 second delay. But the subs were 3 seconds behind the video. So I muxed the elementary streams again, adding a -3000 ms delay to the subtitles. VLC now plays the video right away with the subs at the right time.
    Thanks for this workaround. Problem solved for me.
    Quote Quote  
  8. Member
    Join Date
    Dec 2005
    Location
    Canada
    Search Comp PM
    Just for my own information, is it normal for this type of sub to have what looks like overlapping time stamps?

    Click image for larger version

Name:	Clipboard01.jpg
Views:	135
Size:	53.0 KB
ID:	35023
    Quote Quote  
  9. Originally Posted by sambat View Post
    Just for my own information, is it normal for this type of sub to have what looks like overlapping time stamps?
    Usually I use ffmpeg to directly produce a .mkv-Container out of the .ts-file I get from recording digital satellite television (DVB-S/DVB-S2).
    For subtitles i use the "-scodec dvdsub" option ffmpeg provides. It transforms the DVB bitmap subtitles to DVD bitmap subtitles.
    In other cases I can only use teletext subtitles.

    In the specific recording this topic is about I recorded the french channel W9 HD and tried my usual ffmpeg-approach. While there was no error message the result had an issue: The subtitles weren't at the right position of the HD picture, instead the subtitles were at a position in the upper left part of the picture, where I would expect them if the frame had an SDTV resolution.
    Because of this bug(?) I had to use Project X for subtitles this time and not ffmpeg's "-scodec dvdsub" option.

    This surely isn't an answer to your question, but I though this information could be relevant. I haven't checked whether subtitles overlap when using ffmpeg's "-scodec dvdsub" option.
    Quote Quote  



Similar Threads