VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 13 of 13
Thread
  1. Banned
    Join Date
    Oct 2015
    Location
    United States
    Search PM
    Is there a way to adjust the color output of a file using MPC. It does not look right on the tv. Some movies I can switch to Movie Mode and it does not look as bad. Coloring involves too much orange/yellow. Not dark enough in right places. I know this is only pertinent to MPC, b/c when playing with Win 10 Movies and Tv player, I don't have to adjust any color settings. It looks perfect on Dynamic display of tv with color set at 50. Even if I use Movie mode which is not as bright with MPC I still have to turn down the color on tv to 30 range to get rid of the orange/yellow brightness on everything. It is not just this file.

    Any suggestions? Thanks.
    Quote Quote  
  2. Start by trying the different output devices, View -> Options -> Playback -> Output... Change the proc amp settings, View -> Options -> Miscellaneous. Go to your graphics card's video proc amp setting and adjust them.
    Quote Quote  
  3. Banned
    Join Date
    Oct 2015
    Location
    United States
    Search PM
    Originally Posted by jagabo View Post
    Start by trying the different output devices, View -> Options -> Playback -> Output... Change the proc amp settings, View -> Options -> Miscellaneous. Go to your graphics card's video proc amp setting and adjust them.
    I will try all of those tomorrow, going to bed. I just don't see how the graphics card settings is going to be a factor. Here is a screen shot the one on the left is using Win 10 and the right is MPC. I would assume both players use the same graphics card.
    Image Attached Thumbnails Click image for larger version

Name:	Untitled3.png
Views:	584
Size:	2.07 MB
ID:	34637  

    Quote Quote  
  4. you can also try this- while the video is playing, right click on the MPC screen, then select "render settings" and from there you can select "color management" as well as "output range" and that works with black levels more
    want to see some true 3d clips, custom figures, some hardcore music and other crap?? Check out my youtube page www.youtube.com/mazinz2
    Quote Quote  
  5. Originally Posted by mlmiller707 View Post
    Originally Posted by jagabo View Post
    Start by trying the different output devices, View -> Options -> Playback -> Output... Change the proc amp settings, View -> Options -> Miscellaneous. Go to your graphics card's video proc amp setting and adjust them.
    I will try all of those tomorrow, going to bed. I just don't see how the graphics card settings is going to be a factor. Here is a screen shot the one on the left is using Win 10 and the right is MPC. I would assume both players use the same graphics card.
    I don't use Win10 so I don't know if that'd make it more likely, but video cards generally have settings for adjusting only video (Windows and programs aren't effected) and it's quite possible those settings could effect one player and not another.

    The MPC-HC picture does look pretty bad. There's brightness and colour controls etc under the Miscellaneous tab in MPC-HC's options. If they don't work, then the video card has probably taken control.

    I assume WMP would be using the Media Foundation for some formats and MPC-HC would be using DirectShow. I wonder if that'd be a reason why the video card drivers might effect one player but not the other. Anyone know?
    Quote Quote  
  6. Banned
    Join Date
    Oct 2015
    Location
    United States
    Search PM
    Originally Posted by hello_hello View Post
    Originally Posted by mlmiller707 View Post
    Originally Posted by jagabo View Post
    Start by trying the different output devices, View -> Options -> Playback -> Output... Change the proc amp settings, View -> Options -> Miscellaneous. Go to your graphics card's video proc amp setting and adjust them.
    I will try all of those tomorrow, going to bed. I just don't see how the graphics card settings is going to be a factor. Here is a screen shot the one on the left is using Win 10 and the right is MPC. I would assume both players use the same graphics card.
    I don't use Win10 so I don't know if that'd make it more likely, but video cards generally have settings for adjusting only video (Windows and programs aren't effected) and it's quite possible those settings could effect one player and not another.

    The MPC-HC picture does look pretty bad. There's brightness and colour controls etc under the Miscellaneous tab in MPC-HC's options. If they don't work, then the video card has probably taken control.

    I assume WMP would be using the Media Foundation for some formats and MPC-HC would be using DirectShow. I wonder if that'd be a reason why the video card drivers might effect one player but not the other. Anyone know?
    The other player is something that comes with Win 10, not WMP. It's label is Movies and TV on a right click of open with also listed is WMP and MPC

    Also that screen shot is from the desktop; it looks even worse once it gets to the tv via hdmi. I do have 2 video cards. I only requested one from Dell to provide me the capability for dual monitors. The tv is a bit brighter when you view anything like just desktop background image. Nowhere near the distortion of MPC. I still don't know why I needed 2 video cards. The multiple display options are located within the Intel 520 not the added AMD. Dell rep said AMD was for better graphics and dual monitor options but also said the latter about the Intel. I can try disabling the AMD. English is not Dell rep's strong point.
    Last edited by mlmiller707; 27th Nov 2015 at 04:15.
    Quote Quote  
  7. Originally Posted by mlmiller707 View Post
    I just don't see how the graphics card settings is going to be a factor.
    There are different ways for video to get to the graphics card depending on how the player uses it. For example, one player may convert the YUV video to RGB before giving it to the graphics card, another might give the YUV video to the graphics card and let the graphics card do the conversion (what you see on the screen is always RGB). Different processing may be applied to the two situations.

    Note that there will be two proc amp settings in the graphics card's setup applet, one for the desktop and another for video. The video proc amp only effects video, the desktop proc amp may effect both video and other programs. While you're there, also make sure that all the auto enhancements like contrast, skin tone, saturation, etc. are disabled. All they do is screw up video.
    Last edited by jagabo; 27th Nov 2015 at 07:37.
    Quote Quote  
  8. Banned
    Join Date
    Oct 2015
    Location
    United States
    Search PM
    Originally Posted by jagabo View Post
    Originally Posted by mlmiller707 View Post
    I just don't see how the graphics card settings is going to be a factor.
    There are different ways for video to get to the graphics card depending on how the player uses it. For example, one player may convert the YUV video to RGB before giving it to the graphics card, another might give the YUV video to the graphics card and let the graphics card do the conversion (what you see on the screen is always RGB). Different processing may be applied to the two situations.

    Note that there will be two proc amp settings in the graphics card's setup applet, one for the desktop and another for video. The video proc amp only effects video, the desktop proc amp may effect both video and other programs. While you're there, also make sure that all the auto enhancements like contrast, skin tone, saturation, etc. are disabled. All they do is screw up video.
    Major improvement. Hardly noticeable difference now. I am not sure what "proc" means. I am just going to leave the rest of the settings alone. I changed "enhanced video rendering" to "system default". Never changed it during install. I also adjusted settings in Misc tab, although I did not notice any change even with all tabs all the way to right so I just reset them and the file stayed the same. The one thing I did change that was set as default was in Intel Display was "YCbCr" which came preset to Disabled. I could not tell any difference with it dis/enabled either.

    Nice work.
    Image Attached Thumbnails Click image for larger version

Name:	Untitled4.png
Views:	643
Size:	2.63 MB
ID:	34641  

    Quote Quote  
  9. proc = processing
    Quote Quote  
  10. If the MPC-HC controls aren't working it probably means the video card has control. For Nvidia, there's two options such as "Nvidia settings" and "player settings". There's not necessarily anything wrong with using the video card settings but it seems these days they come with lots of image "enhancing" stuff enabled by default. "System" default" mightn't disable everything completely, but you can probably change or disable individual settings yourself.
    Quote Quote  
  11. Banned
    Join Date
    Oct 2015
    Location
    United States
    Search PM
    Originally Posted by hello_hello View Post
    If the MPC-HC controls aren't working it probably means the video card has control. For Nvidia, there's two options such as "Nvidia settings" and "player settings". There's not necessarily anything wrong with using the video card settings but it seems these days they come with lots of image "enhancing" stuff enabled by default. "System" default" mightn't disable everything completely, but you can probably change or disable individual settings yourself.
    Well it looks good regardless. Here are the same parts of the film as before. Did you mean system default in MPC? or in my Intel 520. The AMD only gives performance and 3d options. Not really anything to change in that card. Anybody know of a good universal remote? I have been looking for apps for iPOd. I just cant imagine that will be that effective.
    Image Attached Thumbnails Click image for larger version

Name:	Untitled5.png
Views:	311
Size:	2.85 MB
ID:	34644  

    Quote Quote  
  12. I changed "enhanced video rendering" to "system default".
    I might have misunderstood your earlier post. I thought you were referring to a "system default" setting for your video card which fixed the quality, but did you mean you changed the renderer used by MPC-HC from "enhanced video renderer" to "system default"? And you did disable all the imagine enhancing stuff in the video card's settings?

    If you disabled the image enhancing stuff and it fixed the picture I guess that was the problem. If changing "enhanced video rendering" to "system default" refers to changing the renderer used by MP-HC then chances are it didn't make a difference because the "enhanced video renderer" probably is the system default renderer for Win10. When you install MPC-HC some of it's default settings might change according to which version of Windows you're running. I'd imagine MPC-HC defaults to using the "enhanced video renderer" for Win7 or newer as it's the preferred renderer.
    Quote Quote  
  13. Banned
    Join Date
    Oct 2015
    Location
    United States
    Search PM
    If changing "enhanced video rendering" to "system default" refers to changing the renderer used by MP-HC then chances are it didn't make a difference because the "enhanced video renderer" probably is the system default renderer for Win10.
    That is exactly what I did, by other posters instructions. That was the difference. I did find the image enhancement tab in the Intel. It was never touched, and all are enabled. It would seem logical that it would effect all programs. But anyways. Golden rule in the tech world. If aint broken, then don't fix it. It's fixed due to what you may have thought did not effect it.
    Last edited by mlmiller707; 28th Nov 2015 at 14:17.
    Quote Quote  



Similar Threads