VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Hey guys! As the title suggests, I'm having problems with the way video files look when using my macs. Up until a few months ago I didn't even know there WAS a problem, then I got an iphone 6 plus and started recording 1080p 60fps video and the video just looked choppy and bad on my computer yet silky smooth on my phone. A few days ago I accidentally opened a file using quicktime and wow, everything was smooth! There was far less blockieness in color gradients, I always thought that was just part of the video file itself but apparently VLC introduced it.

    Comparison screenshot is below, you can see on the vlc part of the frame all the distortion in the sky, how the colors are super blocky. On the quicktime version it's much more natural looking. I also am able to play 1080p 60fps video smoothly using quicktime or itunes whereas on vlc it's choppy and often times gets very blocky looking.

    Click image for larger version

Name:	Screen Shot 2015-07-23 at 11.52.32 PM.png
Views:	211
Size:	877.9 KB
ID:	32783

    Notes that may help. I already tried the whole "skip loop filter decoding" and set to "all", I've turned on and off "hurry up", "drop late frames" and various other easily googlable tips on how to help video run better.

    My system,
    Macbook pro 13"
    2.4 ghtz intel core i5
    8 gb ram
    SSD

    I don't see how the issue could have anything to do with my laptop not being fast enough, like I said, it runs smoothly and correctly when using quicktime. I just like the playlist function of VLC and I'm wondering what I can do to perhaps fix this? Thanks tech guys!
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Yep. That doesn't look good.

    Does it happen with all video files?
    Latest VLC Media Player?

    Or try a mplayer based media player like smplayer.
    Quote Quote  
  3. Disabling the (deblocking) loop filter is the cause of those blocky artifacts.

    Make sure the Use Hardware YUV -> RGB Conversion option is selected. And make sure the video post processing filter is disabled.
    Quote Quote  
  4. @Baldrick
    I know. lol. It's pretty consistent across the board, I have a bunch of music videos in .mp4 form (along with that man of steel trailer I had ripped from youtube.) Also I believe the .mov files from iphone 6plus in 60fps that had similar issues. Latest version of VLC of course. Haven't heard of those other media players, do they support playlists?

    @jagabo
    Ah ha, taking that part on and off made a difference in a big way with artifacts so thanks very much for that! The framerate issue is still there. For things like the music videos it's not really an issue but for home videos at 60fps from iphone, it's still more studdered than running it from itunes or quicktime. It's not a huge difference but enough to be noticeable. I'd personally be totally fine running video playlists through itunes but I'm usually playing them on a second screen and unfortunately itunes forces your other screen to go black if you enter full screen (and from my internet searches, there's not a way to fix that)

    Quick follow up questions if you have time. "Hardware YUV -> RGB Conversion option" where do I find this? I looked through settings, do you know which section it's under is selected. And "Video post processing filter" where is this box? And does "drop late frames" and "skip frames" cause this framerate issue? Thanks so much guys for the help!!
    Quote Quote  
  5. Originally Posted by Ilikebreadsticks View Post
    "Hardware YUV -> RGB Conversion option" where do I find this?
    Maybe it's not in the Mac version? In the Preferences dialog of the Windows version:

    Click image for larger version

Name:	hyuv.png
Views:	120
Size:	63.0 KB
ID:	32812


    Originally Posted by Ilikebreadsticks View Post
    And "Video post processing filter" where is this box?
    I couldn't find that setting in the Preference dialog. On the Video menu (Windows version again):

    Click image for larger version

Name:	vpp.png
Views:	447
Size:	23.5 KB
ID:	32813

    Originally Posted by Ilikebreadsticks View Post
    "And does "drop late frames" and "skip frames" cause this framerate issue?
    Those settings will cause the player to skip decoding (and display) of frames when a new frame isn't available in time. Late Frames probably has more to do with network streams. Skip Frames is used when decoding of the source is too slow to deliver the desired frame rate. When VLC sees that it can't decode frames fast enough (every 1/60 second in the case of 60p video) it can skip the docoding (and the display) of some frames to catch up. When it skips a frame the last frame is displayed again. That causes the jerkiness you are seeing.
    Quote Quote  



Similar Threads