VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or try DVDFab and copy, convert or make Blu-rays and DVDs! :)
+ Reply to Thread
Results 1 to 12 of 12
Thread
  1. I am trying to make a PAL DVD but the final result is showing interlacing scan lines when played on my DVD player. I have read other threads about people having the same problem when trying to encode a PAL dvd, but no solutions. This problem seems to exist when dealing with PAL specifically. Does anything in my script contradict with PAL in any way, maybe? (I have uploaded a short clip a couple of posts below.) Please help

    Source: 50p 1920x1080

    Avisynth script:

    AviSource("final2.avi")
    ConvertToYV12()
    Spline36Resize(720,576)
    Blur(0,0.5)
    ColorMatrix(mode="Rec.709->Rec.601",clamp=0)
    AssumeTFF().SeparateFields().SelectEvery(4, 0, 3).Weave()

    HCencoder:

    Bitrate - Avg 4000, Max 9000
    Profile - Best
    Aspect ration 16:9
    Autogop - 15
    Interlacing - auto detect, TFF
    Chroma Downsampling - progressive
    Matrix - manono3
    Last edited by kieranvyas; 25th Jun 2015 at 07:56.
    Quote Quote  
  2. Interlacing - interlaced, TFF
    Quote Quote  
  3. Originally Posted by jagabo View Post
    Interlacing - interlaced, TFF
    Tried that, exactly the same results unfortunately
    Quote Quote  
  4. Upload a short sample of your M2V.
    Quote Quote  
  5. Originally Posted by jagabo View Post
    Upload a short sample of your M2V.
    here is a clip! Thank you
    Image Attached Files
    Quote Quote  
  6. That m2v is encoded progressive.
    Quote Quote  
  7. Originally Posted by jagabo View Post
    That m2v is encoded progressive.
    Really! I'm using that avisynth script and those HCencoder settings, how can it be progressive? When I drop the clip into Premiere Pro it tells me it is 25.00i UFF? What am I doing wrong? Thank you!
    Quote Quote  
  8. Go back and reencode as interlaced TFF again.
    Quote Quote  
  9. Member
    Join Date
    Oct 2013
    Location
    Germany
    Search Comp PM
    Your sample is incorrectly flagged ("Frametype progressive" is true, which it should not) and also it was encoded using zig-zag scan type which is entirely incorrect for interlaced encoding.


    In HCenc, Settings 1:

    interlacing options (this determines the scan type and the "Frametype progressive" flag):

    • Interlaced
    • TFF


    Chroma downsampling shouldn't have any effect since you are feeding YV12 rather than YUY2.
    Quote Quote  
  10. Originally Posted by jagabo View Post
    Go back and reencode as interlaced TFF again.
    Interlacing options - Interlaced - TFF. Same thing!
    Image Attached Files
    Quote Quote  
  11. That one is properly encoded interlaced. It should play properly after authoring to DVD -- assuming you don't reencode it progressive.
    Quote Quote  
  12. Originally Posted by jagabo View Post
    That one is properly encoded interlaced. It should play properly after authoring to DVD -- assuming you don't reencode it progressive.
    Amazing, it works! Thank you so much
    Quote Quote  



Similar Threads