VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. I have a strange problem. I need 1080p 50fps for a project I'm working on. The show only airs in SD. So I'm comparing a 1080i upscaled by my Sky box to an SD S-Video recording from my Sky box which I then upscaled myself to see which offers the best quality. What do you think gives the best quality after conversion: 1080i box upscale or SD upscale?

    The problem is that when McTemperalDenoise is used on the SD source it's causing the background to jump up and down such as looking at the logo on the wall at 10 secs. When I used DegrainMedian instead I do NOT get this problem. I've used McTemporalDenoise many times on SD videos (NOT to upscale however) and I've never seen this problem before. Does McTemporalDenoise not like upscaling?

    Here are some short samples:

    Source Clips

    1080i Upscale Sky Source: https://drive.google.com/open?id=0B7SrUmaXghlPQUp2RkR5aG5SMG8&authuser=0
    SD Clip Source: https://drive.google.com/open?id=0B7SrUmaXghlPanFYN3RGb09hdWM&authuser=0

    Conversions

    SD to 1080p McTemp & QTGMC Medium: https://drive.google.com/open?id=0B7SrUmaXghlPSDJtQnNsN2laZUk&authuser=0
    SD to 1080p DegrainMed QTGMC Medium: https://drive.google.com/open?id=0B7SrUmaXghlPWmxtajhiLTkwN1U&authuser=0
    1080i Upscale Source to DegrainMed Yadif: https://drive.google.com/file/d/0B7SrUmaXghlPZ2NsR2tWem1BbUk/view?usp=sharing

    I watched all the above clips on a media player attached to my TV.

    Here's my script for SD to 1080p McTemporalDenoise & QTGMC Medium:

    Code:
    setmtmode(5,6)
    DGSource("E:\Video.dgi")
    setmtmode(2)
    
    McTemporalDenoise(settings="medium", interlaced=true)
    AssumeTFF() 
    QTGMC(Preset="Medium")
    Tweak(Bright=20, Sat=0.7, Cont=1.0, Hue=0.0, Coring=False)
    MergeChroma(awarpsharp2(depth=25))
    Crop(56,2,-60,-4)
    AddBorders(56,0,60,0, $000000)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1920, fheight=1080)
    The Tweak and MergeChroma is needed to fix colour and brightness issues that recording via S-video to Elgato gives. Tried without those lines and also tried without upscaling to 1080 and the pixel issue is still there. It seems McTemporalDenoise doesn't like S-Video captures!?

    To convert the 1080i source I just used this script - does anyone have anything better - please note I can't use MultiThreaded in HD sources as it always crashes:

    Code:
    AssumeTFF() 
    DeGrainMedian(limitY=2, limitUV=3, mode=1, interlaced=true)
    Yadif(mode=1, order=1)
    Crop(150,0,-150,-0)
    AddBorders(150,0,150,0, $000000)
    Last edited by MrBiggles; 9th Jun 2015 at 08:05.
    Quote Quote  
  2. Try QTGMC() before MCTD(interlaced=false).
    Quote Quote  
  3. Member
    Join Date
    May 2014
    Location
    Memphis TN, US
    Search PM
    Originally Posted by MrBiggles View Post
    The bottom two links in bold are the same video.
    - My sister Ann's brother
    Quote Quote  
  4. Sorry. I've fixed the link.
    Quote Quote  
  5. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Compared to the SD clip your color gets totally messed up during the upscale.

    Also, by the look of it your AR in the SD video is off, the video seems horizontally squeezed.
    Last edited by newpball; 9th Jun 2015 at 10:14.
    Quote Quote  
  6. Don't know what you're talking about mate the colour is "corrected" not messed up in the upscale. The video had too much sat and was too dark so all I did was correct that so it was like how it aired on TV.

    Obviously the Aspect Ratio in the SD source is messed up. That's just how the Elgato captures S-Video. I could have ticked the "stretch standard definition" in the Elgato settings but which would make it widescreen but it would still look messed up although not as bad. Doesn't matter anyway as the aspect ratio is fixed in the conversion which I would need to do anyway to fix the compression artifacts in the broadcast.

    Originally Posted by jagabo View Post
    Try QTGMC() before MCTD(interlaced=false).
    Thanks. That worked. By the way what is that artifact called? Is it vertical jitter?

    Any thoughts to why that artifact happens when it wasn't in the source. It only happens when using McTD before QTGMC. I thought it might have been the s-video causing it so I converted the 1080i to 576i then re-encoded the 576i to 576i but with McTemperalDenoise before QTGMC and the same artifact happened. So it wasn't s-video causing it.

    By the way is there a way to fix that artifact and keep the video interlaced? I tried to re-interlace at the end of the script and it caused the script to slow down from 6fps to 0.2fps!
    Quote Quote  
  7. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Originally Posted by MrBiggles View Post
    Don't know what you're talking about mate the colour is "corrected" not messed up in the upscale.
    No kidding.

    I don't know what you did but all you need to do for a start is to correct the setup in the SD video.

    Left is yours, right is the AR and setup corrected SD capture:

    Click image for larger version

Name:	pedestal.png
Views:	377
Size:	926.7 KB
ID:	32129

    I don't use the Elgato but I would suggest you double check if you use the correct options when your capture, both for the setup (IRE) and AR because clearly what you got was a botched capture.

    Just helping here!

    Last edited by newpball; 9th Jun 2015 at 11:46.
    Quote Quote  
  8. Originally Posted by MrBiggles View Post
    By the way what is that artifact called? Is it vertical jitter?
    It's essentially a bob artifact.

    Originally Posted by MrBiggles View Post
    Any thoughts to why that artifact happens when it wasn't in the source.
    MCTD in interlaced mode has to deinterlace, filter, and re-interlace. It's accentuating the bobbing of the original interlaced video.
    Quote Quote  
  9. MCTD in interlaced=true mode doesn't do it properly. It just uses separatefields() if you look at the code
    Quote Quote  
  10. Originally Posted by newpball View Post
    Originally Posted by MrBiggles View Post
    Don't know what you're talking about mate the colour is "corrected" not messed up in the upscale.
    No kidding.

    I don't know what you did but all you need to do for a start is to correct the setup in the SD video.

    Left is yours, right is the AR and setup corrected SD capture:

    Image
    [Attachment 32129 - Click to enlarge]


    I don't use the Elgato but I would suggest you double check if you use the correct options when your capture, both for the setup (IRE) and AR.

    Just helping here!

    Do you have a script so I can see what you're talking about that you want me to do? Because after my script the video is in the correct aspect ratio and it looks in proportion so I don't know what problem you're referring to.

    @Jagabo. Here my script:

    Code:
    setmtmode(5,6)
    DGSource("E:\Video.dgi")
    setmtmode(2)
    AssumeTFF() 
    QTGMC(Preset="Super Fast")
    Tweak(Bright=20, Sat=0.7, Cont=1.0, Hue=0.0, Coring=False)
    MergeChroma(awarpsharp2(depth=25))
    McTemporalDenoise(settings="low", interlaced=false)
    Crop(60,0,-60,-0)
    AddBorders(60,0,60,0, $000000)
    nnedi3_rpow2(2, cshift="Spline36Resize", fwidth=1920, fheight=1080)
    Encoded to CRF 16. I'm looking at my encoding on a media player connected to my TV set to 1080p 50hz. Note that I'm using MCTD(Low) and QTGMC(Super Fast). For some reason using Super Fast is the only QTGMC speed that gives a smooth framerate between the following time: 10 sec - 15 secs. Using any other lower QTGMC speed (even "Slower") with MCTD(Low) gives a choppy framerate in that portion. Also using QTMC Super Fast with MCTD(Med) also gives a choppy framerate - you must use "MCTD(Low)".

    Is that not completely weird. Can anyone explain why a higher speed inferior quality QTGMC setting gives a better quality of playback than the slower settings?
    Quote Quote  
  11. Member
    Join Date
    Oct 2013
    Location
    Germany
    Search Comp PM
    I suspect it is not related to QTGMC or any other part of the script but simply a bandwidth problem during playback on your media player (bitrate too high). Are you using a USB thumb drive, a hard disk drive or LAN? Did you specify any VBV and maxrate settings? For playback on hardware devices you really should.
    Quote Quote  
  12. It's not a bandwidth problem. If it were it would affect all the videos. I used the exact same script in all the videos. The only things changed were QTGMC speed and MCTD speed.
    Quote Quote  
  13. Member
    Join Date
    Oct 2013
    Location
    Germany
    Search Comp PM
    Well, just because it worked for other videos doesn't disprove it's not a bandwidth problem since CRF encoding is HIGHLY variable in bitrate.
    Different QTGMC and MCTD settings will result in lower or higher bitrates and peaks with CRF encoding.

    But anyways, I suppose you have played the same files on a computer and got the same result?
    Quote Quote  
  14. Originally Posted by MrBiggles View Post
    Is that not completely weird. Can anyone explain why a higher speed inferior quality QTGMC setting gives a better quality of playback than the slower settings?

    Maybe because QTGMC uses Yadif in the 2 fastest presets and NNEDI3 in the slower presets. Many people don't realize that QTGMC is not a deinterlacer in and of itself, rather it is a processing script, that uses other base deinterlacers and then adds other processing, such as denoising and sharpening, to the process.

    I personally don't use QTGMC for this very reason, if I wanted the video to be denoised and sharpened i would just do it myself.
    Quote Quote  



Similar Threads