VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Hello VideoHelp forums,

    I'm new to the forums and I need some help with the MPC-HC player.
    So as the titles suggests, the video MPC produces is unnaturally dark which is visually unappealing to watch and at times not visible at all. So I downloaded VLC just to see if it was the players fault or somehow my PC, VLC outputs a much better picture or atleast a "normal" render. The MPC image looks completely off and I've tried many things to fix it, there were some people with a similar problem online but not many fixes, I've tried tinkering with the output renderer but the even the ones that fix the problem, create a new problem like not allow subtitles. I have used MPC for a long time now, and is installed on many different PC's at home, but this is the only one so far with this problem.
    If anyone knows the problem, or how to fix it, that would be amazing, since MPC is my preferred media player.

    OS: Windows 8.1 Pro x64
    MPC-HC (64bit) 1.7.8

    I have also taken a screenshot of both video players side by side showing the exact same image on a video which clearly shows how MPC's image is bearly even visible.
    Click image for larger version

Name:	VLCvsMPC-HC.png
Views:	1113
Size:	219.7 KB
ID:	31881
    Quote Quote  
  2. Video uses limited range luminance levels whereas PCs use full range luminance levels. In order for video to display correctly on a PC monitor the levels need to be expanded to fill range. If they're not, the picture can look a bit brighter or washed out.

    I suspect the levels are being expanded correctly by MPC-HC but not by VLC and therefore MPC-HC is getting it right but your monitor needs adjusting.

    If you're using the EVR Custom Presenter renderer with MPC-HC (check in it's options) you should be able to right click on the video and select "Renderer Settings/Output Range". If it's not greyed out (only available with some renderers) and it's set to 0-255, it should be correct. If it is, changing it to 15-235 will probably make it look like VLC, but it's technically wrong.

    That's my best guess. I don't know if VLC has an option to expand the levels as I don't use it. I have a Nvidia video card but they all have a control panel and all should have an option for setting video levels. Some expand video levels by default, some don't. Normally if the player is expanding the levels the video won't expand them again so they don't get expanded twice.

    The nvidia control panel looks something like this for setting the video levels,but all vido cards should have something similar. How is the player and/or video card set?

    Click image for larger version

Name:	nvidia.gif
Views:	7728
Size:	115.1 KB
ID:	31885
    Quote Quote  
  3. Originally Posted by hello_hello View Post
    Video uses limited range luminance levels whereas PCs use full range luminance levels. In order for video to display correctly on a PC monitor the levels need to be expanded to fill range. If they're not, the picture can look a bit brighter or washed out.

    I suspect the levels are being expanded correctly by MPC-HC but not by VLC and therefore MPC-HC is getting it right but your monitor needs adjusting.

    If you're using the EVR Custom Presenter renderer with MPC-HC (check in it's options) you should be able to right click on the video and select "Renderer Settings/Output Range". If it's not greyed out (only available with some renderers) and it's set to 0-255, it should be correct. If it is, changing it to 15-235 will probably make it look like VLC, but it's technically wrong.

    That's my best guess. I don't know if VLC has an option to expand the levels as I don't use it. I have a Nvidia video card but they all have a control panel and all should have an option for setting video levels. Some expand video levels by default, some don't. Normally if the player is expanding the levels the video won't expand them again so they don't get expanded twice.

    The nvidia control panel looks something like this for setting the video levels,but all vido cards should have something similar. How is the player and/or video card set?

    Image
    [Attachment 31885 - Click to enlarge]
    Thank you very much, hello_hello!
    The problem was even worse than that but you made me realise that MPC is being affected by the graphics driver!
    Although the input range was wrong as you said it still didn't make much change until I saw that there was alot of colour correction being done by the video graphics which was really distorting the brightness, gamma and contrast. After setting colour correction and the input range to "Application Settings" and selected 0-255 in MPC-HC, the image looks really good and not as washed out as VLC.

    So thank you again, my problem is now solved after a very long time of having to use VLC




    *If anyone is having a similar problem and is using integrated Intel HD Graphics, I'll gladly put up screenshots of what I changed to fix it*
    Quote Quote  
  4. Get a levels calibration video, disable the player's video proc amp, and adjust the graphics card's video proc amp to get the levels right on the monitor.

    https://forum.videohelp.com/threads/353338-Avisynth-ColorYUV-Gamma-is-doubling-the-enco...=1#post2220162
    https://forum.videohelp.com/threads/326496-file-in-Virtualdub-has-strange-colors-when-o...=1#post2022085
    Quote Quote  
  5. Originally Posted by IntolerableEvil View Post
    Thank you very much, hello_hello!
    The problem was even worse than that but you made me realise that MPC is being affected by the graphics driver!
    Although the input range was wrong as you said it still didn't make much change until I saw that there was alot of colour correction being done by the video graphics which was really distorting the brightness, gamma and contrast. After setting colour correction and the input range to "Application Settings" and selected 0-255 in MPC-HC, the image looks really good and not as washed out as VLC.

    So thank you again, my problem is now solved after a very long time of having to use VLC
    I've never quite understood why the video card driver settings effect some players and not others others. I guess I owe VLC an apology because it does seem to expand the levels by default (I couldn't find a setting to set the levels so I reset it's preferences).

    Why the video card is oblivious to VLC, I'm not sure, but changing the levels setting in the video control panel has no effect on it. Maybe it's something to do with the renderer used. If I set the video card to use it's own settings it stops MPC-HC's own brightness, contrast and colour controls from working but VLC's continue to work. For me it's like the video card has no idea VLC is displaying video.

    Anyway, I'm glad you got it fixed.
    Quote Quote  
  6. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Originally Posted by hello_hello View Post
    Originally Posted by IntolerableEvil View Post
    Thank you very much, hello_hello!
    The problem was even worse than that but you made me realise that MPC is being affected by the graphics driver!
    Although the input range was wrong as you said it still didn't make much change until I saw that there was alot of colour correction being done by the video graphics which was really distorting the brightness, gamma and contrast. After setting colour correction and the input range to "Application Settings" and selected 0-255 in MPC-HC, the image looks really good and not as washed out as VLC.

    So thank you again, my problem is now solved after a very long time of having to use VLC
    I've never quite understood why the video card driver settings effect some players and not others others. I guess I owe VLC an apology because it does seem to expand the levels by default (I couldn't find a setting to set the levels so I reset it's preferences).

    Why the video card is oblivious to VLC, I'm not sure, but changing the levels setting in the video control panel has no effect on it. Maybe it's something to do with the renderer used. If I set the video card to use it's own settings it stops MPC-HC's own brightness, contrast and colour controls from working but VLC's continue to work. For me it's like the video card has no idea VLC is displaying video.
    You got it all reversed.

    All the video card cares about is if it receives TV or PC levels. If it is set to expand it will expand the TV levels. The player can send TV or PC levels to the GPU based on the video and its own settings (e.g. it can software-expand TV levels as well.

    Quote Quote  
  7. Originally Posted by newpball View Post
    You got it all reversed.

    All the video card cares about is if it receives TV or PC levels. If it is set to expand it will expand the TV levels. The player can send TV or PC levels to the GPU based on the video and its own settings (e.g. it can software-expand TV levels as well.
    In your rush to argue, did you take any time to make sure you understood what I wrote?

    The video card has a setting for controlling the video levels, as well as other things such as brightness and contrast etc. It only effects video. Programs and Windows itself continue to display the same way. The video card can over-ride the video settings in the player. When it's set to use (in my case) "the Nvidia settings", the MPC-HC settings have no effect. The video card knows what's being displayed in the MPC-HC window is video, so it displays the way the video card is configured to display video. The brightness and contrast controls etc in MPC-HC no longer work. When it comes to VLC, it appears not to know the player is displaying video. None of the video card's "video" settings have any effect on the way it's displayed by VLC. That's what I said. I didn't get anything reversed. That's exactly what happens.
    Last edited by hello_hello; 24th May 2015 at 08:27.
    Quote Quote  



Similar Threads