VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 3
FirstFirst 1 2 3 LastLast
Results 31 to 60 of 82
Thread
  1. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Did you try adding some noise?
    Quote Quote  
  2. Originally Posted by Warcraft3 View Post
    Shadowplay's videos are compressed (check the image above) in real time (h264 using the GPU when you are playing) up to ~50mb/s at 1080, you can change the bitrate so you don't need to re-encode the video again.
    So just capture at 4500 kbps abr like the ffmpeg test encode.

    The problem you are having is clear -- you have key frame pumping. But it's the reverse of the usual pumping. Instead of clear key frames followed by slowly degrading image until the next keyframe, you have you poor keyframes which are cleaned up over the next several frames. This is because your video has way too much detail for the amount of bitrate youtube allocates to key frames. So if you want to reduce the pumping you need to reduce the detail.
    Last edited by jagabo; 24th Apr 2015 at 12:51.
    Quote Quote  
  3. Code:
    @SET x264opts="deblock=3,3:bframes=2:bitrate=4000:vbv-maxrate=10000:vbv-bufsize=20000:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=4.0:keyint=151:scenecut=-1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YT.mp4
    but quality is low (i prefer more blurry than overcompressed)
    Last edited by pandy; 24th Apr 2015 at 14:17.
    Quote Quote  
  4. Originally Posted by jagabo View Post
    The problem you are having is clear -- you have key frame pumping. But it's the reverse of the usual pumping. Instead of clear key frames followed by slowly degrading image until the next keyframe, you have you poor keyframes which are cleaned up over the next several frames. .
    That's the thing i wanted to know why happens to my videos... others upload same kind of detailed videos but they don't suffer this problem.

    So there must be an answer for that

    Originally Posted by pandy View Post
    Code:
    @SET x264opts="deblock=3,3:bframes=2:bitrate=4000:vbv-maxrate=10000:vbv-bufsize=20000:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=4.0:keyint=151:scenecut=-1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YT.mp4
    but quality is low (i prefer more blurry than overcompressed)
    Youtube:
    https://www.youtube.com/watch?v=sggVfkmUYi8&feature=youtu.be

    Screenshot:





    Could someone upload the video to Youtube (re-encoded) so i can see if it's only afecting to me ?
    https://mega.co.nz/#!eMJUxAYL!nk31rlCqPXVCXVK5KTO0P3AZ9fv7ywBYB1p4klZLaZA
    Quote Quote  
  5. Originally Posted by roma_turok View Post
    Originally Posted by Warcraft3 View Post
    Could someone upload the video to Youtube (re-encoded) so i can see if it's only afecting to me ?
    https://mega.co.nz/#!eMJUxAYL!nk31rlCqPXVCXVK5KTO0P3AZ9fv7ywBYB1p4klZLaZA
    https://www.youtube.com/watch?v=RYnyyYBAdgw
    Could you upload this one too please ? is the original video...

    https://mega.co.nz/#!nI5hUbBR!FCNCtQh7PtdcjKfcfLL_0ktbJRzWztSXtsz_uJlkhYo

    thanks
    Quote Quote  
  6. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Originally Posted by Warcraft3 View Post
    Could someone upload the video to Youtube (re-encoded) so i can see if it's only afecting to me ?
    https://mega.co.nz/#!eMJUxAYL!nk31rlCqPXVCXVK5KTO0P3AZ9fv7ywBYB1p4klZLaZA
    For starters your video contains out of range levels, how did that happen?

    Here is a 4K upload, QHD and UHD looks better.



    Bottom line is that there are too many sharp things that move at the same time, compressor cannot handle it within the given constraints!

    Here we give the compressor a bit of a break by taking away some of the edginess:



    Last edited by newpball; 25th Apr 2015 at 13:22.
    Quote Quote  
  7. Originally Posted by newpball View Post
    Originally Posted by Warcraft3 View Post
    Could someone upload the video to Youtube (re-encoded) so i can see if it's only afecting to me ?
    https://mega.co.nz/#!eMJUxAYL!nk31rlCqPXVCXVK5KTO0P3AZ9fv7ywBYB1p4klZLaZA
    For starters your video contains out of range levels, how did that happen?
    i don't know, i only used that code...

    Could you upload this one ? as given, don't re-encode it.

    https://mega.co.nz/#!nI5hUbBR!FCNCtQh7PtdcjKfcfLL_0ktbJRzWztSXtsz_uJlkhYo
    Quote Quote  
  8. Originally Posted by Warcraft3 View Post
    Could you upload this one too please ? is the original video...

    https://mega.co.nz/#!nI5hUbBR!FCNCtQh7PtdcjKfcfLL_0ktbJRzWztSXtsz_uJlkhYo

    thanks
    Ok , but I don't see what point
    upload will be finish after 45 minutes
    Quote Quote  
  9. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Originally Posted by Warcraft3 View Post
    i don't know, i only used that code...
    So was that the Fraps output or a transcode to H.264?

    Levels are illegal. Finicky encoders may have a problem with it and you might wind up having some renderers think it is PC level and your blacks will no longer be black.
    Quote Quote  
  10. Originally Posted by newpball View Post
    Originally Posted by Warcraft3 View Post
    i don't know, i only used that code...
    So was that the Fraps output or a transcode to H.264?

    Levels are illegal. Finicky encoders may have a problem with it and you might wind up having some renderers think it is PC level and your blacks will no longer be black.
    I only have that problem when i encode a video with the provided code.

    Originally Posted by roma_turok View Post
    Originally Posted by Warcraft3 View Post
    Could you upload this one too please ? is the original video...

    https://mega.co.nz/#!nI5hUbBR!FCNCtQh7PtdcjKfcfLL_0ktbJRzWztSXtsz_uJlkhYo

    thanks
    Ok , but I don't see what point
    upload will be finish after 45 minutes
    That's the original video and i think it's the best way to discard if the problem is in the videos i upload after re-encoding.







    I know there is a lot of information in the video for the bitrate used by Youtube at 1080p but as i said before, i'm one of the few who have this kind of macroblocking burst.

    I've seen lots of similar fast action videos (even with more information as i was only walking on my video) like the recorded with a Gopro or similar action camera (or just a recorded gameplay from an action videogame), but they don't usually have this problem.
    Quote Quote  
  11. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Originally Posted by Warcraft3 View Post
    I only have that problem when i encode a video with the provided code.
    Could you please be so kind to answer the question.
    Was that video straight from Fraps or did you convert it to H.264 and if so with what parameters and in particular how did you convert the RGB to YUV.

    You want people to help you but you refuse to give adequate information, why?
    Quote Quote  
  12. Originally Posted by newpball View Post
    Originally Posted by Warcraft3 View Post
    I only have that problem when i encode a video with the provided code.
    Could you please be so kind to answer the question.
    Was that video straight from Fraps or did you convert it to H.264 and if so with what parameters and in particular how did you convert the RGB to YUV.

    You want people to help you but you refuse to give adequate information, why?


    ORIGINAL VIDEO (Straight from Fraps)

    Originally Posted by Warcraft 3
    Could you upload this one too please ? is the original video...

    https://mega.co.nz/#!nI5hUbBR!FCNCtQh7PtdcjKfcfLL_0ktbJRzWztSXtsz_uJlkhYo
    ENCODED WITH 264 (with the quoted code)

    Originally Posted by Warcraft3 View Post
    Originally Posted by jagabo View Post
    The problem you are having is clear -- you have key frame pumping. But it's the reverse of the usual pumping. Instead of clear key frames followed by slowly degrading image until the next keyframe, you have you poor keyframes which are cleaned up over the next several frames. .
    That's the thing i wanted to know why happens to my videos... others upload same kind of detailed videos but they don't suffer this problem.

    So there must be an answer for that

    Originally Posted by pandy View Post
    Code:
    @SET x264opts="deblock=3,3:bframes=2:bitrate=4000:vbv-maxrate=10000:vbv-bufsize=20000:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=4.0:keyint=151:scenecut=-1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YT.mp4
    but quality is low (i prefer more blurry than overcompressed)
    Youtube:
    https://www.youtube.com/watch?v=sggVfkmUYi8&feature=youtu.be

    Screenshot:




    Could someone upload the video to Youtube (re-encoded) so i can see if it's only afecting to me ?
    https://mega.co.nz/#!eMJUxAYL!nk31rlCqPXVCXVK5KTO0P3AZ9fv7ywBYB1p4klZLaZA

    Use the original video for encoding and upload as it's the source.
    Quote Quote  
  13. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Alright I will take a look at the original.

    Will take some time though.
    Quote Quote  
  14. Originally Posted by newpball View Post
    Will take some time though.
    No problem
    Quote Quote  
  15. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Here is a frame interpolated 60p version from the original Fraps source, not much better either:



    Can you play the game in 60p instead of 30p or is your GPU not able to do that?
    Quote Quote  
  16. Originally Posted by newpball View Post
    Here is a frame interpolated 60p version from the original Fraps source, not much better either:
    I see your point but it doesn't improve...

    (playing at 1080p60)


    Originally Posted by newpball View Post

    Can you play the game in 60p instead of 30p or is your GPU not able to do that?
    I also upload 60fps videos but the bitrate is only a bit higher than 1080p 30fps so the quality is even lower.
    Quote Quote  
  17. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    Originally Posted by Warcraft3 View Post
    I also upload 60fps videos but the bitrate is only a bit higher than 1080p 30fps so the quality is even lower.
    Not necessarily, 60p tends to compress better than 30p.
    Quote Quote  
  18. Another example without this problem and it was uploaded this year:

    min 3:20 (low quality due to complexity and the not enough bitrate, but i don't see the pixelated image every 5 seconds i get)
    https://www.youtube.com/watch?v=D-mBqbgI1cs
    Quote Quote  
  19. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    A bit better:

    Quote Quote  
  20. Originally Posted by newpball View Post
    A bit better:

    Looks better, what did you change ?
    Quote Quote  
  21. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    If you look at the original source at 400% and you go frame by frame it is extremely pixelated.

    So if you apply a mild blur and on top of that a mild radial blur to blur the edges slightly more you will make life easier for the encoder.

    Click image for larger version

Name:	pixelated.png
Views:	305
Size:	536.7 KB
ID:	31422
    Quote Quote  
  22. Banned
    Join Date
    Oct 2014
    Location
    Northern California
    Search PM
    A bit more blur but far less compression trouble:



    Basically you can add just enough blur to get rid of the pixelation.
    Quote Quote  
  23. This one can remove aliasing (thanks to crude antialiast) without sacrificing resolution to much:

    (beware perceived sharpness is lower but this is hi res video)

    Code:
    @SET x264opts="deblock=2,3:bframes=2:bitrate=4000:vbv-maxrate=10000:vbv-bufsize=20000:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=5.1:keyint=152:keyint_min=151:scenecut=-1:nal-hrd=vbr:force-cfr=1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "xbr=2,scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither,format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YTaa.mp4
    btw same as previously - set xbr=4 to go for fake UHD - YT may have better profile for UHD - also bitrate=4000:vbv-maxrate=10000:vbv-bufsize=20000 need to be adjusted accordingly.

    Adding blur may further reduce requirements for bitrate https://www.ffmpeg.org/ffmpeg-filters.html#boxblur .


    With bellow script:
    Code:
    @SET x264opts="deblock=2,3:bframes=2:bitrate=19000:vbv-maxrate=25000:vbv-bufsize=31250:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=5.1:keyint=151:keyint_min=150:scenecut=-1:nal-hrd=vbr:force-cfr=1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:a copy -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "xbr=4,scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither,format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YTaa.mp4
    It looks significantly better when compared to HD YT settings (qp fluctuations are significantly lower - between 33 and 39 not like previously between 32 and 42) - this lead to my earlier suggestion - upscale your HD to fake 4k with additional antialias processing (thanks to xbr rescaling) - please upload such version to YT .
    Last edited by pandy; 26th Apr 2015 at 11:54.
    Quote Quote  
  24. Originally Posted by pandy View Post


    With bellow script:
    Code:
    @SET x264opts="deblock=2,3:bframes=2:bitrate=19000:vbv-maxrate=25000:vbv-bufsize=31250:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=5.1:keyint=151:keyint_min=150:scenecut=-1:nal-hrd=vbr:force-cfr=1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:a copy -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "xbr=4,scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither,format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YTaa.mp4
    It looks significantly better when compared to HD YT settings (qp fluctuations are significantly lower - between 33 and 39 not like previously between 32 and 42) - this lead to my earlier suggestion - upscale your HD to fake 4k with additional antialias processing (thanks to xbr rescaling) - please upload such version to YT .

    This code doesn't work, it shows the cmd windows and then it closes...

    Before closing:

    Quote Quote  
  25. Originally Posted by Warcraft3 View Post
    This code doesn't work, it shows the cmd windows and then it closes...

    Before closing:

    Add Pause as third line - should prevent window to automatic close.
    Seem there is issue with audio stream - try remove -c:a copy - maybe it help.

    btw i just verified - i works for me:

    Code:
    @SET x264opts="deblock=2,3:bframes=2:bitrate=19000:vbv-maxrate=25000:vbv-bufsize=31250:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=5.1:keyint=151:keyint_min=150:scenecut=-1:nal-hrd=vbr:force-cfr=1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:a copy -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "xbr=4,scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither,format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YTaa.mp4
    @pause
    verified with latest build from zeranoe ffmpeg-20150425-git-a3110be-win32-static.7z
    Quote Quote  
  26. Originally Posted by pandy View Post
    Seem there is issue with audio stream - try remove -c:a copy - maybe it help.
    it worked =)

    https://www.youtube.com/watch?v=gny4DjIhl3c


    1080p



    1440p



    2160p




    Looks much better at 4K (due to higher bitrate than 1080, of course), that's the quality i wanted to get for 1080p...
    Quote Quote  
  27. Originally Posted by pandy View Post

    btw i just verified - i works for me:

    Code:
    @SET x264opts="deblock=2,3:bframes=2:bitrate=19000:vbv-maxrate=25000:vbv-bufsize=31250:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=5.1:keyint=151:keyint_min=150:scenecut=-1:nal-hrd=vbr:force-cfr=1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:a copy -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "xbr=4,scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither,format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YTaa.mp4
    @pause
    verified with latest build from zeranoe ffmpeg-20150425-git-a3110be-win32-static.7z
    I was doing more tests and i have 2 problems:

    -When the video it's uploaded to Youtube i get a less contrasted image, but the video encoded (with ffmpeg using that code) has the same contrast as the original...

    -And the video encoded with ffmpeg (also when uploaded to Youtube) has different colors, like it's using another color space, not the original one.

    Do you know what to fix these problems ?
    Quote Quote  
  28. Originally Posted by Warcraft3 View Post
    I was doing more tests and i have 2 problems:

    -When the video it's uploaded to Youtube i get a less contrasted image, but the video encoded (with ffmpeg using that code) has the same contrast as the original...
    Not sure if this is issue - are you intend to lower or keep the same contrast as in source?

    Originally Posted by Warcraft3 View Post
    -And the video encoded with ffmpeg (also when uploaded to Youtube) has different colors, like it's using another color space, not the original one.

    Do you know what to fix these problems ?
    This is maybe related to 601/709 problem - ffmpeg is kind of vague on this area (not particularly informative - automatically doing some color space conversion without giving any info etc).

    I assumed that 4k mandatory color space on YT is 709 (and such color space is encoded as VUI string)
    I would go for https://www.ffmpeg.org/ffmpeg-filters.html#colormatrix

    Code:
    @SET x264opts="deblock=2,3:bframes=2:bitrate=19000:vbv-maxrate=25000:vbv-bufsize=31250:colorprim=bt709:transfer=bt709:colormatrix=bt709:fullrange=on:level=5.1:keyint=151:keyint_min=150:scenecut=-1:nal-hrd=vbr:force-cfr=1:qpmin=4:cabac=1:nr=500:threads=auto:no-psnr:no-ssim"
    @ffmpeg -threads %NUMBER_OF_PROCESSORS%*1.5 -i %1 -c:a copy -c:v libx264 -preset veryfast -tune fastdecode -profile:v high -x264opts %x264opts% -x264-params %x264opts% -vf "xbr=4,scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither,colormatrix=bt601:bt709,format='pix_fmts=yuv420p'" -movflags faststart -y -f mp4 %1_YTaa.mp4
    @pause
    Alternatively/additionally this may help:
    https://www.ffmpeg.org/ffmpeg-filters.html#scale-1

    I would try to do something like this:

    Code:
    scale=iw/2:-2:sws_flags=spline:sws_dither=a_dither:in_range='mpeg/tv':out_range='jpeg/full/pc':in_color_matrix=bt601:out_color_matrix=bt709
    Modify syntax as this is just example.

    If your wish is to use a different color space for h.264 then x264 VUI need to be also modified - replace 709 by bt470bg i.e. colorprim=bt470bg:transfer=bt470bg:colormatrix=bt4 70bg , side to this you may wish to disable VUI signalization for full quantization range - currently this is: fullrange=on where it can be: fullrange=off for 16-235 luma sample values and 16 - 240 chroma sample values.
    Quote Quote  



Similar Threads