VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 1 of 1
Thread
  1. Member ahhaa's Avatar
    Join Date
    Feb 2005
    Location
    Michigan USA
    Search Comp PM
    Hi guys- I'm having a terrific time with my Raspberry Pi 2B, most fun in years!

    If one of you guys who's fully knowledgeable in linux could look at a couple web pages for me?

    Recently, I've successfully installed Iceweasel, the Debian variant of Firefox. However, it is unclear to me
    what is best procedure for bringing on-board the several addons I actually use quite regularly.

    One is Media Converter & Muxer, which will pull an MP3 out of a Quicktime vid in seconds with a drag&drop.

    This add-on is said to be linux compatible, but requires ffmpeg installed to operate.
    (Some other info is found in the Firefox add-on listing)

    Its homepage is http://firefox.add0n.com/media-converter.html

    Now, the Raspberry Pi 2B is running a Debian flavor on an Arm CPU; I am pretty sure it is armhf.

    So on to the ffmpeg download page https://www.ffmpeg.org/download.html

    It has Debian packages for Oldstable, Stable, Testing, and Unstable; as well as armhf.

    It also has a static build; which I saw mentioned somewhere now lost as a bugfix for something.

    Two things are confusing me: will an add-on generated thru Firefox/Iceweasel update itself correctly?

    Second & most important, there seems to be a bug that requires manually setting the path to ffmpeg:


    When I try to point the extension to use FFmpeg on Mac or Linux, the actual binary path is selected instead of the symlink.
    How can I fix this?
    This is a bug with Firefox open file module. There is no easy fix for it. However, you can follow the instruction on https://github.com/inbasic/iaextractor/issues/36 to manually set the correct path for FFmpeg executable.

    That instruction is:

    Another solution is to set the ffmpeg path manually
    Open a browser tab and insert about:config. Now find extensions.feca4b87-3be4-43da-a1b1-137c24220968@jetpack.ffmpegPath and change the path to /usr/local/bin/ffmpeg.

    Also I believe if you install the latest version of the extension on a clean profile, it should detect the right path. Although if you try to manually point the extension to the ffmpeg, it is going to use the real binary path
    .
    https://github.com/inbasic/iaextractor/issues/36

    I'm not sure this fix is OK for my Pi, as it comes from an OS-X thread...

    that term in blue is incorrect, it should include 'Path'
    extensions.feca4b87-3be4-43da-a1b1-137c24220968@jetpack.ffmpegPath
    Last edited by ahhaa; 7th Apr 2015 at 12:00. Reason: error
    Quote Quote  



Similar Threads