VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Hi,

    I have setup Potplayer to use Cyberlink Aucdio Codec for decoding Sound, because I like Cyberlink's TruSurroundXT functionality.

    The Setup works fine however if I play a file that contains Ac3 Sound, then the sound is very silent. I have to pump up the volume to max in order to have a acceptable level of sound.

    At the same time however FIles with DTS Sound play nicely with a volume level where it is more than sufficient to keep the volume level at medium range.

    If I play both of these files directly in Powerdvd, both files are played at a comparable Volume level. I would like to have the same sound quality directly in Potplayer as I have in PowerDVD.

    I have tested a lot in order to investigate the reasons, and I believe it has to do something with which Audio Splitter is used during Playback.

    The following Screenshot shows the filters used for a file with DTS and good sound levels:

    Click image for larger version

Name:	PemKwRqjk.jpg
Views:	688
Size:	284.3 KB
ID:	30783

    The following Screenshot shows the filters used for a file with AC3 and very low sound volume:

    Click image for larger version

Name:	R4MRWeUSt.jpg
Views:	558
Size:	293.6 KB
ID:	30784

    I assume that the Filter used just before the Cyberlink Codec makes the difference.

    The "Built-In Audio Codec/Transform(low merit)" appears to cause the low volume levels with Ac3 sound.

    In Filtermangement I can however not find these filters and teherefore can not prefer the one over the other like I have done with the other filters.

    Anyone can help me to setup Cyberlink Codec properly also for Ac3 sound?

    Thanks!
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    How does your filter control-> audio decoders look like?

    You can also search and ask in https://potplayer.daum.net/forum/ . If you find a solution post back.
    Quote Quote  
  3. I don't use Cyberlink decoder, but there's a setting for AC3 in PotPlayer that might work: Preferences (F5) - Audio - Volume Control - (bottom of the right hand side) tick 'Pre-amplify AC3/DTS Vol.' and use the slider.

    Plus if you left-click Cyberlink Audio Decoder (PDVD10) from the list of currently used Filters (as on your screenshots), does the preferences window of the decoder show up? There might be some settings to amplify AC3 volume.

    I don't quite understand why you have 'Built-in AVI<->AC3/DTS' in currently used filters. Did you add Cyberlink audio decoder to PotPlayer manually - you have it in DirectShow Filter List (via Preferences - Filter Control - Audio Decoder - Filter Management and add it using: Scan or Add external filter or Add registered filter)? And Audio Decoder - AC3 is toggled to Cyberlink Audio Decoder (PDVD10)? If not it might mean that the decoder forced itself to high priority in your whole system. As far as I remember for example Haali Splitter could do it as well.
    Quote Quote  
  4. AC3 can (and often does) contain dialogue normalisation information. The idea being the player uses the dialogue normalisation to adjust the entire volume up or down, so the dialogue in all AC3 audio should be the same level. If there's no dialogue normalisation info present, I think the player is supposed to assume a certain level and adjust the volume accordingly. The upshot of that is AC3 generally ends up being quieter than other audio.

    Chances are the Potplayer AC3 decoder ignores the dialogue normalisation (many software players do) while the Cyberlink Audio Codec does not, hence AC3 being quieter when the Cyberlink Audio Codec is used. Maybe there's a way to disable the dialogue normalisation. I don't know, but that'd be my guess as to the cause.

    If you happen to have ffdshow installed and want to try it, last time I checked libavcodec ignores the dialogue normalisation whereas liba52 does not, so if you change the AC3 decoder to liba52 under ffdshow's codec setup, the result is usually quieter AC3 audio.
    Last edited by hello_hello; 18th Mar 2015 at 05:44.
    Quote Quote  
  5. How does your filter control-> audio decoders look like?

    Click image for larger version

Name:	Unbenannt.jpg
Views:	1293
Size:	158.2 KB
ID:	30802

    @Allisone:

    The options you describe allow me to manually increase the sound, but that means that I have to adjust the volume differently for DTS and for Ac3. Furthermore if I use the option to amplify the volume, then the sound is kinda "metallic".
    Last edited by R0cket; 19th Mar 2015 at 04:40.
    Quote Quote  
  6. Member Krispy Kritter's Avatar
    Join Date
    Jul 2003
    Location
    St Louis, MO USA
    Search Comp PM
    "very silent". Is that like very dead.

    Silent, by definition, is no sound.

    Pardon the interruption, I know it's not helpful.
    Google is your Friend
    Quote Quote  
  7. With Silent I mean, the volume is very low and it is hard to understand the voices or the sounds. I have to turn up the volume to max.

    Normally if I turn the volume up to Max, The sound is too loud for my room so that I keep the volume at medium level. But in the case of Ac3 even with volume to the max, the sound is hardly loud enough to be able to follow the dialogues of a movie sitting two meters away from the source.
    Quote Quote  



Similar Threads