VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. I have a TS that I ran through both MKVToolNix and YAMB and got the same result. I did this because TS's don't seek well on my system. The video size drops from around 7.5 GB down to 3.25 GB when I recontainer it. I did not do any re-encoding. I just changed the container. The video is exactly the same. It is indistinguishable from when in the TS container. MediaInfo reports that the video is a 50 FPS video. If run through YAMB, it maintains this. If ran through MKVToolNix, MediaInfo displays it as Original frame rate and not just framerate.

    Am I really loosing the frame rate? Is the size difference just a huge amount of overhead in the TS container format? I'm not too concerned about having 50 FPS video as I don't think the human brain can process that much info. It's great for super slow-mo but not so much for watching video at regular speed. Correct me if I'm wrong on this.
    Quote Quote  
  2. I'm a Super Moderator johns0's Avatar
    Join Date
    Jun 2002
    Location
    canada
    Search Comp PM
    The file size shouldn't drop that much packaging a ts to mkv,sounds like there's something wrong with the ts.
    I think,therefore i am a hamster.
    Quote Quote  
  3. Member netmask56's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Search Comp PM
    You could try demuxing the TS file into it's audio and video components and then add them into mkvmergegui to make a mkv file.
    BeyonWiz T3 PVR ~ Popcorn A-500 ~ Samsung ES8000 65" LED TV ~ Windows 7 64bit ~ Yamaha RX-A1070 ~ QnapTS851-4G
    Quote Quote  
  4. All else being equal, 50fps progressive video looks way smoother than 25fps progressive video.

    Chances are it's interlaced, so it'd be 25 frames, or 50 fields per second, depending on how you look at it. I'd say everything is fine, but something is lost in the translation so to speak, and MediaInfo ends up displaying the wrong frame rate. When you mux with MKVMergeGUI, try specifying the frame rate. Either 25p, or 50i, or even 50p..... as long as the muxed video still plays at the correct speed if specifying one of those gets MediaInfo to report the correct frame rate, go with that one.

    I'm sure the file size drop is unrelated, but it is pretty odd. The only explanation I can think of is there's a stream in the TS file neither YAMB or MKVMergeGUI are willing to acknowledge. I'm not sure what it'd be or why..... but maybe try TSMuxer to see what happens when it remuxes. Or you could extract the individual streams from the TS file to see how large they are.
    TSMuxer tends to tell you when it's opened a file but it doesn't support a stream within.
    Quote Quote  
  5. Thanks. I'm just going to put it down as a fluke at this point. I've deleted the TS.


    I extracted the streams and they matched the lower sizes I was seeing when the container changes. I saw this before when using YAMB as it temporarily extracts the streams in the same folder.

    I tried setting the FPS in MKVToolNix to all the values you suggested but MediaInfo still reported it as Original frame rate.


    Thanks again.
    Quote Quote