VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. I have a Asus laptop. I used to connect this laptop through an HDMI cord to my LCD TV to watch movies and music videos. The audio works when the laptop isn't connected to the TV. Today, the audio does not work once connected to the TV. There is video. I tried a few other HDMI cables but am getting the same effect. If I remove the HDMI cable, there is audio from the laptop. I try a different TV HDMI to my laptop, same effect, no audio from the TV.


    What is causing this weird scenario?
    Quote Quote  
  2. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    Check your video and audio settings. You need to specifically set HDMI audio output in most laptops and PCs. I don't use HDMI audio for my PCs, so I disable HDMI audio for my video card. But it should auto detect when you insert your HDMI cable and it's connected to a compliant device.
    Quote Quote  
  3. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    Sounds like some setting is corrupted. Might need an uninstall/re-install cycle.

    Scott
    Quote Quote  
  4. Yep might want to check and see if there are newer drivers for the video chipset. They should have the HDMI audio drivers with them. Uninstall the old and reinstall the new. Should get everything back up and running. Still, check audio settings first to see if it's just an issues with output type being incorrect.
    Quote Quote  
  5. Originally Posted by Poppa_Meth View Post
    Yep might want to check and see if there are newer drivers for the video chipset. They should have the HDMI audio drivers with them. Uninstall the old and reinstall the new. Should get everything back up and running. Still, check audio settings first to see if it's just an issues with output type being incorrect.
    This ASUS link backs up your suggestion, with the caveat that sometimes you may need to revert to the original drivers:

    http://rog.asus.com/forum/showthread.php?17258-HDMI-connection-picture-but-no-sound-solved
    They that give up essential liberty to obtain a little temporary safety deserve neither liberty or safety.
    --Benjamin Franklin
    Quote Quote  
  6. It used to auto connect. I didn't have to change any settings. I will check on the video chipset but hadn't installed anything recently that may effect the computer.
    Quote Quote  
  7. Originally Posted by jyeh74 View Post
    I have a Asus laptop. I used to connect this laptop through an HDMI cord to my LCD TV to watch movies and music videos. The audio works when the laptop isn't connected to the TV. Today, the audio does not work once connected to the TV. There is video. I tried a few other HDMI cables but am getting the same effect. If I remove the HDMI cable, there is audio from the laptop. I try a different TV HDMI to my laptop, same effect, no audio from the TV.


    What is causing this weird scenario?
    When the laptop is connected to the TV via HDMI, under the Sound settings (Win 7), it is set to Sony TV. Auto detected.
    Still no sound until I disconnect the HDMI.
    Quote Quote  
  8. Originally Posted by Poppa_Meth View Post
    Yep might want to check and see if there are newer drivers for the video chipset. They should have the HDMI audio drivers with them. Uninstall the old and reinstall the new. Should get everything back up and running. Still, check audio settings first to see if it's just an issues with output type being incorrect.
    I go to control panel and uninstall a program. However, I am not sure exactly which video driver I have with my asus.

    I went to asus and looked up my model u47a.
    It has two under video
    nVidia Graphics Driver
    Intel Graphics Driver

    I uninstalled and reinstalled the Intel Graphics Driver.
    I restarted my computer.
    Now when I go to play music on my laptop, under the sound it plays the Realtek High Definition Audio (default)
    Above it is the Sony TV but it won't let me select it, even when the HDMI cable is plugged in. How do I set it, I can't hit OK or apply or anything and it will not auto detect my TV now.
    Last edited by jyeh74; 9th Jan 2015 at 01:03.
    Quote Quote  
  9. Member Krispy Kritter's Avatar
    Join Date
    Jul 2003
    Location
    St Louis, MO USA
    Search Comp PM
    Try reinstalling the audio (ie: Realtek) drivers as well.
    Google is your Friend
    Quote Quote  
  10. From what little I've been able to find the audio over HDMI is handled via the nVidia driver, not the intel or the Realtek. Realtek is the onboard sound and Intel is the integrated video. The HDMI audio is handled by the nVidia chipset.
    Quote Quote  
  11. joollyjohn jollyjohn's Avatar
    Join Date
    Mar 2005
    Location
    Sydney Australia
    Search Comp PM
    Your TV will show up here when connedted. Select it.
    Image Attached Thumbnails Click image for larger version

Name:	Settings.jpg
Views:	198
Size:	34.5 KB
ID:	29682  

    Quote Quote