VideoHelp Forum

+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. I have a PAL DVD boxset of The A-Team I want to convert into anamorphic x264. The DVDs are flagged Interlaced but they show no interlace fragments, except for about 5 minutes on episode 15 from season 2. I tried deinterlacing with QTGMC but the result is almost identical to the original. With the Handbrake Bob Decomb setting it get's watchable, but it's still very noticable it has been deinterlaced due to unsmooth edges. Is there any way I can deinterlace it with QTGMC or is there something wrong with the master from Universal?

    QTGMC .avs file:
    Code:
    LoadPlugin("C:\Program Files (x86)\AviSynth 2.5\plugins\masktools2-25.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth 2.5\plugins\dgmpgdec158\DGDecode.dll")
    LoadPlugin("C:\Program Files (x86)\AviSynth 2.5\plugins\decomb\Decomb.dll")
    Import("C:\Program Files (x86)\AviSynth 2.5\plugins\QTGMC-3.32.avsi")
    MPEG2Source("C:\VIDEO_TS\qtgmc\title03_track1_eng.d2v")
    QTGMC( Preset="Very Slow" )
    Crop(2,4,-2,-4)
    AssumeTFF().SeparateFields().SelectEvery(4,0,3).Weave()
    QTGMC commandline:
    Code:
    x264.exe --profile high --preset veryslow --crf 19 --sar=764:716 --output output.mkv test.avs
    Handbrake Settings:
    Code:
    Anamorphic: Custom
    Width: 716
    Height: 568
    Display Width: 764
    Cropping: Custom - L2, T4, R4, B2
    Modulus: 2
    Deinterlace: Decomb, Bob
    Framerate: 23.976 - Constant
    Quality: CRF 19
    x264 Preset: Very Slow
    Profile and Level: Auto
    Original:


    QTGMC (Very Slow-setting):


    Handbrake (Bob Decomb-setting):



    I've included 3 video's. They are slowed down to match their original framerate (25->23.976). If I encode everything in 25FPS, everything looks just the same.
    Image Attached Files
    Quote Quote  
  2. Groucho2004
    Guest
    Originally Posted by pub View Post
    Code:
    QTGMC( Preset="Very Slow" )
    ...
    AssumeTFF().SeparateFields().SelectEvery(4,0,3).Weave()
    Not surprising that it does not work. The last line in your script re-interlaces the video that you previously de-interlaced with QTGMC.
    Quote Quote  
  3. Originally Posted by Groucho2004 View Post
    Originally Posted by pub View Post
    Code:
    QTGMC( Preset="Very Slow" )
    ...
    AssumeTFF().SeparateFields().SelectEvery(4,0,3).Weave()
    Not surprising that it does not work. The last line in your script re-interlaces the video that you previously de-interlaced with QTGMC.
    I think I googled wrong then. What line should I use to get 25fps instead of 50fps? SelectEven()?
    Quote Quote  
  4. Groucho2004
    Guest
    Originally Posted by pub View Post
    What line should I use to get 25fps instead of 50fps? SelectEven()?
    Yes.
    Quote Quote  
  5. Or you can have QTGMC() decimate to the source frame rate with QTGMC(FPSDivisor=2).

    But your source isn't really interlaced, it's progressive frames captured out of phase. Use TFM() instead of QTGMC().
    Last edited by jagabo; 28th Dec 2014 at 09:56.
    Quote Quote  
  6. Originally Posted by jagabo View Post
    Or you can have QTGMC() decimate to the source frame rate with QTGMC(FPSDivisor=2).

    But your source isn't really interlaced, it's progressive frames captured out of phase. Use TFM() instead of QTGMC().
    That did it, thanks!
    Quote Quote