VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Page 16 of 16
FirstFirst ... 6 14 15 16
Results 451 to 473 of 473
Thread
  1. Hello everyone, I'm in the process of exploring the program and unfortunately fail because of the release of sound films. The message appears: "Error initializing audio stream compression. No installed audio codec could compress the source audio to the desired format". What should I do? Thank you!!!
    Quote Quote  
  2. Member
    Join Date
    Dec 2014
    Location
    Switzerland
    Search PM
    Hello ,

    Is your film a film with a soundtrack?
    Have you tried reinstalling the Lagarith codec from Film9?
    Have you installed K-Lite Mega Codec Pack correctly always from Film9?

    Regards
    Quote Quote  
  3. Hallo Gelinox, yes this is a film AVI 1080x1440 with sound. I reinstalled the Lagarinth codes already. But .... i have installes the programm on another PC and it works fine there. So i will reset the hole PC and start again. Thanks for the extremly fast answer!
    Quote Quote  
  4. I know its Vaporsynth based - but perhaps it could work with avisynth and thus with film9 too... might be an nice upscaling/ detail enhancement for those old super8 films...

    https://github.com/AlphaAtlas/VapourSynth-Super-Resolution-Helper
    Quote Quote  
  5. Hi Gelinox.

    For the first time today, I tried Film9 'without syncro'

    I used a projector on the wall, a camera taking video.

    I saw some strobe effect in my video

    I put the video in to Film9 and chose 'without syncro'

    I hoped I would see the strobe be taken away, but it remains.

    Am I doing something wrong, or have I got the idea of 'without syncro' setting misunderstood?

    edit

    No matter, I have been corrected in the use of 'without syncro' and the fault is mine.
    Last edited by super8rescue; 9th Apr 2021 at 05:46.
    Quote Quote  
  6. Member
    Join Date
    Dec 2014
    Location
    France
    Search PM
    Hello super8rescue,

    As stated in the Film9 documentation (page 18), "Without Synchro" mode means the projector is running in its own stream.
    But, it is imperative that the speed of the projector is adjusted to 16.6fps (PAL sensor) or 20fps (NTSC sensor).
    Then, FILM9 will automatically delete the bad images.

    The "With Synchro" mode means that the projector can be synchronized with the Sensor to obtain exactly 1 film frame = 1 video frame.
    But, other capture systems (like scanners) can also produce image-film = image-video.
    Quote Quote  
  7. Originally Posted by GillesH View Post
    Hello super8rescue,

    As stated in the Film9 documentation (page 18), "Without Synchro" mode means the projector is running in its own stream.
    But, it is imperative that the speed of the projector is adjusted to 16.6fps (PAL sensor) or 20fps (NTSC sensor).
    Then, FILM9 will automatically delete the bad images.

    The "With Synchro" mode means that the projector can be synchronized with the Sensor to obtain exactly 1 film frame = 1 video frame.
    But, other capture systems (like scanners) can also produce image-film = image-video.
    Thanks, I guess I should have looked in the manual before posting.

    That said, I know of no Super8 projector that will run at 16.6 or 20fps without some kind of modification, which is not out of the question for my Sankyo 500
    Last edited by super8rescue; 9th Apr 2021 at 05:47.
    Quote Quote  
  8. Member
    Join Date
    Dec 2014
    Location
    France
    Search PM
    It is true that if the projector does not have a speed adjustment with potentiometer, it is necessary to make a modification.
    In addition, during capture, it is necessary to check the regulation of this speed (16.6 or 20). A tolerance of 5% is granted.
    And so, this type of capture often requires modifications to the projectors.

    I don't have a standard method because many different modifications are possible depending on the projectors.
    There are many discussions on this subject on the French forum "Le Transfert Pellicule".
    https://letransfert.soforums.com/f25-Reglage-de-la-vitesse-de-transfert.htm
    Among other things, it is this forum which is at the origin of the birth of FILM9.

    Good luck with the translation....
    Quote Quote  
  9. Originally Posted by GillesH View Post
    It is true that if the projector does not have a speed adjustment with potentiometer, it is necessary to make a modification.
    In addition, during capture, it is necessary to check the regulation of this speed (16.6 or 20). A tolerance of 5% is granted.
    And so, this type of capture often requires modifications to the projectors.

    I don't have a standard method because many different modifications are possible depending on the projectors.
    There are many discussions on this subject on the French forum "Le Transfert Pellicule".
    https://letransfert.soforums.com/f25-Reglage-de-la-vitesse-de-transfert.htm
    Among other things, it is this forum which is at the origin of the birth of FILM9.

    Good luck with the translation....
    Many thanks for the link, fortunately Chrome browser translates it for me.
    Much reading to do.....
    I have an electronically speed controlled projector, so I am able to investigate further the possibility of telecine rather than 'scanning'
    Quote Quote  
  10. Member
    Join Date
    Apr 2021
    Location
    United Kingdom
    Search Comp PM
    Image
    [Attachment 58351 - Click to enlarge]
    Hi.
    I am new to Film9 and am trying to process a mp4 video file to remove film dirt etc.
    Everything looks fine in the preview windows, and the dirt is removed, and the adjusted picture looks exactly how I want it.
    However, when I start the rendering, I get 2 error messages.
    The first is that there is no codec to compress the audio and the second is that Avisynth cannot find the .avi file it needs.

    I have attached screenshots of the two errors.

    I have also added a screenshot of the mp4 file properties.

    Whilst I am not worried about the audio issue which I can resolve in other ways, the video error obviously won't allow me to render the file.

    I have tried converting the mp4 file to an AVI one and then using that as the file I insert into Film9 to be rendered, but that doesn't help either.

    Any ideas what I am doing wrong?
    Image Attached Thumbnails Click image for larger version

Name:	Screenshot (1).png
Views:	12
Size:	245.6 KB
ID:	58349  

    Click image for larger version

Name:	Screenshot (2).png
Views:	8
Size:	243.0 KB
ID:	58350  

    Last edited by Filmboychris; 10th Apr 2021 at 10:42.
    Quote Quote  
  11. what video format are you choosing for your export?

    .mov .avi .mp4?

    What audio selection are you making for that export

    You might find you are using the wrong audio setting.

    Are you using the K Lite Mega codec pack, and not the regular K Lite codec pack?

    I noticed today an update for the mega codec pack, I can't say that would cause the issue, just a heads up.

    Image
    [Attachment 58353 - Click to enlarge]


    Image
    [Attachment 58354 - Click to enlarge]
    Quote Quote  
  12. Member
    Join Date
    Apr 2021
    Location
    United Kingdom
    Search Comp PM
    Hi super8rescue, and thanks for your reply.
    I have the latest K-Lite Megapack installed.
    I have tried using the H264 codec and rendering to create an mp4 file as per the source, as well as converting the file to avi and then trying to render to avi.
    Both times the same errors appear.
    I even tried selecting silent film to avoid processing any audio and still the audio and video errors appear?

    Really have no idea why this is failing to render for me.
    Quote Quote  
  13. Sorry I can't be of further help.

    Have you used Film9 for any silent work with success?

    Forum member Gelinox is the chap you need, let's hope he will see this and offer you further advice.
    Quote Quote  
  14. Member
    Join Date
    Apr 2021
    Location
    United Kingdom
    Search Comp PM
    No problem super8rescue, and thanks for your advice.
    I haven't really had much success with Film9 so far in rendering successful files.
    As a test, I selected the no audio option in the file menu, and I selected the "synchro" option in Film9 profile with 16.6 as the fps, since I have seen other posts that mentioned issues in rendering.
    This did render, but produced a file that does correct the film dirt problem, but runs like slow motion.
    Since the original file is from video at 25fps I guess this makes sense, so I am now running a silent render using the synchro option set at 25fps to see what happens.
    Hopefully, this will create the rendered file correctly at the correct speed and with the film dirt removed. At least I am not yet seeing the same errors as before, but it is odd that the file won't render using the videotape option with audio, when that is what the original mp4 file is from.
    Hopefully Gelinox will be able to assist with why I am having this problem.
    Quote Quote  
  15. A few things help you with "synchro," both on and off.

    First, the best transfers are "frame accurate." This is the term the film transfer industry uses instead of "synchro." It means that you get one frame of film transferred to one frame of video, without blends, duplicates, or drops. You pretty much have to get this type of transfer if you intend to do any restoration or improvement on the transfer because field/frame dups, as well as blends and drops, completely screw up most of the tools used to reduce film artifacts. You certainly will not get good results with dirt removal.

    However ...

    I built a film transfer system that intentionally is NOT syncrhonized. I did this by removing the shutter from a very nice 16mm Eiki projector. I put a telephoto lens in the projector and then put my video camera point blank in front of the lens. It is a trick I discovered years ago, where you intercept the image before it hits the focal point (i.e., it is upside down). I then set my NTSC interlaced video camera (this would also work with a 60p camera) to a high shutter speed so I can differentiate fields that have blends. I also identify the fields where pulldown happens (which is trivially easy to do). You have to carefully work through the math, but it turns out that with a 60 field/frame per second camera, and a projector that goes no faster than 24 fps (mine is sync'd to the line frequency), you can be 100% assured that you will always get two matching fields of video from every frame of film, without any fields which contain a blend of adjacent film frames.

    Figuring out how to do those matches, and reassembling frames using fields from two adjacent frames (when there is a blend or a pulldown field) is the extremely difficult part. I even briefly considered patenting the process, since it is so unique (too much money, however, and no benefit to me other than ego satisfaction of saying that I have a patent).

    The point of this post is simply to point out that, with the right equipment and the right know-how, you can get excellent results without synchronization, but you have to have an NTSC camera (25/50 frame/field per second PAL is not fast enough), and you also need to remove the projector shutter, or else live with manual exposure. The reason is that the shutter devastates the auto-exposure because pure black makes the exposure increase, resulting in flicker.

    Having said that you need an NTSC camera, this would also probably work with slower video camera frame rates (e.g., PAL) but only if you slowed down the projector.
    Quote Quote  
  16. Originally Posted by Filmboychris View Post
    No problem super8rescue, and thanks for your advice.
    I haven't really had much success with Film9 so far in rendering successful files.
    If I can be of any help with Film9 I would be very happy to help you.

    I have been using it for around 6 months now, I first tried it around 3 years ago and gave up because I couldn't make it work.

    I have made a very basic tutorial about Film9

    If you haven't already seen it it https://youtu.be/jYPJLlsBMHM

    I love Film9

    It took me a while to get my head around it, but now I manage to put content in to Film9 and am mostly very happy with the end result.

    There are times when Film9 completely messes things up, but that is down to me and my chosen settings.

    I did have some issues with sound edits when I began, but somehow they seem to be ok now.


    Good luck, Don't give up, you'll get there.
    Last edited by super8rescue; 11th Apr 2021 at 07:00.
    Quote Quote  
  17. Member
    Join Date
    Apr 2021
    Location
    United Kingdom
    Search Comp PM
    Thatís a nice tutorial.
    I have kind of worked out the basics with Film9 and it really does have great potential as restoration software, especially as it is freeware and seems powerful in what it can do.What brought me here is a desire to try and restore existing feature films that are available online, but which have not had any clean up work done.There are countless films like this, and whilst I appreciate that Film9 was created to improve home movies shot on super 8 film, I hoped it may be a suitable tool to improve films that have been digitised to mp4 files.
    I realise the main issue here is how these films have been captured.Telecine processes all alter a 24fps film to either PAL 25fps or NTSC 29.97 FPS and this creates duplicate frames which make trying to use the film cleaning part of Film9 either impossible, or very difficult.It seems that the manner in how the digital file has been created, totally determines How Film9 might be able to clean the picture or not.
    I am finding that using the cleaning tool set to video 25fps or 30fps or 29.97fps depending on the source of the mp4 file, usually means it wonít work in cleaning dirt, because of all the duplicate frames confusing the software in identifying dirt.
    I have tried pull down IVTC or whatever it is called in the filters, and this rarely seems to remove the duplicates to make the cleaning tool function.
    As an alternative, I have tried the synchro option and the non synchro option as well, and my efforts always result in either no sound being processed, or out of synch sound is created, or a silent file is created which runs in slow motion, or only converts a third of the file, or various other issues that result in an unusable treated file.
    Perhaps Film9 is not the tool that can create the restorations I seek, but I seem so very close to getting there, that I hope a way can be found to render these files so they stay at the correct frame rate to allow cleaning, without being speeded up etc, and will then allow me to keep the soundtrack in lip synch.
    Perhaps Gelinox knows of how I can achieve my aims.
    Quote Quote  
  18. Originally Posted by Filmboychris View Post
    Thatís a nice tutorial.
    I have kind of worked out the basics with Film9 and it really does have great potential as restoration software, especially as it is freeware and seems powerful in what it can do.
    Perhaps Gelinox knows of how I can achieve my aims.
    Yes it does have potential.
    It can make cine film look amazing.
    I have proof of that.
    Perhaps Gelinox will help, he is very kind.
    Last edited by super8rescue; 11th Apr 2021 at 05:20.
    Quote Quote  
  19. Member
    Join Date
    Dec 2014
    Location
    France
    Search PM
    As johnmeyer stated, I confirm that it is not possible to correct correctly if adjacent frames are the same.
    Film9 is based on the use of Avisynth and several Plugins which work in temporal mode, ie on several images.

    For those who are new to Avisynth, there are several filters to remove duplicate images, such as TIVTC. But there are others.
    This type of fault often occurs with captures made in teleprocessing.
    Film9 does not have this ability to remove duplicate images.

    Nevertheless, I recall:
    - "Without Synchro" Mode is mainly intended for films captured in the stream with a projector speed of 16.6 fps in PAL and 20 fps in NTSC.
    In this mode only, Film9 will remove the scrambled images, provided you have respected these projection speeds.
    However, this type of capture can be improved by applying certain modifications to the projector, such as speed regulation, removing the blades (as indicated by John).
    Preferably use CMOS sensors rather than Rolling-Shutter. And, there are other tips for using this capture mode, but that's not the point.

    - "With Synchro" Mode is only intended for videos in which each frame is equal to the original film. As already indicated, you need image-video = image-film.

    - "Tape" Mode is intended for analog videos which have been directly digitized. But beware, some DVDs from the teleprocess may have duplicate images.


    To help Filmboychris, maybe he could upload a clip of 30 seconds max that we can analyze.

    And a BIG THANKS to super8rescue for this tutorial.
    Quote Quote  
  20. Member
    Join Date
    Dec 2014
    Location
    Switzerland
    Search PM
    This software was created by Gilles and myself. Gilles replies less often on the English forum, but he can also help you.
    He's even the boss when it comes to using Avisynth and these filters.

    Effectively with an extract, we will be able to see if the problem comes from the video characteristics of your clip.

    I'll just add that for your testing, start trying to process a movie without sound by clicking "Silent Film" in the "Project" window.

    Completely uninstall K-Lite (clean the computer if possible) and reinstall K-Lite MegaPack again directly from Film9's "Preferences" window.
    Then reinstall Lagarith (only after K-Lite).
    Quote Quote  
  21. Member
    Join Date
    Apr 2021
    Location
    United Kingdom
    Search Comp PM
    Thanks for all the replies I have had over this.

    Your combined advice is steering me in the right direction to find a solution.

    I am not working with any actual film scans, only video files that have been created by others.

    Obviously, what I am attempting to do is completely reliant on how the video file has been created each time.

    Some files look like they have been scanned from NTSC video or dvd at 29.97 fps and then converted to 25fps mp4 files.
    Others look like they have been scanned from PAL video at 25 fps , and then converted to 30 fps mp4 files.

    With all these different scan possibilities, trying to determine the duplication pattern and then remove duplicate frames without altering the film dialogue synchronisation is the challenge.
    Creating silent files has solved the original error codes I was seeing as per the start of this thread, and Film9 does then render the file and clean most of the dirt it sees on single frames. Well done guys for creating this great software.
    However, the resultant file then seems to run at the wrong speed to maintain audio synchronisation when I try to match it with the picture on my video editing software, so I am having to play around with adjusting the picture speed, and cut the audio into small chunks to try and keep everything in synch. I'm hoping there is an easier way.

    Unfortunately, the suggestion to upload the file for checking is not possible at the moment, as the file is big and I will need to edit a small clip first.

    I am wondering if there is a way of me being able to analyse the various files I am working with, and determine what scanning method has been used to create the file, so I know how to deal with it for the removal of duplicates.
    My IVTC filter doesn't seem to have the 3:2 pulldown removal option I have heard people speak of that converts ntsc video back to single frames, so I am trying to use the simple frame rate option in virtualdub2 to create new files running at 24fps, which I hope Film9 can then perform it's magic cleaning on.

    Does anyone know if there is a simple setting that can convert a 25fps mp4 file to remove all the duplicate frames whilst still maintaining audio synchronisation? That seems to be the main thing I am seeking.

    Thanks for creating Film9 guys, as it really does go a nice job in restoring these video files I like working with, when I get the settings right that is.
    Quote Quote  
  22. The way I analyze films is to run a one-line AVISynth script containing only

    separatefields()

    I do this because you have to assume that any video you receive might have odd fields that are from different moments in time than the even fields. When the original material is video, and every single pair of fields is from a different moment in time, it is called interlacing. However, when the original material is film, you will often find, as you look at the video which results from "separatefields()" that some of the video fields are from the identical moment in time (you won't see any horizontal motion, just a little up/down motion because the fields are offset spatially), while others are from different moments in time. You may also see duplicate fields, often from adjacent frames. All of this results from the "telecine" process where duplicate fields are added so that 16, 18, or 24 fps film doesn't get sped up when played on an NTSC TV set which operates at a nominal 30 fps.

    To determine what is actually going on, I open this separated video in Virtualdub and use the right arrow key to step through the video one frame at a time. If the original is progressive, I should see two identical fields, then the next field advances in time, but is matched by the next field. This is standard progressive video and is what you want to end up with in order to do film restoration. However, if you don't find nothing but pairs of matching fields, you then have to count how many duplicate fields in a row you find. You also need to do this for at least 30-40 fields in order to find a pattern. Telecine patterns, especially for slower 16 and 18 fps film, can require that you look at a lot of film before you see a pattern.

    Normal 24 fps film that has been telecined to play at 30 fps has a 3:2 pattern, meaning that you will count three identical fields, followed by two identical fields, followed by three, etc. You need to remove each extra field.

    As Gilles confirmed, if you want to do any restoration or improvement on an existing capture, you MUST first remove these duplicates. If you don't, the software will look at two adjacent frames, and if they are duplicates, won't find any dirt spot that is on one, but not the other (which is how dirt removal works) and won't do anything.

    "Inverse telecine" undoes the telecine process and with a clean telecine, such as you usually find with films that are broadcast OTA, the IVTC process can be absolutely perfect, with no artifacts. However, when the duplicate fields come from pointing the camera at a projector screen (or at a FILM9 capture device), you also get blends, where the camera captures one frame and then part of the next frame, before the shutter closes. That produces the equivalent of an old-fashioned double-exposure, a common mistake people made with old still cameras. With two images "baked in" on the same field or frame, you have no choice but to throw out that field or frame and attempt to synthesize a new one. That is what that complicated script attempts to do.
    Quote Quote  
  23. Member
    Join Date
    Apr 2021
    Location
    United Kingdom
    Search Comp PM
    That is a very in depth response.

    I'm feeling a bit out of my depth here.

    I'm afraid I don't understand AviSynth scripting at all.

    It looks like trying to write computer code to my eyes.

    I think the best thing to do is for me to edit a small clip from the file I want to clean, and upload it so you clever guys can analyse it and tell me how it has been captured and converted.

    The file is 25fps mp4, and looking at it frame by frame, it looks to me like there is a random pattern of duplicated frames, where sometimes you get 3 frames that advance in sequence, and then a frame that holds twice, and then perhaps 4 frames advance in sequence followed by 1 that is shown twice, then 3 advance in sequence followed by 1 that is held 3 times etc.
    No wonder this file won't perform cleaning filters in Film9 correctly. It removes the single frame instances of dirt beautifully, but of course leaves the frames where dirt shows for 2 or sometimes even 3 frames.

    I imagine this file has had multiple processing, so that the original 24fps film has seen a conversion to NTSC 29.97fps, followed by another conversion to adjust to PAL 25fps, so the duplications are now very random, and I haven't got the faintest idea of how to get it back to a single frame per image file again.

    My attempts at using IVTC filter in VirtualDub2 are not working out as yet, probably because I don't really know what I am doing, and I am getting rendered files that are either speeded up, slowed down, or look jerky, or only seem to process a third of the film and then stop.
    I can't get my mind round how a file that is 131,261 frames in size and runs for 1 hour and 27 minutes 31 seconds, can be converted to 105,020 frames and still run the same time?
    I am presuming the fps will have to be lowered to achieve this, but at least the resulting file will hopefully allow Film9 to see single frames only, clean all the dirt, and I can then produce a new file at 25fps to make sure I can audio synch everything back again?
    Quote Quote