VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 3 of 4
FirstFirst 1 2 3 4 LastLast
Results 61 to 90 of 114
Thread
  1. the same problem of duration doubled is present trying to export by speed razor. However I think it uses the same directshow avi mux

    Click image for larger version

Name:	AVIMUX.jpg
Views:	149
Size:	557.0 KB
ID:	28777

    so I wonder: can I try to replace the avi mux module present in directshow with another?
    Quote Quote  
  2. I used mainconcept MP4 muxer - can you try that in graphstudio or s**** r**** ?
    Quote Quote  
  3. Remember that AX components ? You can try their AX64 file writer, and/or AX MP4 multiplexer filter as well

    Did you try the "dump" filter jagabo suggested ?

    (everytime I see "dump" I think of this )
    Name:  superpoop.gif
Views: 816
Size:  4.2 KB
    Quote Quote  
  4. Originally Posted by poisondeathray View Post
    I used mainconcept MP4 muxer - can you try that in graphstudio or s**** r**** ?
    you use that to get a mp4 file?
    Quote Quote  
  5. Originally Posted by poisondeathray View Post
    Remember that AX components ? You can try their AX64 file writer, and/or AX MP4 multiplexer filter as well

    Did you try the "dump" filter jagabo suggested ?

    (everytime I see "dump" I think of this )
    Image
    [Attachment 28781 - Click to enlarge]
    the problem of the ax64 is that the speed razor for cats don't see it in list of codecs, is there a way to "see" it?

    I searched the dump in the DSFMGR but I cannot find it, where is downloadable?
    Quote Quote  
  6. Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post
    I used mainconcept MP4 muxer - can you try that in graphstudio or s**** r**** ?
    you use that to get a mp4 file?
    Yes, mainconcept mp4 muxer => file writer in graphstudio (plus)

    Looks ok time wise.. quality.....not so good compared to x264 at the same bitrate


    Format : MPEG-4
    Format profile : Base Media / Version 2
    Codec ID : mp42
    File size : 14.5 MiB
    Duration : 11s 0ms
    Overall bit rate : 11.0 Mbps
    Encoded date : UTC 2014-11-24 16:47:45
    Tagged date : UTC 2014-11-24 16:47:45

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High 4:2:2@L4.0
    Format settings, CABAC : Yes
    Format settings, ReFrames : 4 frames
    Format settings, GOP : M=3, N=33
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 11s 0ms
    Quote Quote  
  7. Maybe s**** r**** can only use "AVI" components ? Have you ever been able to use anything non AVI/VFW even in directshow ?
    Quote Quote  
  8. Originally Posted by poisondeathray View Post
    I used mainconcept MP4 muxer - can you try that in graphstudio or s**** r**** ?
    is called mainconcept MP4 muxer? seems I cannot find it

    Click image for larger version

Name:	MP4MUX.jpg
Views:	105
Size:	632.9 KB
ID:	28782

    or is the Mainconcept MP4 Multiplexer?
    Quote Quote  
  9. Yes, mainconcept mp4 multiplexer - you had the same one in your 1st screenshot on the last page (post 49)
    Quote Quote  
  10. Originally Posted by poisondeathray View Post
    Maybe s**** r**** can only use "AVI" components ? Have you ever been able to use anything non AVI/VFW even in directshow ?
    mm maybe yes, remeber is a program for cats

    however the problem of duration doubled is present also when I try to write file in graphstudio. I'm not able to write mp4 files, but on avi file the duration seems constantly doubled
    Quote Quote  
  11. Can you try the AX components in graphstudio ? Just to see if duration is doubled. If it's not, that suggests some issues with using AVI in your workflow
    Quote Quote  
  12. Click image for larger version

Name:	MC2.JPG
Views:	114
Size:	211.0 KB
ID:	28790

    trying using mainconcept mxf decoder but after the press play, system freeze and I have to kill graphstudio with the task manager

    using ffdshow as decoder, when I press the play button don't do nothing (but ffdshow seems take progressive output also when the interlacing options are cheched)

    How I have configure graphstudio to use ax components?
    Quote Quote  
  13. Click image for larger version

Name:	MC3.jpg
Views:	113
Size:	390.4 KB
ID:	28791

    also trying this:
    but graphstudio don't write the mp4 output file
    Quote Quote  
  14. I don't know, maybe contact rovi/mainconcept ? The other difference was graphstudio next (not graphstudio original), and broadcast avc encoder (422)

    I think the cat gods are sending you another sign to update your NLE
    Quote Quote  
  15. poison a kindness: do you know if exist a patch for the x264vfw that "enable" the paff mode?

    or can I convert with ffmpeg a mpeg_in_avi mbaff file to mp4 paff? thanks
    Quote Quote  
  16. Originally Posted by marcorocchini View Post
    poison a kindness: do you know if exist a patch for the x264vfw that "enable" the paff mode?

    or can I convert with ffmpeg a mpeg_in_avi mbaff file to mp4 paff? thanks
    This was already answered a few times. Not possible.

    You need to hire someone to write a paff branch for x264
    Quote Quote  
  17. I'm trying to use the mainconcept only for proofs of quality, but it different a lot beetween the x264vfw

    When I use the x264vfw I set CRF to 18 and use this additional line

    --tff --range tv --colorprim bt709 --transfer bt709 --colormatrix bt709 --keyint 33 --bframes 1 --sar 1:1 --log-level none

    please poison if I would use the mainconcept can you tell me what parameter I have to set to "equalize" the mainconcept at the same quality of the x264vfw? I don't see the crf, maybe the costant can replace crf? but most of difficulty I have to set the "advanced settings section"
    Quote Quote  
  18. Originally Posted by marcorocchini View Post
    I'm trying to use the mainconcept only for proofs of quality, but it different a lot beetween the x264vfw

    When I use the x264vfw I set CRF to 18 and use this additional line

    --tff --range tv --colorprim bt709 --transfer bt709 --colormatrix bt709 --keyint 33 --bframes 1 --sar 1:1 --log-level none

    please poison if I would use the mainconcept can you tell me what parameter I have to set to "equalize" the mainconcept at the same quality of the x264vfw? I don't see the crf, maybe the costant can replace crf? but most of difficulty I have to set the "advanced settings section"

    Big difference , right?

    In terms of quality and compression? The truth is you can't with Mainconcept, unless you use much larger filesizes. Set a higher bitrate or lower quantizer

    If you mean single pass rate control in general, you can use quantizer based encoding, but it's not quite the same as CRF either. More recent versions have "constant quality, average quantizer", that is the most similar to CRF, but still you need much larger bitrates for similar quality. The directshow version I think lets you enter a range. The values don't correspond to x264's values, so you have to do trial and error
    Quote Quote  
  19. Originally Posted by marcorocchini View Post
    poison a kindness: do you know if exist a patch for the x264vfw that "enable" the paff mode?

    or can I convert with ffmpeg a mpeg_in_avi mbaff file to mp4 paff? thanks
    Maybe if you ask another dozen times he'll change his answer.
    Quote Quote  
  20. Originally Posted by poisondeathray View Post

    If you mean single pass rate control in general, you can use quantizer based encoding, but it's not quite the same as CRF either. More recent versions have "constant quality, average quantizer", that is the most similar to CRF, but still you need much larger bitrates for similar quality. The directshow version I think lets you enter a range. The values don't correspond to x264's values, so you have to do trial and error
    double pass take more quality? seems to me x264vfw have a very high quality
    Quote Quote  
  21. Code:
    AssumeTFF().SeparateFields().SelectEvery(4, 0, 3).Weave()
    or to "resolve": what is the correspondant in ffmpeg?

    theorically I can remux the the doubled duration with ffmpeg to have a correct duration...
    Quote Quote  
  22. Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post

    If you mean single pass rate control in general, you can use quantizer based encoding, but it's not quite the same as CRF either. More recent versions have "constant quality, average quantizer", that is the most similar to CRF, but still you need much larger bitrates for similar quality. The directshow version I think lets you enter a range. The values don't correspond to x264's values, so you have to do trial and error
    double pass take more quality? seems to me x264vfw have a very high quality

    No , 2 pass won't affect it much. x264 is the "gold standard" for AVC encoders . To overcome it's deficiences, you must use higher bitrate with Mainconcept. It's as simple as that. On average you need about 1.3-1.5x the filesize for similar quality as a rough guideline, using typical settings . If you want to use Mainconcept , just factor that in and you'll be fine


    Originally Posted by marcorocchini View Post
    Code:
    AssumeTFF().SeparateFields().SelectEvery(4, 0, 3).Weave()
    or to "resolve": what is the correspondant in ffmpeg?

    theorically I can remux the the doubled duration with ffmpeg to have a correct duration...
    I posted how to do this ffmpeg "reinterlace" in your other threads . It was either the 2nd or 3rd low pass thread There were several variations of how to do it in ffmpeg and with ffbmc, each with pros/cons +/- low pass... Hint: remember -vf tinterlace etc....

    Are you sure remux "fixes" duration ? Hopefully nothing else is "broken"...
    Quote Quote  
  23. I don't know any way to resolve...
    Seems to me that durations is exactly doubles, so I hypotyze that:

    I put the exported .avi from speedrazorforcats5.51 into ffmpeg that have, that should, decimate x2 the duration but...

    is it possible use the -vcodec copy and at the same time half the duration? ^^
    Quote Quote  
  24. upload sample with "double duration"
    Quote Quote  
  25. Click image for larger version

Name:	DURW.jpg
Views:	97
Size:	800.5 KB
ID:	28798

    from the timeline of the dyno-nle I have select 5seconds. If I try export with all other encoder I get a 5seconds of file, but only with the mainconcept and only in "interlaced field" the duration is doubled (5seconds.avi = 10,0 seconds)
    Image Attached Files
    Quote Quote  
  26. ps: duration become 10 seconds , 40 ms if in the advanced settings, the "write end of sequence" is set to yes:

    Click image for larger version

Name:	WREND.jpg
Views:	215
Size:	95.9 KB
ID:	28799

    otherwise is 10,00 (exactly the double)
    Quote Quote  
  27. Member racer-x's Avatar
    Join Date
    Mar 2003
    Location
    3rd Rock from the Sun
    Search Comp PM
    I wonder if outputing as Transport Stream instead of mp4 would correct the duration error? try adding this near the end -f mpegts

    You'll need to output as TS, but the station should be able to use that anyway.
    Got my retirement plans all set. Looks like I only have to work another 5 years after I die........
    Quote Quote  
  28. Member racer-x's Avatar
    Join Date
    Mar 2003
    Location
    3rd Rock from the Sun
    Search Comp PM
    That sample has duplicate frames, that's why it's 10 sec.
    Got my retirement plans all set. Looks like I only have to work another 5 years after I die........
    Quote Quote  
  29. I don't think you can "fix" this, certainly not with "stream copy" . Elementary stream isn't encoded properly

    The cat gods are sending you another sign....
    Quote Quote  
  30. ok but the doubled duration is not guilty of Speed Razor For Cats 5.51, is a problem in output of the mainconcept codec: in fact the same doubled duration is present if you try to encode the C0044.mxf using graphstudio once time in "interlaced fields" and in "interlaced frames"

    when encoding in "interlaced frames" duration is the same of the original c0044.mxf

    when encoding in "interlaced fields" duration is doubled (C0044out.avi)

    Click image for larger version

Name:	MC4.jpg
Views:	112
Size:	622.7 KB
ID:	28801

    seems duplicate frame, considering the attached C0044out.avi really is not a way to cut the frame duplication with ffmpeg to half duration?
    Image Attached Files
    Last edited by marcorocchini; 25th Nov 2014 at 03:06.
    Quote Quote