VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 4
FirstFirst 1 2 3 4 LastLast
Results 31 to 60 of 114
Thread
  1. Then contact the vendor for support about the duration (Rovi/Mainconcept) . They will probably say you're using outdated host software.
    Quote Quote  
  2. but I think is not a problem of the catnle

    please poison do you know a software that can use the installed direcshow codec (mainconcept broadcast avc h264) and, similarry to virtualdub, write a mp4?
    Quote Quote  
  3. Originally Posted by marcorocchini View Post
    but I think is not a problem of the catnle

    It doesn't matter what "you" think. If you want it fixed or working , it matters what the vendor thinks

    please poison do you know a software that can use the installed direcshow codec (mainconcept broadcast avc h264) and, similarry to virtualdub, write a mp4?
    Not one that you want to use - Graphstudio / graphedit

    The other commonly used NLE's can export PAFF directly (usually a limited version of the Mainconcept SDK is licensed), and don't have time/duration issues
    Quote Quote  
  4. Did you try this directshow encoder?

    I don't know if it does PAFF or MBAFF, it just says "interlaced"

    http://ax-comp.com/aac-avc-encoders.html
    Quote Quote  
  5. simply I would like to do a proof out of speed razor to check if the problem of the duration persist or not, with graphstudio/graphedit I can encode a .mxf file into a mp4 using the mainconcept directshow codec?
    Quote Quote  
  6. ah don't bother with the AX above, it looks like a wrapper for x264

    Yes, if you encode out of graphstudio and the duration is correct, that suggests problem with speedrazor or at least speedrazor handing off the data to the codc
    Quote Quote  
  7. think I have correctly installed the ax codec (seems good... high422, interlaced ec..) but ..

    Name:  crying_cat2.jpg
Views: 463
Size:  82.4 KB

    speed razor don't "see" the codec in the list of codec altought it seems correctly installed

    Click image for larger version

Name:	AX.jpg
Views:	107
Size:	433.3 KB
ID:	28746
    Quote Quote  
  8. Didn't you read my post above

    It's a wrapper for x264. The preset and tune should be a big hint, but I tested it already and verifed MBAFF, the metadata even says x264
    Quote Quote  
  9. Also, Mainconcept directshow works fine for PAFF encoding duration wise in graphstudio. Problem is likely S**** R**** like I guessed above.

    Just update your NLE already, and all your threads and problems go poof! Vanishing cat act
    Quote Quote  
  10. Originally Posted by poisondeathray View Post
    ah don't bother with the AX above, it looks like a wrapper for x264

    Yes, if you encode out of graphstudio and the duration is correct, that suggests problem with speedrazor or at least speedrazor handing off the data to the codc
    so graphstudio can encode a mp4 using the mainconcept directshow codec?
    Quote Quote  
  11. Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post
    ah don't bother with the AX above, it looks like a wrapper for x264

    Yes, if you encode out of graphstudio and the duration is correct, that suggests problem with speedrazor or at least speedrazor handing off the data to the codc
    so graphstudio can encode a mp4 using the mainconcept directshow codec?
    Yes, and duration is correct (see above post 39, we are juggling posts).. poof!
    Quote Quote  
  12. Originally Posted by poisondeathray View Post
    Didn't you read my post above

    It's a wrapper for x264. The preset and tune should be a big hint, but I tested it already and verifed MBAFF, the metadata even says x264
    but for me is ok also if I encode a mpeg in avi file

    it's a wrapper for x264 what means? that I can use in any way?
    Quote Quote  
  13. Originally Posted by poisondeathray View Post
    Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post
    ah don't bother with the AX above, it looks like a wrapper for x264

    Yes, if you encode out of graphstudio and the duration is correct, that suggests problem with speedrazor or at least speedrazor handing off the data to the codc
    so graphstudio can encode a mp4 using the mainconcept directshow codec?
    Yes, and duration is correct (see above post 39, we are juggling posts).. poof!
    mm sorry poison what is the procedure in graphstudio? Add media file, render media?

    hoewver you get a file pure interlaced using the mainconcept codec, that have a correct duration?
    Quote Quote  
  14. Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post
    Didn't you read my post above

    It's a wrapper for x264. The preset and tune should be a big hint, but I tested it already and verifed MBAFF, the metadata even says x264
    but for me is ok also if I encode a mpeg in avi file

    it's a wrapper for x264 what means? that I can use in any way?

    It' s just a directshow filter for x264. It uses the same x264 libraries . It encodes MBAFF only. So not useful for you
    Quote Quote  
  15. ahh ok
    Quote Quote  
  16. Originally Posted by marcorocchini View Post

    mm sorry poison what is the procedure in graphstudio? Add media file, render media?

    hoewver you get a file pure interlaced using the mainconcept codec, that have a correct duration?
    Yes duration is correct

    Construct a graph,

    1) graph => insert file source (async), select input file

    2) graph => insert filter (add the mainconcept filter).

    3) Connect the pins from output to input of the mainconcept box (drag a line from the boxes). Graphstudio should automatically put in a directshow splitter and decoder, that you have arranged merits for (higher priorities get connected first)

    4) change your settings. Right clicking any box gives you more options, you can check the input and output pins, colorspaces etc...

    5) Insert mainconcept mp4 multiplexer filter, connect the pins

    6) Insert file writer (graph=> insert filter)

    7) push the play button to "encode" it

    (This is for video only. You can do the same thing with audio and plug it into the multiplexer filter)
    Quote Quote  
  17. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    Click image for larger version

Name:	Horse_no_Think.jpg
Views:	281
Size:	22.8 KB
ID:	28751

    'Nuff said.

    Scott
    Quote Quote  
  18. Originally Posted by poisondeathray View Post
    Originally Posted by marcorocchini View Post

    mm sorry poison what is the procedure in graphstudio? Add media file, render media?

    hoewver you get a file pure interlaced using the mainconcept codec, that have a correct duration?
    Yes duration is correct

    Construct a graph,

    1) graph => insert file source (async), select input file

    2) graph => insert filter (add the mainconcept filter).

    3) Connect the pins from output to input of the mainconcept box (drag a line from the boxes). Graphstudio should automatically put in a directshow splitter and decoder, that you have arranged merits for (higher priorities get connected first)

    4) change your settings. Right clicking any box gives you more options, you can check the input and output pins, colorspaces etc...

    5) Insert mainconcept mp4 multiplexer filter, connect the pins

    6) Insert file writer (graph=> insert filter)

    7) push the play button to "encode" it

    (This is for video only. You can do the same thing with audio and plug it into the multiplexer filter)
    I don't know why but I cannot get a final .mp4 from the file writer filter.

    However is there a encoder, like virtualdub, that use directshow filters? it's only for a proof

    please consider I use mc_bc_enc_avc.dll and mc_bc_enc_avc_ds.ax

    mainconcept broadcast ("_bc_") avc encoder
    Quote Quote  
  19. Originally Posted by poisondeathray View Post
    Originally Posted by marcorocchini View Post

    mm sorry poison what is the procedure in graphstudio? Add media file, render media?

    hoewver you get a file pure interlaced using the mainconcept codec, that have a correct duration?
    Yes duration is correct

    Construct a graph,

    1) graph => insert file source (async), select input file

    2) graph => insert filter (add the mainconcept filter).

    3) Connect the pins from output to input of the mainconcept box (drag a line from the boxes). Graphstudio should automatically put in a directshow splitter and decoder, that you have arranged merits for (higher priorities get connected first)

    4) change your settings. Right clicking any box gives you more options, you can check the input and output pins, colorspaces etc...

    5) Insert mainconcept mp4 multiplexer filter, connect the pins

    6) Insert file writer (graph=> insert filter)

    7) push the play button to "encode" it

    (This is for video only. You can do the same thing with audio and plug it into the multiplexer filter)
    I can use the "non"-broadcast mainconcept encoder, however in my proof I cannot get the mp4 file: I don't know why

    Click image for larger version

Name:	GHP.jpg
Views:	107
Size:	100.7 KB
ID:	28765
    Quote Quote  
  20. Originally Posted by marcorocchini View Post
    I don't know why but I cannot get a final .mp4 from the file writer filter.
    That filter should be named "AVI File Writer". It only creates AVI files. Try using Dump. That outputs whatever is input into a file, unmolested.
    Quote Quote  
  21. 1) I originally used ffdshow for video decoder, but I noticed output pin was 4:2:0 and I couldn't get it to decode 4:2:2 properly (thus couldn't encode 4:2:2 properly), so I swapped it out with mainconcept .

    2) Check decoder settings as well, some are set to "deinterlace" by default. You need to disable all processing, esp. deinterlacing. It's called "weave" in many decoders. Never leave any settings on "auto"

    3) Sometimes other splitter might work better, like lav splitter source. I used Mainconcept MXF Demultipexer from file source (async)

    4) I'm using graphstudio next, not graphedit, maybe there is a difference there with the file writer? (it looks like he's using graphstudio) . I've written other things like MKV before so if it's supposed to be AVI only, I don' t know how it works .
    Quote Quote  
  22. Originally Posted by poisondeathray View Post
    4) I'm using graphstudio next, not graphedit, maybe there is a difference there with the file writer? (it looks like he's using graphstudio) . I've written other things like MKV before so if it's supposed to be AVI only, I don' t know how it works .
    You may be right but in the past I've had problems trying to write other types of data with File Writer. And I know there's more than one filter with that name. Is yours qcap.dll?
    Quote Quote  
  23. Yes, it's qcap.dll . It works with the MP4 multiplexer as in his screenshot above. Maybe the MP4 multiplexer is doing the actual muxing and writing?
    Quote Quote  
  24. Click image for larger version

Name:	GP1.jpg
Views:	97
Size:	137.8 KB
ID:	28769

    Click image for larger version

Name:	AVIMUX.jpg
Views:	89
Size:	104.6 KB
ID:	28770

    hoewver using the mainconcept (broadcast or non broadcast) h264 avc codec, when I set in the "frame type" menu --> interlaced frames, I get an avi (mpeg in avi) file that have the same duration of the original.

    When in the "frame type" I set "interlaced fields" ---> the duration is doubled (or almost doubled) and seems there is no option to remediate.

    In the "advanced settings" menu of the encoder, to write an avi file, is possible that is necessary set the [MISC]Timestamp pass throught mode ---> AVI compatible
    Quote Quote  
  25. And I don't think the "regular" encoder can do 422, it's not the right version in your screenshot

    Check advanced settings, post screenshot of that when you switch the encoder
    Quote Quote  
  26. ok but don't change nothing: the problem of the doubled duration remains

    Click image for larger version

Name:	MCB.jpg
Views:	96
Size:	242.5 KB
ID:	28771

    Click image for larger version

Name:	DURAW.jpg
Views:	75
Size:	152.7 KB
ID:	28772
    Last edited by marcorocchini; 24th Nov 2014 at 10:13.
    Quote Quote  
  27. Originally Posted by poisondeathray View Post

    Check advanced settings, post screenshot of that when you switch the encoder
    I have try all possible combinations but the doubled duration remains

    Click image for larger version

Name:	ADV.jpg
Views:	72
Size:	363.9 KB
ID:	28773
    Quote Quote  
  28. Originally Posted by poisondeathray View Post
    Maybe the MP4 multiplexer is doing the actual muxing and writing?
    Maybe I was the one with the "bad' File Writer in the past. For some reason the Win7 64 bit computer I'm on right now doesn't have File Writer at all. I just checked on another Win7 system and I was able to write the output of other muxers with File Writer (qcap.dll).
    Quote Quote  
  29. Originally Posted by marcorocchini View Post
    When in the "frame type" I set "interlaced fields" ---> the duration is doubled
    I think this is the common problem where some decoders don't interpret field-sequential encoding correctly.
    Quote Quote  
  30. I don't think he has the field rate issue - because his screenshot shows 0:11 in the main screen (and interlaced frame, 422 as the input). So everything up to the encoder looks ok. I used mainconcept mxf demuxer (not lav), but I doubt it has any effect since your time looks ok up to the encoder

    I think you already tried it, but I had pulldown: no pulldown, and timestamp pass through was "keep input"

    I dont' know if it makes a difference, but I was using graphstudio next , not graphstudio
    Quote Quote