VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 21 of 21
Thread
  1. Hello everybody,

    I've been using MKVtoolnix for a week, and it was working fine, suddenly it screwed, I add a video and I click on Mux, it goes immediately to "4%" then it stuck and nothing happens.
    I tried to renistall the program, codecs etc, nothing helped, any suggestions?
    Quote Quote  
  2. sounds like theres something wrong with the files your adding. are there any errors after it stops ? have you tried adding a different video ?
    Quote Quote  
  3. Hi Acesn8s,
    thing is... the same file I've "muxed" it couple of time, but I kept doing it because the subs never worked, and then one time this problem happened! so I don't if it conneted with the file why MKVTNIX could mux it before?
    anyhow, I'll follow your advice, and I'll try to check another file and I'll update you, thanks for the reply
    Quote Quote  
  4. Okey guys, I'm really growing sick of it!
    MKVtoolnix: I tried another file as "Acesn8s" recommended, and the same problem happened, I just click on "Mux", it goes to 4% then nothing.
    as for Mkvmerge: it never seem to mix the subtitle for me, I do everything by the manual and it never worked. I still want MKTNIX to work cuz of the "split mode" option.

    so any idea what maybe causing the problem?
    Quote Quote  
  5. Okey, I tried another thing now:
    I used Avidemux, despite the fact that it enever encode the MKV/Mp4 the correct way, I tried to add Subs to it, I added it, "Preview" and it was fine.
    then I saved it, the subs didn't appear in the output file
    I just mentioned it so maybe this information would be useful for helping me.
    Thanks
    Quote Quote  
  6. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    Load your files into mmg, press mux, wait for it to hang, then post a screen shot (making sure both windows are visible).
    Quote Quote  
  7. Ndjamena, thanks for your reply:

    Am not sure if you meant Toolnix or Mkvmerge by "mmg", though I SS for both:


    Mkvmerge:



    This is the result "everything went fine blabla"... but the subs weren't there as well

    mkvmerge v7.3.0 ('Nouages') 32bit built on Oct 22 2014 18:44:01
    'D:\resize\project1.mkv': Using the demultiplexer for the format 'Matroska'.
    'D:\resize\Subs\project-subs.ass': Using the demultiplexer for the format 'SSA/ASS subtitles'.
    'D:\resize\project1.mkv' track 0: Using the output module for the format 'AVC/h.264'.
    'D:\resize\project1.mkv' track 1: Using the output module for the format 'AAC'.
    'D:\resize\Subs\project-subs.ass' track 0: Using the output module for the format 'text subtitles'.
    The file 'D:\resize\project1 (1).mkv' has been opened for writing.
    The cue entries (the index) are being written...
    Muxing took 2 minutes 16 seconds.
    Last edited by userer; 10th Nov 2014 at 03:02.
    Quote Quote  
  8. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    OK

    1: how are you deciding the subtitles aren't there?

    2: have you actually opened your subtitles in a text editor to make sure there's actually something relevant inside?
    Quote Quote  
  9. Alright,

    1: Because I open the output file, the subs weren't mixed.

    2: Yes, I've, and I played the source video with VLC or Classic Player and the subs were shown fine, though there was problem with BSPlayer that in order to show the subs fine I had to save the sub file as "ANSI" .

    and btw, you can take a look on my previous reply above for Avidemux , maybe all these problems are connected.
    I desperately need a help ^_^
    Quote Quote  
  10. Did check output file with mediainfo program?
    Did you select subtitles in VLC by Subtitles -> Sub Track -> Track 1
    Quote Quote  
  11. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    MMG is short for MKVMerge GUI, it's a term that only applies to the old version, and until MKVToolnixGUI is in a much better state than it is, MMG is what you should be using.

    Did you try remuxing the ANSI version into the file?

    Have you checked the output file using MediaInfo?
    Quote Quote  
  12. Okey Guys, update:

    I tried to renistall the whole package, used MKVmerge(Toolnix still face the same issue), opened output with VLC, subs worked but the character encoding weren't correct, though with Classic Player they were shown right, with BSPlayer once I open the file I see a ERROR and BSPlayer crash.


    Thanks for your Patience guys, but I'll ask a dumb question at the moment !
    All these muxing, it isn't actually burning the subs into video file? because I need to upload the video afterwads to a website.
    And why with Avidemux the subs merge isn't working? (I've just checked the output with MediaInfo) !
    because after all, I still need to split the video(since MKVtoolnix is bugged), that's why i'm reasking about Avidemux

    Thanks a lot;
    Quote Quote  
  13. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    So you want to burn in the subtitles, not just mux them in the file?

    Have you tried Handbrake?
    Quote Quote  
  14. Yep, Burn.

    Am reencoding it at the moment with Handbrake, it's at 20%, but anyhow, what's the right way to set in order to get the same quality of the source file?
    Quote Quote  
  15. ndjamena,
    Handbrake is currently encoding, I tried to play the output file, but no subs in it so far
    this is the settings in the program, have I done anything wrong?
    Quote Quote  
  16. Well, ^_^
    I played the file again with VLC player, and it shows me that there are subs but I;ve to enable them through 'Video>Subtitle Track>etc' !
    well, isn't Handbrake a burning subs program? in this case why aren't the subs burnt in the video and i've to enable them? cuz this way it subs won't appear if I pload the video to the web.
    Quote Quote  
  17. well people? any help? there are no burn in option in Handbrake
    Quote Quote  
  18. Thanks a million, works perfectly
    Now I just need a quick tool like MKVtoolnix to split MKV fast, I'll search the net.
    Thanks again guys for your great help,
    Thumbs UP !
    Quote Quote