VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. I have a short clip which contains a few scene-changes; it was edited in AP pro. When I output it and converted it to MP4 (AVCHD) format it has inherited little flickers at the scene changes. (see attachment).

    I have examined the MP4 footage frame-by-frame at the scene-changes and can see that one-frame transitions are present which were not there in the edit. I have not noticed this with any other footage.

    What can be causing these superious frames? Is it just the nature of converting to MP4?

    arktop.mp4
    Quote Quote  
  2. Member
    Join Date
    Jul 2014
    Location
    Denmark
    Search Comp PM
    You might want to try a fixed GOP size (keyframe interval) or lower the scene change sensibility (if possible). Try to encode using ffmpeg with a suitable x264 preset.
    I'm the developer behind FFQueue. My posts might reflect this! ;-)
    Quote Quote  
  3. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    From the visuals, I'm guessing it had a bad time of seeking and so didn't cut exactly on the scene change. Or it was trying to cut on the GOP I-frame (and couldn't?), or both.

    I also notice that it looks like you've incorrectly resized interlaced footage, because you have those telltale thick band jitter artifacts (most noticeable when you pan).

    Start back from scratch and upconvert first from AVCHD to an Intraframe DI format and correctly process the interlacing. Then edit, then convert to MP4.

    Scott
    Quote Quote  
  4. I see no sign of it having been improperly resized; when bobbed there's no interlacing. However, at many of the scene changes there are fields with two fields blended together, sometimes with one being zoomed, sometimes from a different part of the video (I think). In the picture below,the blend is of the previous scene and a zoomed in version of the following scene. I have no idea how it happened, but then I have no idea what 'AP Pro' is, either, and don't use it.
    Image Attached Thumbnails Click image for larger version

Name:	DoubleImage.jpg
Views:	211
Size:	64.0 KB
ID:	28157  

    Last edited by manono; 27th Oct 2014 at 15:07.
    Quote Quote  
  5. Member
    Join Date
    Jul 2014
    Location
    Denmark
    Search Comp PM
    I've seen this happen when a cut is "dirty" (my hard drive recorder does this sometimes) and two frames have the same or similar PTS (presentation timestamp). Don't know the options you have available with your encoder but you might want to force som new timestamps. FFMpeg filter setpts can do this by using -vf "setpts=PTS-STARTPTS" for video and (if present) -af "asetpts=N/SR/TB" for audio.
    I'm the developer behind FFQueue. My posts might reflect this! ;-)
    Quote Quote  
  6. Member
    Join Date
    May 2014
    Location
    Memphis TN, US
    Search PM
    I've seen this as a danger of "editing" very long GOP's with software unable to do it the right way. Some of the GOP's in the sample are longish, some over 125 frames. And a couple of cuts appear to have been made on interlaced frames that were exactly on scene changes in the original long GOPs. Kinda stingy on the bitrate for motion video of this frame size (4Mbps ? ?). Maybe a piece of the original source would help avoid too much guessing.
    Last edited by LMotlow; 27th Oct 2014 at 17:58.
    - My sister Ann's brother
    Quote Quote  
  7. Sorry encoded it at 4mbs to keep filesize small for uploading here. AP pro = Adobe Premiere Pro editing suite.

    Actually we shot some footage on a DSLR at 25P and some on a PAL camcorder at 25i and went for an overall 25i project. This small clip comes from the DSLR amd was 25p originally. However, we were going to work in 25i and the fact that I am not happy with 25p footage due to judder issues I converted it to 50p using a frame doubling script found on this forum (kind of interpolation). And then loaded it into the 25i project.

    The footage when viewed frame by frame in AP does not show the flicker scene-change problem. However, when output to mp4 and played in VCL player it shows the flicker. I am not sure if the the conversion to mp4 has introduced this artefact or if AP is hiding some redudant frames.

    [btw the place is Bukhara in the central Asian republic of Uzbekistan].
    Quote Quote  
  8. Originally Posted by akkers View Post
    ... I converted it to 50p using a frame doubling script found on this forum (kind of interpolation).
    I take it the problems occur only in the material originally sourced from the DSLR? Maybe at the same time reinterlace it to 25i in the script before adding it to the native 25i material.
    Quote Quote  
  9. Originally Posted by LMotlow View Post
    I've seen this as a danger of "editing" very long GOP's with software unable to do it the right way.
    That's my guess. Long GOP, out of order frames, and container issues.
    Quote Quote