VideoHelp Forum

Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 12 of 12
  1. Hello,
    i'm trying to download multiple ts files with ffmpeg.
    I have the m3u8 file but i am getting "HTTP error 403 Forbidden" all the time.

    There are 4 videos on the page, i am trying to download the first video on top off the page.

    ffmpeg output:

    sradic@ubuntu-E6400:~/bin$ cd ~/bin && ./ffmpeg -i "" -c copy ~/videos/76.tsffmpeg version 2.4.git Copyright (c) 2000-2014 the FFmpeg developers
    built on Oct 24 2014 21:07:12 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
    configuration: --prefix=/home/sradic/ffmpeg_build --extra-cflags=-I/home/sradic/ffmpeg_build/include --extra-ldflags=-L/home/sradic/ffmpeg_build/lib --bindir=/home/sradic/bin --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-x11grab
    libavutil 54. 11.100 / 54. 11.100
    libavcodec 56. 9.100 / 56. 9.100
    libavformat 56. 10.100 / 56. 10[/COLOR].100
    libavdevice 56. 1.100 / 56. 1.100
    libavfilter 5. 2.100 / 5. 2.100
    libswscale 3. 1.101 / 3. 1.101
    libswresample 1. 1.100 / 1. 1.100
    libpostproc 53. 3.100 / 53. 3.100
    [http @ 0x3aa95a0] HTTP error 403 Forbidden Server returned 403 Forbidden (access denied)

    What am i doing wrong?

    Thanx in advance
    Quote Quote  
  2. Is this the correct video?
    Try livestreamer instead of ffmpeg;
    livestreamer "hls://" best -o output.ts
    Last edited by blimey; 24th Oct 2014 at 18:32.
    Quote Quote  
  3. Thanx mate, that worked lika a charm
    Quote Quote  
  4. I have the same problem (http error 403 forbidden) with the video hosted on this page: I've tried with ffmpeg, which returns me the same error encountered by beo59. Also, I'm not having any luck with livestreamer, no matter the string I put in.
    It looks like the site is geoblocked outside of Germany, unfortunately.
    This is the m3u8 file ( ) and this is the manifest file ( ), hoping this will be enough info for someone to be able to help me. Thanks in advance
    Quote Quote  
  5. Member nullacht's Avatar
    Join Date
    Jun 2013
    On The Run.
    Search PM
    Originally Posted by getupkid View Post
    I can download the video with this command:

    livestreamer "hds://*~hmac=ffd27911abc5aa41e0d9a2b5198043b6845a42b3348ad91e23f8b5073b691896&g=LQUGOLVWUVYS&hdcore=3.2.0&plugin=jwplayer- pvswf=" best -o 01.flv
    [cli][info] Found matching plugin stream for URL hds://*~hmac=ffd27911abc5aa41e0d9a2b5198043b6845a42b3348ad91e23f8b5073b691896&g=LQUGOLVWUVYS&hdcore=3.2.0&plugin=jwplayer- pvswf=
    [cli][info] Available streams: 1328k, 2628k (best), 340k (worst), 640k
    [cli][info] Opening stream: 2628k (hds)

    Note: The link expires soon.
    Quote Quote  
  6. @nullacht:it works. I didn't have a clue about the pvswf... part of the command line. Very good,I learned something new...thanks again for your help
    Quote Quote  
  7. @nullacht : can I bother you again for another video on this same site? on this page ( ) I am not having any luck with livestreamer using the same command line that seems to be working on pretty much every other video.
    As soon as I enter the string i get a "[cli][info] stream ended" response, with only 1kb of data downloaded. Other videos on the same site give me no problems, just this one.
    These videos are archived for a short time only, that's why I would really appreciate any help here. Thanks
    Quote Quote  
  8. Originally Posted by getupkid View Post
    on this page ( ) I am not having any luck with livestreamer
    Checked both hds and hls for id=s399344, each is working. You must be making some sort of mistake.
    Quote Quote  
  9. @blimey I've tried for at least 10 times with both the hls and hds command lines yesterday without any success..Tried again this morning and it worked on my first try, don't really know how or why, or what I might have done differently though...feeling quite silly now..thanks for having taken the time to look into this
    Quote Quote  
  10. Hey buddy hat's very commen error most of the time faced because our public IP gets restricted from accessing from the content or page but by simply using HackBS|GOM VPN trick*you can easily bypass such issues without any hassle.. It' s worth trying!!
    Quote Quote  
  11. Hello everyone.

    I get the error 403 Forbidden when accessing this video:

    If i'm not wrong, the referer is

    But i cannot access to the video with

    livestreamer --http-header "Referer=" "hlsvariant://" best
    Maybe I have to insert something more in the header... but is strange because with php curl and only this referer it works. Can someone help me, please?
    Quote Quote  
  12. Member
    Join Date
    Feb 2018
    Search PM
    Last edited by sumit; 20th Feb 2018 at 17:34.
    Quote Quote