VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Whenever I download a movie that is an MKV, it usually comes with subtitles. (srt file)

    If I play the movie on my computer I can turn off the subtitles on VLCplayer. However, if I place the movie on a flash drive for my blue ray player, the movie no matter what keeps the subtitles. Even if I delete the srt file and try to disable the subtitles with the remote, they just don't seem to go away.

    The subtitles aren't hardcoded but somehow retain the subtitles. How can I remove them? Thank you.
    Quote Quote  
  2. Member netmask56's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Search Comp PM
    It seems that the MKV file has subs contained within the mkv container as well as the external. Just delete the srt and load the mkv into mkvmergegui and see if there are indeed any internal subs, if so just untick all but the video and audio and remux. No re encoding is involved so no loss of quality.
    BeyonWiz T3 PVR ~ Popcorn A-500 ~ Samsung ES8000 65" LED TV ~ Windows 7 64bit ~ Yamaha RX-A1070 ~ QnapTS851-4G
    Quote Quote  
  3. Worked great.

    Thank you
    Quote Quote  
  4. Member
    Join Date
    Jun 2015
    Location
    Texas
    Search Comp PM
    Well, I had the opposite problem, subs would always display on Media Player Classic for any file type. It was a pain to find where to turn them off at.

    Here is where I went to turn them off in MPC,

    From the menu bar at the top, go to >Play>DirectVobSub (auto-loading version)>Hide Subtitles




    The only reason why I'm posting this, is because I have forgotten this in the past, and it was a complete pain in the but to find out how to turn them off/on again.

    As you can see on the pull down menu from >Play, the subtitle menu option there is grayed out. Why is it even listed there? I wonder if I'm just using an old version of MPC.
    Quote Quote  
  5. If it's muxed into the MKV file, you can also do it via taskbar by right clicking the white haali or LAV icon (If you have it installed or use a codec pack) where all video, audio, subtitle tracks are listed and choosing no subtitles option.
    Quote Quote  
  6. Originally Posted by netmask56 View Post
    It seems that the MKV file has subs contained within the mkv container as well as the external. Just delete the srt and load the mkv into mkvmergegui and see if there are indeed any internal subs, if so just untick all but the video and audio and remux. No re encoding is involved so no loss of quality.
    Thanks it's working
    Quote Quote