VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 10 of 10
  1. Hi, Yesterday I decided to update to the latest version of Format Factory (3.5.5) & now it won't convert anything when the use Avisynth option is enabled, I just get a 'not supported/unrecognized' error.

    I downgraded to the version I was using before but now this too is doing the same thing & refusing to encode anything with Avisynth enabled.

    I use this to convert MKV anime with embedded subtitles to avi/xvid so that my sister can watch them on an old xbox running XBMC in another room & the only way of getting Format Factory to encode with subtitles is by enabling the Avisynth option.

    I've tried installing new versions of Avisynth & uninstalling/reinstalling Format Factory itself yet still nothing seems to fix anything.

    Anyone got any ideas?
    Quote Quote  
  2. Did you delete all the folder locations when you uninstalled. There may be residual files .ini, etc, left over.

    The only other thing I can think of is that sometimes the registry values for Avisynth become corrupted and point to the wrong file location. Unfortunately I can't recall the fix, although it has been mentioned on the forum before so maybe someone else can point you in the right direction.

    Try deleting any instance of FF and avisynth and run CCleaner.
    If you're familiar with it Regedit and Google may be your best tools.

    Edit: might I suggest you change your thread title to 'Problems Using Avisynth and Format Factory'
    You may get more interest.
    Last edited by transporterfan; 18th Aug 2014 at 11:05.
    Quote Quote  
  3. Yeah I manually removed all program folders when I tried the uninstall/reinstall.

    I had a similar problem a few times in the past when I've installed a new version of Format Factory on 3 different systems so it seems that for whatever reason updating that program screws things up somehow. Its part of why I have kept using the older version for over a year, I really regret trying to upgrade it this time although I was hoping it would work as it should this time

    Only reason I keep using Format Factory is because its the best/easiest (Simple drag & drop) program i've found thats able to convert MKV's to other formats while retaining all embedded subtitle, styles & fonts without having to do multiple steps to extract subtitles etc.... which isn't ideal when you have a bunch of episodes.
    Last edited by Stef2010; 18th Aug 2014 at 11:34.
    Quote Quote  
  4. Thanks, I gave that a go yet it produces the same error.

    I've tried just about everything I can think of now, Uninstalled/reinstalled, Gone through the registry etc... Yet nothing seems to get FF working with the Avisynth option enabled yet as I say disabling that means it doesn't do the subtitles.

    Guess that for the time been I'll just have to find another piece of software that can do the subtitles & hope that its just as simple & easy to use as FF is.
    Quote Quote  
  5. Possibly broken DirectShow filters if converting from MKV.
    Quote Quote  
  6. Thanks for the replies so far.

    I tried using some other software today & something called Leawo Video Converter converts my MKV's & retains the subtitles style, Although there do seem to be some odd moments of subtitle font changing.

    Regarding the DirectShow filters, If something is wrong there is there any way to figure out where the issue is & fix it?
    Quote Quote  
  7. Just wanted to say that I seem to have fixed it.

    I downloaded something called Graphedit which I read informed you of broken Directshow filters.
    I dragged one of my mkv files onto it & it crashed, However when I dragged it onto the 64-bit version of the program it loaded & allowed me to play the file without problem.

    This seemed to suggest its an issue with a filter/codec or whatever on the 32-bit side (Format Factory is also 32-bit).

    I then decided to install the K-lite codec pack just to get a bunch of codecs/filters setup, From there I played around with some of the settings (Set FFdshow as preferred filter for mkv/aac) & then Format Factory started working properly again

    Hopefully it continues to work & I have no more problems.

    Would like to thank you for the help, The last one about broken Directshow filters put me looking on the right path
    Quote Quote  
  8. Very good. Glad you got it working. The general concensus is that you should avoid codec packs (they can actually break filters) and K-Lite, although well known, is one of those with a mixed pedigree and can lead to a debate on its own merits (or lack of). Talking of merit system, Google 'merit+video filters' to see why adding packs can be a bad idea). I would have suggested just reinstalling ffdshow.

    NEVER install more than one pack. Pleased you got going again. Fingers crossed.
    Quote Quote  
  9. I usually do stay away from Codec packs as I know how problamatic they can be from past experience & up until the recent problems with Format Factory the only thing I had installed was FFDshow.
    When I started having the problems I did uninstall/reinstall FFdshow a few times, I tried the latest versions & some older one's but nothing solved things.

    I only tried K-lite last night as I read something about it having some checks for broken filters & stuff as part of the installation process & it seems to have been that which found some broken stuff & removed/replaced/reinstalled them or whatever which on top of changing some of the preferred filter settings within its codec tweak settings helped me fix things.

    For now I'll just leave things as they are with K-lite installed since all seems to be working fine for now.

    Thanks again for you help though.
    Quote Quote