VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 10 of 10
  1. Hello,
    I'm trying to convert a .ts file to .vob using TMPGEnc Video Mastering Works 5, but after I have converted the file and attempt to play it, I get weird green pixels appearing on and off throughout the converted file. I have converted alot of .ts files in the past with this software without any problems, so what could be the reason for this? The .ts file I am trying to convert reportedly have these specs: MPEG4 Video (H264) 1920x1080 25fps 6189Kbps. I have tried converting both to PAL and NTSC .vob but the pixels are present in both converted files. Please help! If you need any more info please let me know what and how I go about getting it. Thanks so much for reading, any help appreciated.
    Here is an example of what these pixels look like:
    Last edited by guy24s; 5th Aug 2014 at 08:28.
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Search Comp PM
    Try convert with something else like avstodvd and see if you get same problems. Avstodvd can both output dvd/vob files or mpeg2 files.

    If still same problems the ts might be corrupt and you need to fix it with for example videoredo or something.
    Quote Quote  
  3. Do you see the same thing when playing the TS file? It looks like it might be a decoding problem to me, or maybe the original video is a little corrupt.

    I don't use TMPGEnc Video Mastering Works myself, but it's capable of CUDA decoding (hardware decoding with an Nvidia video card). I'm not sure about other methods. Can you change the decoding method to see what happens?
    Quote Quote  
  4. Thanks for the suggestion of using avstodvd, I will try that and report back if it helped.
    PS: The pixels are not present when playing the TS file, they only appear on the converted files.
    I don't know if maybe my TMPGEnc Video Mastering Works is screwed up all of a sudden, I tried converting a mp4 HD file to VOB and while the result did not have any pixels as in the TS file, the result VOB played very bad with lots of framedrops, sort of like a strobe effect. I don't know what is wrong. I converted files a few days ago with no problems.
    Quote Quote  
  5. Can't get avstodvd to work.. Getting all sorts of error messages. Here's what the log files are saying. Any ideas?



    <2014-08-06 11:05:55>

    <2014-08-06 11:05:55>

    DVD Video Standard: PAL
    DVD Titles number: 1
    DVD Size: 4142/8100 MB (51%)
    DVD Output Setup: ISO UDF Image
    DVD Label: DVD
    DVD Menu: No Menu
    Output Folder: C:\dvd test
    Delete Temp Assets Files: Yes
    Delete Temp Working Files: Yes
    Edit Command Parameters: No
    Post Process Task: Show Progress Status window


    MultiThread: 1
    AVS Video Source Filter: A2DSource
    AVS Audio Source Filter: A2DSource
    AVS UpSize/DownSize Filter: Lanczos4Resize/Spline16Resize
    Frame Adjust Strategy: 1
    PAL SpeedUp: 0
    NTSC SlowDown: 0
    Video Resolution: 0
    Video BitRate Min: 2500
    Video BitRate Level 1: 6500
    Video Profile Level 2: 4500
    Video BitRate Max: 8500
    Keep DVD Compliant Video: 1
    AC3 Audio Encoder: 0
    Force FFmpeg for Long Audio: 1
    DVD Audio Format: 0
    DVD Audio BitRate: 192
    Keep DVD Compliant Audio: 1
    Normalize Audio: 0
    Auto Delay Audio: 1
    DVD Audio Language (Primary): EN - English
    DVD Audio Language (Secondary): EN - English
    DVD Subs Language (Primary): EN - English
    DVD Subs Language (Secondary): EN - English
    DVD Subs Font: Tahoma 16pt (255,255,255)
    Chapters Interval: 5
    Use Source Chapters: 1
    DVD Burning Drive: E: TSSTcorp DVD+-RW SH-216BB D100
    DVD Burning Speed: 4x
    Auto Erase DVD RW: 1
    Unload ActiveMovie library: 0
    Adjust ffdshow at runtime: 1
    Save General Settings: 0

    <2014-08-06 11:05:55>
    Video: C:\Video\video.ts
    Info: AVC - 6189 kbps - 1920x1080 - DAR 1,778 - 25 fps (CFR) - MBAFF - 1:04:10 hours - 96249 frames
    Audio 1: C:\Video\video.ts
    Info: AC3 - 384 kbps - CBR - 6 ch - 48000 Hz - 16 bit - 1:04:09 hours (0 ms delay) - EN
    [MediaInfoLib - v0.7.67]

    <2014-08-06 11:05:55>
    Import("C:\Program Files (x86)\AVStoDVD\Lib\A2DSource.avsi")

    Video = A2DVideoSource("C:\Video\video.ts", CacheFolder="C:\Users\R\AppData\Local\Temp", FrameRate=25, VFR=false)
    # Audio is frameserved by AviSynth just for Preview and Edit purposes.
    Audio = A2DAudioSource("C:\Video\video.ts", CacheFolder="C:\Users\R\AppData\Local\Temp")

    Video = Video.ConvertToYV12()
    Video = Video.Spline16Resize(720,576)

    AudioDub(Video, Audio)

    <2014-08-06 11:05:55>
    Encoding Profile: FFmpeg CBR 1-pass
    Target Video FileSize: 3901,1 MB
    Encoding Parameters: -i "C:\Users\R\AppData\Local\Temp\DVD_0_video_1.a vs" -threads 4 -aspect 16:9 -c:v mpeg2video -b:v 8500k -minrate 8500k -maxrate 8500k -bufsize 2000k -dc 10 -y "C:\Users\R\Videos\DVD_0_video.m2v"

    <2014-08-06 11:10:53>
    Process aborted during Title 1 VIDEO encoding operations.

    Video errors warning skipped by user.

    <2014-08-06 11:10:53>
    FFmpeg Parameters: -i "C:\Video\video.ts" -acodec copy "C:\Users\R\Videos\DVD_0_video_1.ToFix.ac3"

    <2014-08-06 11:12:18>
    Created File: C:\Users\R\Videos\DVD_0_video_1.ac3 (176,2 MB)
    OUTPUT AUDIO INFO: AC3 - 384 kbps - CBR - 6 ch - 48000 Hz - 16 bit - 1:04:09 hours (0 ms delay)

    <2014-08-06 11:12:18>
    BatchMux Parameters: -arglist "C:\Users\R\AppData\Local\Temp\DVD_0_BatchMux. ini"
    BatchMux ini file:
    -d "C:\dvd test\DVD_0\VIDEO_TS"
    -mxp "C:\Users\R\AppData\Local\Temp\ p"
    -l "C:\Users\R\AppData\Local\Temp\DVD_0_MuxMan.lo g"
    -muxman "C:\Program Files (x86)\AVStoDVD\MuxMan"
    -prio LOW
    -palette "C:\Users\R\AppData\Local\Temp\DVD_0_Palette.t xt"
    -v "C:\Users\R\Videos\DVD_0_video.m2v"
    -vidmode LB
    -a1 "C:\Users\R\Videos\DVD_0_video_1.ac3"
    -a1lang en
    -cellfr "C:\Users\R\Videos\DVD_0_video_Chapters.txt"
    -progfr "C:\Users\R\Videos\DVD_0_video_Chapters.txt"
    -chapfr "C:\Users\R\Videos\DVD_0_video_Chapters.txt"


    <2014-08-06 11:12:27>
    Process aborted during DVD AUTHORING operations!

    Check following files for more details:

    AVStoDVD log file <C:\dvd test\DVD_0.log>
    BatchMux log file <C:\dvd test\DVD_0_BatchMux.log>

    For more troubleshooting on Authoring issues, see Help/FAQ/Authoring.

    <2014-08-06 11:12:40>
    Log file created by AVStoDVD Release 2.7.4



    BatchMux version --> 1.3
    Destination Folder --> C:\dvd test\DVD_0\VIDEO_TS
    MuxMan Script File --> C:\Users\R\AppData\Local\Temp\DVD_0_MuxMan.mxp
    MuxMan Log String --> -l "C:\Users\R\AppData\Local\Temp\DVD_0_MuxMan.lo g"
    Folder of the MuxMan executable --> C:\Program Files (x86)\AVStoDVD\MuxMan
    Check presence of MuxMan.exe --> PASSED
    Palette File --> C:\Users\R\AppData\Local\Temp\DVD_0_Palette.txt
    Default Palette --> SUCCESSFULLY REDEFINED
    Segment memory resources --> RELEASED
    Local Stack memory --> RELEASED
    File i/o structures --> DEALLOCATED
    Quote Quote  
  6. Member hech54's Avatar
    Join Date
    Jul 2001
    Yank in Europe
    Search Comp PM
    For the little bit of time I had a cable box that recorded useable TS files, I relied on MPEG-VCR and AviDemux. MPEG-VCR to give me clean MPEG files and AviDemux to straighten out any audio sync problems.
    Quote Quote  
  7. I can't help with avstodvd as I the last time I converted something to DVD format seems like a lifetime ago.

    Until someone else comes along, maybe try opening the ts file with tsmuxer and resaving it as a new ts or m2ts file.... too see if it complains about corruption or offers any errors. Even if it doesn't, sometimes just remuxing can fix problems. You could try converting the newly created ts file instead.
    Or MKVMergeGUI will open ts files and remux them as MKVs, which you could try converting instead of the original. You never know....
    Quote Quote  
  8. Thanks for your suggestions, I'll try it!
    Quote Quote  
  9. Member
    Join Date
    Nov 2003
    West Texas
    Search PM
    You're using ffmpeg 1 pass CBR in AVStoDVD. I'd switch to a 2-pass encode using the HCenc encoder. But as others have pointed out, there may be something messed up in the .ts file.
    Quote Quote  
  10. @guy24s

    could you post a screenshot of 'Codecs'/'Build DirectShow Filters Graph' (from AVStoDVD main menu) of the video.ts file?


    AVStoDVD Homepage
    Quote Quote