VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 11 of 11
  1. Never used Deshaker before ... was following the steps here:
    same shown in several youtube vids.

    Have a 64 bit W7 PC
    Running 32 bit VD ver 1.10
    downloaded latest 32bit plugin of DeShaker (3.0)

    Open VD
    Load an avi (confirmed plays fine with MPC)
    Test run in VD it plays fine
    > video >filters > add > Deshaker ver 3.0
    Select Pass 1
    All as per defaults .. only change was to 'tick' append box (as per DeShaker page help comments)
    then >OK on filter box

    On VD Press output screen button to 'play'

    It starts, and as expected on output screen shows the motion detect lines & dots.
    However around 70-100 frames in, the output screen goes black.
    If I progress to loading again and applying pass2 .... end result in that avi starts to pay then I get message "This frame was not processed in pass1"

    I have tried it on several avi clips ... on some of them it fails with same message immediately not after ~100 frames.

    I must have something fundamentally wrong ... any clues appreciated.
    file info for typical avi files shown:.

    sample 1 is one that fails after ~100 frames

    sample 2 is one that fails straight away.
    (have tried running Deshaker in Interlaced mode ... again it runs pass1, but still fails on pass2
    Image Attached Files
    Last edited by Tafflad; 1st Jul 2015 at 06:35.
    Quote Quote  
  2. For sample1 - h264/AVC in AVI container can be problematic in many programs. Frames can get mixed up / out of order, green frames, black frames . When you don't have frame accuracy, pass1 and pass2 can be different causing the problem

    Don't open it directly in vdub. Open it up with an indexed avisynth script e.g. ffms2, l-smash

    For sample2 , when you load it directly in vdub, what does file=>file information say ? which VFW mjpeg decoder do you have configured currently ?

    What do you mean by fails immediately ? Does it even load ? Can you view it without deshaker in vdub
    Last edited by poisondeathray; 24th Jun 2014 at 17:22.
    Quote Quote  
  3. > what does file=>file information say ?

    For sample 2 ... it says:
    Frame size, fps (Ás per frame): 640x480, 30.000 fps (33333 Ás)
    Length: 750 frames (0:25.00)
    Decompressor: Internal Motion JPEG decoder (MJPG)
    Number of key frames: 750
    Min/avg/max/total key frame size: 32504/38392/40568 (28120K)
    Min/avg/max/total delta size: (no delta frames)
    Data rate: 9214 kbps (0.06% overhead)

    Sampling rate: 16000Hz
    Channels: 1 (Mono)
    Sample precision: 8-bit
    Compression: PCM (Uncompressed)
    Layout: 7 chunks (4.10s preload)
    Length: 400000 samples (0:25.00)
    Min/avg/max/total frame size: 6784/57142/65536 (391K)
    Data rate: 128 kbps (0.04% overhead)

    I have now managed to get it to work, ... setting options in each pass to 'Interlaced' ... was sure I tried this yesterday & it failed.

    All my new videos are progressive so keen to get it to work on the other sample ...
    I can load a clip of if required
    Last edited by Tafflad; 25th Jun 2014 at 04:34.
    Quote Quote  
  4. Originally Posted by poisondeathray View Post
    For sample1 ...

    Don't open it directly in vdub. Open it up with an indexed avisynth script e.g. ffms2, l-smash
    Created simple script file with following line:
    DirectShowSource("E:\Users\Rick\Desktop\clip\sampl e1.avs")
    save as video.avs

    This will open & play within MPC (but strangely not WMP)

    I have tried 'open' within VD - but that failed with error "Downmix of 6 Audio Channels is not supported"

    Why is this ... Mediainfo shows it as 2 Ch only (not 5:1)

    Anyway added 6Chn mixdown function .. and file would then load in VD

    But same as before ... DeShaker starts .. and on Pass1 after 70- 100 frames it goes black screen.
    Last edited by Tafflad; 25th Jun 2014 at 07:38.
    Quote Quote  
  5. DirectShowSource isn't necessarily frame accurate, and can alter the results depending on how you have your directshow filters setup . Use ffms2 or lsmash

    Quote Quote  
  6. I'm missing a step somewhere ... I have ffms2.avsi and ffmsw.dll in teh plugin directory.
    So if I follow my thoughts ... Avisynth should autoload the ffms function (as its avsi)

    I tried to run script in MPC first ...

    LoadPlugin("D:\Program Files (x86)\AviSynth 2.5\plugins\ffms2.dll")

    no joy
    also tried:

    LoadPlugin("D:\Program Files (x86)\AviSynth 2.5\plugins\ffms2.dll")

    both give error "no function named ffms2"

    what am I missing .. (dropped off the 6ch downmix for now)
    Last edited by Tafflad; 28th Jun 2015 at 17:23.
    Quote Quote  
  7. You have MJPEG video and PCM audio in AVI. VirtualDub should be able to open that file directly. Or you can use AviSourc() to open the file in AviSynth if you plan on filtering in AviSynth first. There should be no problems with out of order frames since every frame in MJPEG is a keyframe.
    Quote Quote  
  8. Hi Jagabo .... quick background .... the files will load direct into VD and plays ...
    The issue is when I apply the DeShaker filter ... it fails .. 'PoisonDeathRay' (#2 in thread above) had advised to try loading via Avisynth with with ffms2

    If there is a simpler way to load this ... please do tell.
    Quote Quote  
  9. Don't use "Play" to run the first pass of deshaker. Use File -> Run Video Analysis Pass. Let it run all the way to the end. Then go back and change DeShaker to second pass.
    Quote Quote  
  10. OK tried that
    The only reason I was following the 'play button option' was as per a load of tutorial vids eg:

    Tried your approach and it works .... why have others made it so complex?
    Quote Quote  
  11. The play button will work if your computer is fast enough to perform the first pass of DeShaker in real time. It might even work if your computer isn't fast enough depending on other VirtualDub settings. I think disabling Options -> Drop Frames When Behind will let you "play" the first pass -- as it will force playback to display every frame rather than skipping frames when real time playback isn't possible. Audio will get choppy.
    Quote Quote