VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 3
FirstFirst 1 2 3 LastLast
Results 31 to 60 of 64
Thread
  1. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I'll see if I can do it...
    Quote Quote  
  2. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Originally Posted by jagabo View Post
    That means you don't have Windows' DirectShow set up to read and display M2TS files (you probably need an M2TS reader/splitter like Haali or LAV Filter, and maybe a DirectShow h.264 decoder). But I don't think you need to see the video to cut it (though obviously, it's easier). You can just mark off a 10 second clip in the middle of the file and save it.
    I have to admit that I'm completely at a loss as to what you're suggesting I do here. I can't even begin to figure out how the mark off anything in that M2TS splitter.
    Quote Quote  
  3. Originally Posted by naiera View Post
    I can't even begin to figure out how the mark off anything in that M2TS splitter.
    1) Move the slider to the start of the portion you want to export. Press the Start button.
    2) Move the slider to the end of what you want. Press the End button.
    3) Press the Add button.
    4) Press the Cut button.
    Quote Quote  
  4. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Thanks, but I still can't get the splitter thing to actually open the file.
    Quote Quote  
  5. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Got some unsubbed movies in from Germany today. I MadeMKV'ed the first one (City of Violence), found near perfect subs, muxed it together and played it perfectly in VLC. As usual.

    When I tried it on the Oppo, the video would be all stuttery. It would show an image, wait three seconds, then show another one. I just can't catch a break here!
    Quote Quote  
  6. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I also received Howling today. Just finished it without a hitch. The subs are all italics though, but I won't look a gift horse in the mouth. The italics thing also happened with Hindsight and City of Violence, but not on Snowpiercer (I bring that one up because it's my most recent success).

    Now I need to buy a BD50 to burn Howling on though. Even Snowpiercer fit on a BD25
    Quote Quote  
  7. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    I've been reading the thread again. I'll point out again that the Language for the Video stream in the not-working M2TS is English, while the audio is Korean, while the working one lists both as English. And I'll repeat, did you try setting the video stream to Korean in the broken file, or changing the audio to English if changing the video isn't possible?
    Last edited by ndjamena; 19th May 2014 at 19:54.
    Quote Quote  
  8. Make sure the MKV muxer isn't using header removal compression.
    Quote Quote  
  9. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Originally Posted by ndjamena View Post
    I've been reading the thread again. I'll point out again that the Language for the Video stream in the not-working M2TS is English, while the audio is Korean, while the working one lists both as English. And I'll repeat, did you try setting the video stream to Korean in the broken file, or changing the audio to English if changing the video isn't possible?
    I forgot about that. I shall make a new one with both set to English now. I just turned off the projector, so I won't be able to test it until tomorrow though.
    Quote Quote  
  10. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Originally Posted by jagabo View Post
    Make sure the MKV muxer isn't using header removal compression.
    How do I do that using tsMuxerGUI? Or is there some other program I should subject the MKV file from MakeMKV to?
    Last edited by naiera; 19th May 2014 at 20:17.
    Quote Quote  
  11. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Originally Posted by ndjamena View Post
    I've been reading the thread again. I'll point out again that the Language for the Video stream in the not-working M2TS is English, while the audio is Korean, while the working one lists both as English. And I'll repeat, did you try setting the video stream to Korean in the broken file, or changing the audio to English if changing the video isn't possible?
    Didn't work I changed all three tracks to English in tsMuxerGUI. I also put it through MKVToolNix to make sure that the header compression thing wasn't an issue either.


    EDIT: I'm using that old VoxMan tsMuxerGUI because the new one gives me that "Can't find ttf file for font C" error on SRT files.
    Quote Quote  
  12. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Doing the header de-compression thing to City of Violence didn't work there either
    Quote Quote  
  13. I thought you were trying to play MKV files at some point. Header Removal Compression would apply if you were playing MKV files. Many devices don't support files muxed with the feature.
    Quote Quote  
  14. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Yeah, I figured it didn't mean anything in this regard.
    Quote Quote  
  15. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Since making an almost-proper Blu-ray Disc doesn't seem to be an option with City of Violence and Hindsight, could there be some other way to do it? The Oppo BDP-83 doesn't read NTFS; otherwise it would be easy to just format the USB stick and watch an MKV with the subs put in it.

    I just need to maintain 1:1 picture quality, high definition sound and then add some subs. I have a WDTV Live G3, but I don't trust it to do as good/correct a job as my Oppo. I don't know if it does NTFS either.
    Quote Quote  
  16. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I tried the Oppo BDP-103 at my local AV pusher the other day. I read online that it reads exFat and NTFS, and it works just fine with the MKV files I've been fighting with here. It's not an optimal solution, but it's an acceptable one, to be able to watch the movies as MKV files instead. Now, to find those 500...
    Quote Quote  
  17. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I finally timed some subs acceptably for Good Bye, Lenin!, and it seems to have the exact same problem as City of Violence (German Blu-ray).

    I ripped the subs for Liebe Mauer (Beloved Berlin Wall) off the Hong Kong dvd I was lucky to be able to buy, converted them to 23.976 fps and timed them. When I tried to mux them, tsMuxer didn't like the sound stream. Works fine as an MKV on the Oppo BDP-103, but I've never seen that kind of language track before.

    Bottom line: Stupid German Blu-ray people!
    Quote Quote  
  18. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I just got my Oppo BDP-103 today and I already have a slight problem. I have a German Blu-ray movie that I've added subs to and want to play as an MKV from a USB thumb drive. Problem is, it plays at 29.970Hz! I re-checked the file in MediaInfo, and it is very much a native 23.976Hz video stream, just like the Blu-ray is.

    Any tips? I'm OK with somehow "24Hz flagging" the MKV or some sort of workaround with the player. It's pretty important to me that this works, as playing these self-subbed Blu-rays that didn't work out as AVCHD files (I had an Oppo BDP-83 earlier that did play such files off USB memory) as MKV files was my main motivation for upgrading.
    Quote Quote  
  19. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    Mux it with MKVMerge at (24/1001)*1000 fps with the fix timecodes option, see if that helps.
    Quote Quote  
  20. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I tried selecting 24/1001 under the format specific options, and that didn't help. Was there something else I needed to do, perhaps?
    Quote Quote  
  21. I think he meant you should try the "Fix bitstream timing information" setting at the bottom of the video specific options tab.
    Quote Quote  
  22. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    I'm pretty sure I did that, but I see no label about bitstream or fixing anywhere. I can choose FPS and that's about it.

    Click image for larger version

Name:	mkmergev.jpg
Views:	167
Size:	178.1 KB
ID:	25679
    Quote Quote  
  23. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    Yup '24000/1001p', and the 'Fix bitstream timing information' checkbox under the 'Format specific options' tab of the MPEG4 H.264 stream options in MMG. Do I really need to load up MMG and check what everything is called each time I give advice

    :P

    Anyway, that should be the first thing to try whenever odd things happen, you never know what a reader is looking at to get information.

    The Current version of MakeMKV has been screwing up timecodes lately, if you used that you might consider re-ripping with an older version.

    Someone posted on the MakeMKV forum recently about an Oppo not recognising the existence of an several audio streams in a file, it might be related.
    Quote Quote  
  24. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Originally Posted by ndjamena View Post
    The Current version of MakeMKV has been screwing up timecodes lately, if you used that you might consider re-ripping with an older version.
    Hmm. It does check out as 23.976 when I run it through MediaInfo.
    Quote Quote  
  25. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    It would, MediaInfo only checks the header and glances at the beginning of the stream. I mean MakeMKV has been messing up the actual timecodes in the MKV blocks scattered throughout the entire file. MediaInfo is mislabelling half my DVD rips as VFR despite there being nothing in the Matroska header to indicate such a thing. The Oppo might be a little more sensitive. I'm pretty sure that's going to be causing a lot of problems in the foreseeable future.

    Just something to consider.
    Quote Quote  
  26. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    How far back should I go?
    Quote Quote  
  27. Here's the Windows version:

    Click image for larger version

Name:	spec.png
Views:	233
Size:	39.6 KB
ID:	25680

    Note that the function is greyed out for WVC1 video. Maybe the Mac version doesn't even show it when it's not available. Try an h.264 video and see if the option shows up.
    Quote Quote  
  28. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    As far as I'm aware the problem only began appearing in the current version, any previous version should be fine.

    Or you could try extracting the streams with MKVExtract and then Remuxing them with MKVMerge. That should purge any remnants of bad Matroska timings, assuming that's what the problem actually is.
    Quote Quote  
  29. Member naiera's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Search Comp PM
    Can I MKVExtract on my Mac?
    Quote Quote  
  30. Member
    Join Date
    Sep 2012
    Location
    Australia
    Search Comp PM
    I don't know if there's a gui for it but if you can get MKVMerge you can get MKVExtract, it's all compiled within MKVToolNix.
    Quote Quote