VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 3
FirstFirst 1 2 3 LastLast
Results 31 to 60 of 64
Thread
  1. Originally Posted by videobruger View Post
    @Zeggo
    Perhaps attach the srt together with MediaInfo (View -> Text) for the MP4 file to a post.
    Here's MediaInfo - SRT file attached:

    General
    Complete name : E:\--- Movies to burn to DVD ---\Matador\Matador_1978_S01E01-DenRejsende.mp4
    Format : MPEG-4
    Format profile : Base Media / Version 2
    Codec ID : mp42
    File size : 1.03 GiB
    Duration : 45mn 19s
    Overall bit rate mode : Variable
    Overall bit rate : 3 250 Kbps
    Encoded date : UTC 2011-05-10 05:48:37
    Tagged date : UTC 2011-05-10 06:45:37

    Video
    ID : 1
    Format : MPEG-4 Visual
    Format profile : Advanced Simple@L5
    Format settings, BVOP : Yes
    Format settings, QPel : No
    Format settings, GMC : No warppoints
    Format settings, Matrix : Default (H.263)
    Codec ID : 20
    Duration : 45mn 19s
    Bit rate mode : Variable
    Bit rate : 3 164 Kbps
    Maximum bit rate : 4 831 Kbps
    Width : 720 pixels
    Height : 544 pixels
    Display aspect ratio : 4:3
    Frame rate mode : Constant
    Frame rate : 25.000 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Compression mode : Lossy
    Bits/(Pixel*Frame) : 0.323
    Stream size : 1.00 GiB (97%)
    Writing library : em4v 4.1.6.5
    Language : English
    Encoded date : UTC 2011-05-10 05:48:37
    Tagged date : UTC 2011-05-10 06:45:37

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 45mn 19s
    Source duration : 45mn 19s
    Bit rate mode : Variable
    Bit rate : 80.4 Kbps
    Maximum bit rate : 95.0 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 44.1 KHz
    Compression mode : Lossy
    Stream size : 26.1 MiB (2%)
    Source stream size : 26.1 MiB (2%)
    Language : English
    Encoded date : UTC 2011-05-10 05:48:37
    Tagged date : UTC 2011-05-10 06:45:37

    Menu
    00:00:00.000 : Chapter 1
    00:05:43.720 : Chapter 2
    00:14:13.320 : Chapter 3
    00:18:29.680 : Chapter 4
    00:23:42.720 : Chapter 5
    00:31:58.800 : Chapter 6
    00:35:30.960 : Chapter 7
    00:38:49.080 : Chapter 8
    Image Attached Files
    Quote Quote  
  2. Your .srt is Unicode encoded while Vidcoder (probably) expect UTF-8. Open the .srt in Notepad and change the encoding at the bottom of the Save-As Window.
    Image Attached Thumbnails Click image for larger version

Name:	UTF-8.png
Views:	2566
Size:	14.0 KB
ID:	32440  

    Image Attached Files
    Quote Quote  
  3. Thanks videobruger - that did the trick
    Quote Quote  
  4. I have the same trouble as @Zeggo. I have an MP4 file and a separate SRT file. I need to hardcode the subs in for streaming.

    The subs work when playing on a local media player with sub file selected.

    I run VidCoder 1.5.33.0. I've checked "Burn in" but no matter what I do, no subs are being written into the new output MP4.

    Any suggestions on what could be the issue? And how to fix?

    I attach here the .srt and Media Info. of the mp4.

    General
    Complete name : C:\Users\tiendq\Downloads\LEGOģ Youngest Builders - Letís Build Happy.mp4
    Format : MPEG-4
    Format profile : Base Media
    Codec ID : isom (isom/iso2/avc1/mp41)
    File size : 9.65 MiB
    Duration : 1mn 0s
    Overall bit rate : 1 347 Kbps
    Writing application : Lavf54.63.104

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L3.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 3 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 1mn 0s
    Bit rate : 1 217 Kbps
    Width : 1 280 pixels
    Height : 720 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 25.000 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.053
    Stream size : 8.71 MiB (90%)
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 1mn 0s
    Bit rate mode : Constant
    Bit rate : 126 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 44.1 KHz
    Frame rate : 43.066 fps (1024 spf)
    Compression mode : Lossy
    Stream size : 922 KiB (9%)
    Default : Yes
    Alternate group : 1
    Image Attached Files
    Quote Quote  
  5. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Originally Posted by blueflowerhp View Post
    I have the same trouble as @Zeggo. I have an MP4 file and a separate SRT file. I need to hardcode the subs in for streaming.

    The subs work when playing on a local media player with sub file selected.

    I run VidCoder 1.5.33.0. I've checked "Burn in" but no matter what I do, no subs are being written into the new output MP4.

    Any suggestions on what could be the issue? And how to fix?

    I attach here the .srt and Media Info. of the mp4.

    General
    Complete name : C:\Users\tiendq\Downloads\LEGOģ Youngest Builders - Letís Build Happy.mp4
    Format : MPEG-4
    Format profile : Base Media
    Codec ID : isom (isom/iso2/avc1/mp41)
    File size : 9.65 MiB
    Duration : 1mn 0s
    Overall bit rate : 1 347 Kbps
    Writing application : Lavf54.63.104

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L3.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 3 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 1mn 0s
    Bit rate : 1 217 Kbps
    Width : 1 280 pixels
    Height : 720 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 25.000 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.053
    Stream size : 8.71 MiB (90%)
    Color range : Limited
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.709

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 1mn 0s
    Bit rate mode : Constant
    Bit rate : 126 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 44.1 KHz
    Frame rate : 43.066 fps (1024 spf)
    Compression mode : Lossy
    Stream size : 922 KiB (9%)
    Default : Yes
    Alternate group : 1
    Try rename your subtitle file....remove the special characters and just name it lego.srt. THen import it in vidcoder.

    If that fails try hardcode with Xmedia Recode.
    Quote Quote  
  6. @Baldrick: Tks for your help. I've renamed the srt file but it doesn't work.

    I've tried with Format Factory, the subs are perfect but the video quality is not as good as with Vidcoder.
    Quote Quote  
  7. @Baldrick: I've tried with Xmedia Recode, it works perfect. Tks you a lots.
    Quote Quote  
  8. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Be sure to use h264/avc video in format factory or xmedia recode. And decrease the constant quality/quantizer value for better quality or increase the bitrate under the video encoding settings.
    Quote Quote  
  9. Originally Posted by Baldrick View Post
    Be sure to use h264/avc video in format factory or xmedia recode. And decrease the constant quality/quantizer value for better quality or increase the bitrate under the video encoding settings.
    Tks you a lots. I will try
    Quote Quote  
  10. Thanks for the great software guys!

    Is there a way to change the color of the subtitles when hardcoding?

    I'm trying to sub a black and white video and the default (white) color isn't adecuate for it

    The program itself lacks this configuration, but maybe I can add a line in a cfg file or something?
    Quote Quote  
  11. .srt has font color as a formatting option.
    Quote Quote  
  12. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Quote Quote  
  13. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Updated the guide with:
    You can use Subtitle Edit to change the color in your srt subtitle, In Subtitle Edit open the srt, Mark all (Ctrl+A). Rigth click. Select Color. Save as a new srt. Import it in Vidcoder.

    Thanks to videobruger.
    Quote Quote  
  14. Is there a way to automatically burn .srt when there exists an .srt file with the same filename as the movie being re-coded (e.g., mymovie.mp4 is being re-coded and there exists a mymovie.srt file)?
    I would like to burn subtitles during re-coding of a list of files without having to go through the addition of subtitles manually.
    Quote Quote  
  15. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Originally Posted by Mr_Anderson View Post
    Is there a way to automatically burn .srt when there exists an .srt file with the same filename as the movie being re-coded (e.g., mymovie.mp4 is being re-coded and there exists a mymovie.srt file)?
    I would like to burn subtitles during re-coding of a list of files without having to go through the addition of subtitles manually.
    I don't think so. But you could try click on Picker:None (at top right in latest vidcoder beta) and choose Subtitle selection: First or All and see if it autoloads any subs.
    Quote Quote  
  16. Thanks--I could not get it to work (tried some other picker settings as well).
    Quote Quote  
  17. is it possible to change the subtitles' settings? (size, font etc) because they are not very easily readable if ur bed is not close to the pc..
    Quote Quote  
  18. is it possible to change the subtitles' settings?
    Even though some players/software may support formatting in .srt beside the basics bold, italic, underline, color you should
    never expect it.

    Instead convert your .srt to ass (Aegisub/Subtitle Edit), do the formatting and mux the .ass with the video with MKVToolnix GUI and you can hardcode it in VidCoder/HandBrake.
    Quote Quote  
  19. Originally Posted by videobruger View Post
    is it possible to change the subtitles' settings?
    Even though some players/software may support formatting in .srt beside the basics bold, italic, underline, color you should
    never expect it.

    Instead convert your .srt to ass (Aegisub/Subtitle Edit), do the formatting and mux the .ass with the video with MKVToolnix GUI and you can hardcode it in VidCoder/HandBrake.
    unless i just make everything bold by adding the bbcode. that will work for me, thanks anyways.
    Quote Quote  
  20. Member
    Join Date
    Feb 2014
    Location
    Croatia
    Search Comp PM
    My srt file is ANSI. Can I change the settings in VidCoder? From UTF-8 to what exactly: there are several ANSI options...
    Quote Quote  
  21. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Originally Posted by Arbok View Post
    My srt file is ANSI. Can I change the settings in VidCoder? From UTF-8 to what exactly: there are several ANSI options...
    Wont it work fine with default ASCII? Or do you get strange characters?
    Quote Quote  
  22. Member
    Join Date
    Feb 2014
    Location
    Croatia
    Search Comp PM
    Actually, I get some character missing.
    Quote Quote  
  23. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Try ISO-8859-2 then.

    ISO-8859-2 Latin 2
    Latin-written Slavic and Central European languages: Czech, German, Hungarian, Polish, Romanian, Croatian, Slovak, Slovene.
    Or maybe try convert your srt to utf8.
    Quote Quote  
  24. Member
    Join Date
    Feb 2014
    Location
    Croatia
    Search Comp PM
    I tried with ISO-8859-2 and now only 1 character isn't showing, "ě"!
    It's definitely an improvement, but I'm still opened for suggestions.
    Last edited by Arbok; 4th Dec 2017 at 17:17.
    Quote Quote  
  25. Member
    Join Date
    Feb 2014
    Location
    Croatia
    Search Comp PM
    Ok, I tried converting the subtitle file to UTF8 and worked just fine, so that's sorted. Now I have another question: why is my output file significally larger than the input file? Input file is 1.49 GB and output is 2.75 GB! I didn't touch anything in Vidcoder settings. Is there a way to avoid such change in file size? Here's the Mediainfo slip from the input file, if it helps.
    Image Attached Thumbnails Click image for larger version

Name:	mi.jpg
Views:	107
Size:	117.6 KB
ID:	43914  

    Last edited by Arbok; 4th Dec 2017 at 18:24.
    Quote Quote  
  26. Member
    Join Date
    Feb 2014
    Location
    Croatia
    Search Comp PM
    And here's the output file:
    Image Attached Thumbnails Click image for larger version

Name:	mioutput.jpg
Views:	115
Size:	111.7 KB
ID:	43916  

    Quote Quote  
  27. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    You didn't do nothing, but since vidcoder has not direct stream copy for video, your compression settings gets almost twice bitrate. Check overall bitrate in last post. 4611 and in first it is about 2500. You will hurt quality size when reencoding video, which is must be when hardcoded subtitles. To keep same size, use 2pass encoding with same video bitrate as original video has. And it has around 2000 Kbps in your original post.
    And do nothing actually spoiled your audio quality. AAC codec in vidcoder isn't much great, if you want your original quality keep, so in audio tab set it to auto passthrough.
    Bernix
    Last edited by Bernix; 5th Dec 2017 at 03:04.
    Quote Quote  
  28. Member
    Join Date
    Feb 2014
    Location
    Croatia
    Search Comp PM
    Bernix, that nearly did the trick, although I couldn't find 2pass encoding in the settings. All in all, the result is more than satisfactory! Tnx!
    Quote Quote  
  29. Member Bernix's Avatar
    Join Date
    Apr 2016
    Location
    Europe
    Search Comp PM
    Hi,
    glad it helped. Two pass encoding is in Video encoding tab. It is above average bitrate. You can set final size of video in MB. Two pass is much more better than average bitrate in terms of quality at same size. I suggest next time use this with turbo first pass, and of course switch to constant frame rate instead of variable bitrate that is default(lots of trouble) and frame rate same as source.
    If you have no trouble with Variable frame rate VFR it doesn't mean others can't or your other devices can have problem as well.
    Bernix
    Quote Quote