VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 10 of 10
  1. When using ffmpeg to transcode large MKV files to smaller MP4 files to play on my phone, there appears in some of the outputted files a footer reading "00:00:00:000" at the bottom of my screen. Oddly, it's visible in Media Player Classic but not Windows Media Player. Is there a command line switch that will prevent ffmpeg from putting this information or instruction in the new file? Thanks.
    Quote Quote  
  2. Originally Posted by wallywalters View Post
    Is there a command line switch that will prevent ffmpeg from putting this information or instruction in the new file?
    If it's a sub, add "-sn" to the commandline (without the quotes)

    You can do a quick verification test by encoding , say a 10 second section then playing that back. Add "-t 00:00:10" to the commandline (without the quotes)

    Make sure you move the file , change the name of the file, or that other sub files are not in the same directory (MPCHC might be reading other soft subs in the same directory)
    Quote Quote  
  3. Thanks. Still getting the same results, though. I have also tried it with and without "-metadata timecode= " to no avail.
    Quote Quote  
  4. But you say it's only on some of the output videos ?

    Can use use mediainfo (view=>text) and determine what is different for those source videos that have the problem ?

    Can you post your commandline and maybe a sample that exhibits this problem ?

    Does the "footer" change, like timecode, and is it persistent? Or only at the beginning ? Or only the "00:00:00:000" entry ?
    Quote Quote  
  5. Thanks again. Now we're getting somewhere. I just compared two files -- one with the footer and one without -- and the information below is only in the MediaInfo report of the one with the footer, so it's these "menu" listings that are the problem. The question now is what's the CLI switch to keep them out of the output files?

    Menu #1
    ID : 3
    Codec ID : text
    Duration : 1mn 0s
    Language : English

    Menu #2
    00:00:00.000 : 00:00:00.000
    Quote Quote  
  6. So that was the input file ? What does mediainfo say about that output file?

    What is your current commandline ? If you didn't specify copy all streams -c copy -map 0 , it shouldn't have been copied over

    ie. If you only specified video and audio, that's what you should be getting; the other stuff should be dropped
    Last edited by poisondeathray; 17th Apr 2014 at 18:02.
    Quote Quote  
  7. My command line is: "%ffPath%\ffmpeg.exe" -threads 4 -y -i "%~nx1" -f mp4 -sn -c:v libx264 -r:v 23.976 -vf scale=720:404 -aspect 2.35 -crf 19 -coder 1 -c:a libvo_aacenc -b:a 96k -ar 48000 -ac 2 -t 0:01:00 "%~n1 (NEW).mp4"

    As for the MediaInfo report on the input file, this notation appears below the audio section (and it's the only entry that isn't in the MediaInfo report on the input file that doesn't produce the footer):

    00:00:00.000 : en:00:00:00.000

    Should I be looking at the "map" switch to ignore the item called "Menu?"
    Quote Quote  
  8. I'm not sure . Does the menu show up as a separate stream in ffmpeg or ffprobe ?


    ffmpeg -i input.ext

    It will say something like

    0:0 video
    0:1 audio

    You can try adding -map 0:0 -map 0:1 to specifically call the 1st video, 1st audio stream
    Quote Quote  
  9. ok add
    -map_chapters -1
    This worked on a couple test videos I had. If it doesn't work for you, please post an input sample
    Quote Quote  
  10. That did it. Thank you very much. The way I was going, I never would have found that on my own.
    Quote Quote