VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 4 of 4
  1. Hello. This is my first post here.

    I create videos from various sources, mostly camcorder footage, which I script with avisynth, then save with virtualdub. I also use ffmpeg and mencoder in Linux (which I prefer over Windows). When saving videos, one of my preferred options is to save some of my work as uncompressed avi files, to save on too much processing work for each avisynth script. This method worked well until I had to reinstall Windows.

    I installed the KLite codecpack and ffmpeg, avisynth-2.5 and virtualdub-1.10.4.

    Since starting out, virtualdub won't save uncompressed avi files when I check "fast recompress". I want to avoid conversion YUV > RGB > YUV, which occurs when using "full processing". When saving, it looks like it's saving the file properly, but the resultant files are only a few kB in size. When trying to open these files again with virtualdub, the video only shows as a green block of the correct size. Saving with the xvid codec with "fast recompress" works with no problem.

    It may be possible that I could use ffmpeg, but I don't want to learn how to do this in Windows (I already know the Linux syntax), when I don't even know if it will work. I have tried looking at K-Lite's Codec Tweak Tool, but can't see how that could help me.

    Can anyone here possibly help?
    Quote Quote  
  2. Member
    Join Date
    Jul 2013
    Search PM
    To save a file without compression, select video / compression and brand (Uncompressed RGB / YCbCr)

    I hope that's what you want

    The syntax for ffmpeg is equal in linux and windows
    Quote Quote  
  3. And ffmpeg can be compiled with .avs support

    An option is to use lossless video compression instead of uncompressed to reduce the filesize of your avs intermediates e.g. ffv1, utvideo codec
    Quote Quote  
  4. My problem with ffmpeg for windows is that I really don't like trying to use cmd when I use BASH for most things. I tried imagemagick, but found use of inverted commas and things are all different and what I've read about ffmpeg is that the filters and switches are the same, but you don't type the same stuff.

    I'd be happy to go for the option of using lossless codecs (as long as they can work on Linux as well as Windows), so that is a kind of solution that I might go with, but it doesn't explain why uncompressed video won't save. There's nothing to configure, so how can I configure it?!

    What I didn't mention is that when I reinstalled Windows, I did try Windows 7 first, but ditched it when I had this same problem, so I went back to XP expecting everything to work the way it had for the last two or three years.
    Quote Quote  

Similar Threads