VideoHelp Forum

+ Reply to Thread
Results 1 to 3 of 3
  1. Member
    Join Date
    Dec 2013
    Search Comp PM
    Hi there, I experience this quite often - not always.

    1. Input: .MOV (iMovie export, h.264 or mpeg-4)
    2. MP4 H.264 mencoder preset
    3. CABAC, bframes, two-pass (its' the same w/out two-pass)
    4. Possibly pointless: space in filename

    Video compression works like a charm, I tried to copy the *.264 elementary stream while audio was normalized and it is perfect.

    When muxing occurs, this happens:

    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    configuration: --enable-memalign-hack --enable-mp3lame --enable-gpl --disable-vhook --disable-ffplay --disable-ffserver --enable-a52 --enable-xvid --enable-faac --enable-faad --enable-amr_nb --enable-amr_wb --enable-pthreads --enable-x264
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    built on Apr 15 2006 04:58:19, gcc: 4.0.1 (Apple Computer, Inc. build 5250)
    Input #0, h264, from '/Volumes/temp/14 Dimitris Kazakis.264':
    Duration: N/A, bitrate: N/A
    Stream #0.0, 25.00 fps(r): Video: h264, yuv420p, 1280x720
    Input #1, wav, from '/Volumes/temp/14 Dimitris Kazakis.wav':
    Duration: 00:21:56.6, start: 0.000000, bitrate: 1411 kb/s
    Stream #1.0: Audio: pcm_s16le, 44100 Hz, stereo, 1411 kb/s
    Output #0, mp4, to '/Volumes/temp/14 Dimitris Kazakis.aac.mp4':
    Stream #0.0: Audio: aac, 48000 Hz, mono, 64 kb/s
    Stream mapping:
    Stream #1.0 -> #0.0 [sync #0.0]
    Press [q] to stop encoding
    size= 10766kB time=1316.6 bitrate= 67.0kbits/s
    video:0kB audio:10283kB global headers:0kB muxing overhead 4.694838%
    Adjusting AVC SizeLength to 16 bits
    AVC-H264 import - frame size 1280 x 720 at 25.000 FPS
    Adjusting AVC SizeLength to 24 bits
    Import results: 32916 samples - Slices: 580 I 32960 P 32292 B - 1 SEI - 578 IDR
    IsoMedia import - track ID 1 - Audio (SR 48000 - 1 channels)
    Saving /Volumes/temp/14 Dimitris Kazakis.mp4: 0.500 secs Interleaving
    Encoding completed on Thu Dec 12 17:58:55 CET 2013

    It results into a completely black video track...
    Now I'm using a work-around by copying the elementary 264 stream during audio compression, then I use MKVToolnix to mux and Quicktime7 to export.

    Is there something that could be fixed?
    Quote Quote  
  2. Member
    Join Date
    Dec 2013
    Search Comp PM
    Just checked... same result with no blank spaces in the whole path.
    Apparently it depends on video (large 720p export from iMovie, not always).

    I forgot to mention it... of course I registered ffmpegX, years ago!

    If at least the "Keep Elementary Streams" option was working, I wouldn't have to keep the eye on the exact moment of audio encoding in order to copy the .264 stream (which is good!)
    Last edited by panet; 8th Jan 2014 at 07:08.
    Quote Quote  
  3. Member
    Join Date
    Dec 2013
    Search Comp PM
    Still pending…
    For the time being when I compress files from iMovie I create before a folder with the exact target name.
    I get an error, I have elementary streams, and the I mix them with MKVToolnix (with a further export/reincapsulation from QTP7)
    Quote Quote  

Similar Threads