VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 35
Thread
  1. Hello everybody,

    I'm converting some MOD video to the MP4 format, using the free Video-To-Video converter. The convertion works bad.
    I tryed with "Same As Source" and "Highest" quality options and I always got some artifacts:

    in motion scenes, I can see frames crossed by some horizontal lines. It seems that odd horizontal lines and even horizontal lines have been misplaced of a little.

    Is it a convert options problem? That is: can I resolve my issue with a convenient choice of convertion options?

    Thanks you for care
    Quote Quote  
  2. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Not making much sense.

    Upload a short sample which illustrates the problem.
    Quote Quote  
  3. MOD files are standard definition interlaced files. Sounds like you are converting to progressive mp4 without properly deinterlacing.

    (edit: this sentence is wrong -- Based on a quick perusal of their website, your software does not appear to have the option to do this.)

    Try a different software such as handbrake.
    Last edited by smrpix; 12th Nov 2013 at 18:44.
    Quote Quote  
  4. Thank you for answers.

    I uploaded two frames from the original and converted videos. In the last one you can see:

    - fuzzy edges;
    - a wrong aspect ratio: indeed, the original video size is 770 x 430, while the converted video size is 720 x 580.

    Do you think I can solve these issues changing convertion options?

    Here are the actual convertion options:

    Convert to: MP4 movie (*.mp4)
    Extension: *.mp4
    Length: 4:01.888

    Quality: "7-highest" (this option changed by me: the default value was "custom")

    Video codec: mpeg4
    Extension: *.mp4
    Video size: original
    Video aspect: auto
    Video bitrate: 4680
    Video framerate: auto

    Audio codec: aac
    Audio bitrate: 128
    Audio sampling: 44100
    Audio channels: 2 stereo
    Audio disable: no
    Sync A/V: no
    Audio stream index: default
    Volume: 1/8

    Target filesize: unlimited
    Two pass encoding: no
    Deinterlace: no
    Keep aspect: yes
    Spin: no
    Flip: no

    Thanks for care
    Image Attached Thumbnails Click image for larger version

Name:	before-the-convertion.png
Views:	539
Size:	766.4 KB
ID:	21198  

    Click image for larger version

Name:	after-the-convertion.png
Views:	602
Size:	830.9 KB
ID:	21199  

    Quote Quote  
  5. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    When I said 'sample' I really meant an actual video sample but, if I understand you correctly, you wish to keep the video's subjects anonomous. Fair enough.

    The combing artifact is the visual representation of interlacing - I see you did not de-interlace when you converted. You can either convert as de-interlaced or simple de-interlace at playback. If you still see the artifact when you de-interlace at playback I recc that you follow the above suggestion and use a different converter.

    The original videos paraeters is odd - did you really mean 770 or should that be 720 ?. Then it is closer to 16:9 and you should convert to 16:9.
    Quote Quote  
  6. Change the deinterlacing option from no to yes. Done.

    Click image for larger version

Name:	v2v.png
Views:	695
Size:	39.0 KB
ID:	21201
    Quote Quote  
  7. Video sizes I wrote are based on rough pixel measurements I took on frames I updated.

    Do you think it would be useful operate on:

    "Deinterlace: no" option?

    I search the web about the MOD video format: it's a JVC proprietary format. See at http://www.fileinfo.com/extension/mod

    where you can read some tech info that I can't understand.

    Thanks for care
    Quote Quote  
  8. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    No need to guess the video size. Install mediainfo and load the videos in to it.

    Post the report here.
    Quote Quote  
  9. Ok, I tried "deinterlace=yes". Convertion stops with error:

    #2140.0: Access violation at address 6252A4D7 in module 'avfilter-3.dll'. Read of address 00000000
    ERROR: Access violation at address 6252A4D7 in module 'avfilter-3.dll'. Read of address 00000000...
    Quote Quote  
  10. I can post now other tech info about source file. Now I'll try to install MediaInfo...

    General
    Complete name : C:\Users\.....\MOV00a.MOD
    Format : MPEG-PS
    File size : 265 MiB
    Duration : 4mn 1s
    Overall bit rate mode : Variable
    Overall bit rate : 9 181 Kbps
    Video
    ID : 224 (0xE0)
    Format : MPEG Video
    Format version : Version 2
    Format profile : Main@Main
    Format settings, BVOP : Yes
    Format settings, Matrix : Custom
    Format settings, GOP : M=3, N=12
    Duration : 4mn 1s
    Bit rate mode : Variable
    Bit rate : 8 615 Kbps
    Maximum bit rate : 8 900 Kbps
    Width : 720 pixels
    Height : 576 pixels
    Display aspect ratio : 16:9
    Frame rate : 25.000 fps
    Standard : PAL
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Interlaced
    Scan order : Top Field First
    Compression mode : Lossy
    Bits/(Pixel*Frame) : 0.831
    Stream size : 248 MiB (94%)
    Color primaries : BT.470-2 System B, BT.470-2 System G
    Transfer characteristics : BT.470-2 System B, BT.470-2 System G
    Matrix coefficients : BT.470-2 System B, BT.470-2 System G
    Audio
    ID : 189 (0xBD)-128 (0x80)
    Format : AC-3
    Format/Info : Audio Coding 3
    Mode extension : CM (complete main)
    Muxing mode : DVD-Video
    Duration : 4mn 1s
    Bit rate mode : Constant
    Bit rate : 384 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Bit depth : 16 bits
    Compression mode : Lossy
    Delay relative to video : -80ms
    Stream size : 11.1 MiB (4%)
    Quote Quote  
  11. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Try de-interlace under playback. What player are you using ? Try mpc-hc or vlc
    Quote Quote  
  12. Originally Posted by monteverde View Post
    I search the web about the MOD video format... you can read some tech info that I can't understand.

    Thanks for care
    Or you can just re-read my post (#3). Why don't you try handrake?
    Quote Quote  
  13. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Ok. I did not see the mediainfo report when I posted my last reply.

    There is nothing wrong with that MOD file. It is just the way you have processed it. The video is essentially 16:9 stored in the same format as a dvd ie 720*576. When it is displayed, the video is stretched to show the correct display aspect ratio.

    What is uncertain is the detail of the converted file. Pls post the mediainfo report of that. I guess you ignored the 16:9 flag and simply converted 'as is'. If the converting program did not recognise the flag and just assumed the video to be 720*576 (hence the squashed picture) or you did not make the appropiate setting, you have no choice but to use another converter.

    You see if we had an actual video example* - we are not concerned with the people in the vid and really this looks quite harmless - we could test this ourselves in the various tools and suggest the best (and easiest) one for you.

    * Of the original, non-converted video
    Last edited by DB83; 13th Nov 2013 at 03:47. Reason: clarity
    Quote Quote  
  14. Thanks all for answers.
    Unfortunately I can't understand words as "16:9 flag" and other technical expressions. I'm just a newbie.

    Now I post one video, it's a 47.3 MB (43 secs).

    I hope you can play this video (download can need some minutes, please wait).

    Thanks for care.

    http://expocabrini.it/materiale/gatto.MOD
    Quote Quote  
  15. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    I notice that vlc does not recognise the AR flag - sorry to be technical but when you deal with video you have to learn the terms.

    I have done a quick conversion using avidemux. The only filtering I have done is to de-interlace.

    Take a look at this and see if it solves your issues.
    Image Attached Files
    Quote Quote  
  16. The deinterlace function causes VTV to freeze. Get rid of VTV. VTV is broken. Use handbrake, avidemux or something similar.
    Last edited by smrpix; 13th Nov 2013 at 15:55.
    Quote Quote  
  17. I'm amazed looking your convertion: it's good!

    Now I'm discarding my convertion tool (Video - to - Video) and I'm installing one of tools you have reported.

    Only a question: comparing your converted video with the original one, I can see that quality is (slightly) got worse. Look at the gray can on the lower left of the frame I uploaded.

    Do you think I will be able to improve video quality using convertion tool you suggested?

    Thank for care.
    Image Attached Thumbnails Click image for larger version

Name:	cat-before-convertion.png
Views:	551
Size:	899.1 KB
ID:	21242  

    Click image for larger version

Name:	cat-after-convertion.png
Views:	282
Size:	1.51 MB
ID:	21243  

    Quote Quote  
  18. If you want smooth motion and good deinterlacing you should use QTGMC() in AviSynth. But that has a pretty steep learning curve. And it's pretty slow. Video only h.264 MKV attached.
    Image Attached Files
    Quote Quote  
  19. The problem illustrated in your screenshots is mainly from the bitrate used. DB83 just did a quick example for demonstration purposes - notice the filesize of original was 47.3MB vs 16.4MB . If he had used a higher bitrate (lower crf value) resulting in larger filesizes - those details would have been retained

    But you will get higher quality results with avisynth and QTGMC as jagabo suggested
    Quote Quote  
  20. Thanks for answers.

    Is quality control easy in handbrake or avidemux ?

    NB: Matrioska format is out for me: my TV set only read MP4 format.
    Quote Quote  
  21. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    I really suggest that you try out avidemux. It can be as easy or as complicated as you want it to be. Try it out and post any specific issues you have with it.
    Quote Quote  
  22. Originally Posted by monteverde View Post
    NB: Matrioska format is out for me: my TV set only read MP4 format.
    I uploaded MKV because that's what I usually use. The tools I used can also output MP4. Or you could easily remux into MP4 with free tools.
    Quote Quote  
  23. I finally discarded Video to Video, but I noted that another program was installed on my PC with it. It's name is:

    LAV Filters 0.55.3 (Hendrik Leppkes)

    I discarded it too.

    Now I have Avidemux 2.6.6

    I run the program and loaded my MOD video, then I...

    - changed output format from AVI Muxer to MP4 Muxer
    - changed Video output to Mpeg4 AVC (x264)
    - changed Audio output to AAC (Faac)

    Then I saved the video (MP4 extension)

    Well, the combing artifact is still present.

    Must I change any other options?
    Quote Quote  
  24. Deinterlace?
    Quote Quote  
  25. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    If you read my reply when I posted the sample, I mentioned that the only filtering I did was to de-interlace. Go to the Video Menu, chose filters and one of the options under 'interlacing'. If memory serves me I simply selected the top one which works very quickly. Some of the others are probably better but are very slow. You must also chose the field-order of your source which in your case is 'Top'

    You can go straight to filters by clicking the icon under the video selection.

    You must also go into the x264 confiruration menu, select the Output 1 tab and change the Pixel Aspect Ratio to 16:9 otherwise you still end up with a square picture.
    Quote Quote  
  26. Thanks for your useful tips.

    I tried your options set, but convertion was wrong. Here there is what I did:

    - Opened the MOD file
    - Video Output: Mpeg4 AVC (x264)
    - Filters: Interlacing - Decomb decimate - [+] - Ok - Close the window
    - Configure: Output 1 tab - Aspect ratio: PAL 16:9
    - Audio Output: AAC (lav)
    - Output Format: MP4 v2 muxer
    - Saved with a new name

    Combinig artifact is still there.

    However I don't understand your sentence: "set the fiels-order of source: Top"

    Very thanks for your care
    Quote Quote  
  27. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    It is quite possible that you are using a later version of avidemux to mine. My top selection is 'DGBob'

    When I click the '+' button to add that filter to the project I get another window where I have to select the field-order of the source.It defaults to 'bottom' but your source is top field so it must be changed. Interlaced video is made up of two fields and you must ensure that you have selected the field that is displayed first else you have display issues.

    You get the field-order from the mediainfo report.

    DeComb decimate does not have that option. Someone with more knowledge of interlacing could explain why.
    Quote Quote  
  28. Yes, now it works! Thank so much.

    I selected the dgbob filter and I left default options:

    Top Field First: checked
    Mode: Keep nb frames and fts
    Threshold: 12
    Extra: not checked

    I'm grateful to you.

    Now another question about Avidemux and convertion quality.

    If I open Configure Video - General tab, I can set the Quality scroll bar, from 0 (high quality) to 51 (low quality).

    All I want is that: "converted file quality" has to be equal (or slightly lower) than "source file quality".

    Is it a bad question?

    Have I to set cursor to "high quality" or I have to go by trials and errors?

    Thanks for your care
    Quote Quote  
  29. Originally Posted by monteverde View Post
    - Filters: Interlacing - Decomb decimate - [+] -
    I don't use AviDemux, but to me Decomb Decimate doesn't mean deinterlacing at all, but frame removal. If the original framerate was 25fps, did it become 20fps afterwards?
    Quote Quote  
  30. Well, I've done some test. All has gone bad around quality.

    I post a report with a detail of my video (the gray tank on the bottom left corner, at the 39-th second).

    All of my guesses are worst than original.

    Also note the increasing file sizes while quality has (slightly) improved.

    At the maximum quality level I get a file size that is x4 than original file size, yet quality is too less.

    Must I surrender and lose my original quality?

    Alas, the MOD format is only read by my camcorder and by Windows Media Player, not by my TV set and other devices.

    Thanks for care.
    Image Attached Thumbnails Click image for larger version

Name:	confronto.png
Views:	272
Size:	1.16 MB
ID:	21289  

    Quote Quote  



Similar Threads