VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Member
    Join Date
    Oct 2013
    Location
    United States
    Search PM
    I think this has been answered before, however I had tried all suggested remedies read. From "taking control" to command prompt. The folder is located in Local Disk (C / Program Files (x86) / Foldername. And every which way I've tried in command prompt, from direct address, to vague - it reads invalid switch - +/- c:/addressThen in taking control - I am the admin and I have rights to change it. I am thoroughly baffled. I cannot properly update this folder with it being stranded as read only. And every new folder I create in or around the C: is forever ... Read-Only. The option is greyed, but upon selection to remove the read-only, it only returns back to default. It's frustrating. What is it I'm missing? The windows is Windows7 x64bit.
    I am administrator and all permissions collectively allow me to run/change things except that, apparently.
    Quote Quote  
  2. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    What is it you're trying to do? The folders themselves *are* usually read only.
    Quote Quote  
  3. Originally Posted by davexnet View Post
    The folders themselves *are* usually read only.
    The folders themselves are *always* read only.

    You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/326549
    They that give up essential liberty to obtain a little temporary safety deserve neither liberty or safety.
    --Benjamin Franklin
    Quote Quote  
  4. Member
    Join Date
    Oct 2013
    Location
    United States
    Search PM
    Originally Posted by davexnet View Post
    What is it you're trying to do? The folders themselves *are* usually read only.
    I am trying to disable the Read-Only attribute. I would like to allow them to change via outside source. You see, the program itself within the folders cannot nor will not run *because* of the Read-Only being selected. However, I cannot make any permanent changes to this option no matter what way I try. I do Not Want it to be Read-Only.C;/, I am aware, is Read-Only. But the file within Program Files(x86) I do not want to be read-only.
    Example; C:/Program Files(x86)/Test <-- Test is Read-Only. I do not want this file to be a Read-Only. I want the source to be able to update this file Properly, however the source - which is an internet update - cannot proceed due to the file consistently being stuck as Read-Only.
    To work around this problem, use the Attrib command at a command prompt (Cmd.exe) to view or to remove the Read-only or the System attributes of folders.
    To view or to remove the Read-only or the System attributes of folders

    Warning If you remove the Read-only or System attribute from a folder, it may appear as a ordinary folder and some customizations may be lost. For example, Windows customizes the Fonts folder and provides a special folder view that permits you to hide variations, such as bold and italic. It also permits you to change the folder's view settings in ways that are specific to fonts. If you remove the Read-only and System attributes of the Fonts folder, these customized view settings are not available. For folders that you have customized by using the Customize tab of the folder's Properties dialog box, the folder icon and other other customizations may be lost when you remove the Read-only attribute.

    If a program cannot save files to a folder with the Read-only attribute, such as My Documents, change the Read-only attribute to System by using the Attrib command at a command prompt.

    Note If the Run command is not listed on the Start menu, do the following: Click Start, click All Programs, click Accessories, and then click Run.

    To remove the Read-only attribute and to set the System attribute, use the following command:attrib -r +s drive:\<path>\<foldername>
    For example, to remove the Read-only attribute and to set the System attribute for the C:\Test folder, use the following command:attrib -r +s c:\test
    Be aware that some programs may not operate correctly with folders for which the System attribute and the Read-only attribute are set. Therefore, use the following command to remove these attributes:attrib -r -s c:\test

    I have tried this, My result is "Invalid Switch"
    Last edited by wickedrabies; 13th Oct 2013 at 22:23.
    Quote Quote  
  5. Member Budman1's Avatar
    Join Date
    Jul 2012
    Location
    NORTHWEST ILLINOIS, USA
    Search Comp PM
    Try going to the folder in question and right clicking and choose properties. Click the security tab and highlight your user(yourname) and click edit.
    Click image for larger version

Name:	ScreenHunter_35 Oct. 13 23.24.jpg
Views:	1569
Size:	53.5 KB
ID:	20528

    Highlight your name again or add it if it isn't there and click full control. It always works for me in Windows 7:
    Click image for larger version

Name:	ScreenHunter_35 Oct. 13 23.25.jpg
Views:	1422
Size:	41.8 KB
ID:	20529
    I know you are administrator but Windows 7 seems to mean THE administrator Administrator not User administrator. You should also be able to facilitate the attributes as mentioned and the files inside the folder should now be accessible also
    Quote Quote  
  6. Member
    Join Date
    Oct 2013
    Location
    United States
    Search PM
    Originally Posted by Budman1 View Post
    Try going to the folder in question and right clicking and choose properties. Click the security tab and highlight your user(yourname) and click edit.
    Image
    [Attachment 20528 - Click to enlarge]


    Highlight your name again or add it if it isn't there and click full control. It always works for me in Windows 7:
    Image
    [Attachment 20529 - Click to enlarge]

    I know you are administrator but Windows 7 seems to mean THE administrator Administrator not User administrator. You should also be able to facilitate the attributes as mentioned and the files inside the folder should now be accessible also
    Did that too. ^^;;There is only one user to edit - and that is self. And under the network, too, it's all selected to be changeable. In fact, to test it myself, I unchecked all the things for both local and self-user. I don't know of any other way to get to THE Administration outside of being the admin self to do it. There are no other users on the computer. Outside the network.
    So in summary - I defaulted both computer and local network to not be able to change the file at all, which worked. To the self and network being able to change it and admin have all permissions...
    This did not work. It is simply a grey check, where as another computer is a blue square that simply doesn't allow admin to change it.
    (Multiple computers to try this with)
    One, which was originally troubled with crashing for so much as being left on too long, Willingly allowed me to change the same program folder within Program Files(x86) - It remains as a readable file, same windows and same setup as the current problem.
    Quote Quote  
  7. Member Budman1's Avatar
    Join Date
    Jul 2012
    Location
    NORTHWEST ILLINOIS, USA
    Search Comp PM
    Good call Jagabo (as always)! Might also check the UAC settings (Click start, type UAC, and select Change User Access Control Settings)
    Keep mine set at default so it always gives me a hassle but it's easy to fix. Compare your 2 computers also.
    Click image for larger version

Name:	ScreenHunter_35 Oct. 14 11.00.jpg
Views:	824
Size:	19.8 KB
ID:	20535
    Quote Quote  
  8. aBigMeanie aedipuss's Avatar
    Join Date
    Oct 2005
    Location
    666th portal
    Search Comp PM
    win7 seems to put stricter control over /windows, /program files, and /program files(x86) folders so you might try moving the folder out of there or if it's a program re-install it outside of those folders.
    --
    "a lot of people are better dead" - prisoner KSC2-303
    Quote Quote  



Similar Threads