VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 4 of 4
Thread

Threaded View

  1. I have a video mp4 (avc, aac) file. The voice only comes out of one speaker and the music only comes out of the other. I'm trying to extract and duplicate the audio track so I can get music and voice out of both speakers and then remux the files.

    I extracted the video/audio tracks with MyMP4Box Gui, then duplicated, mixed and rendered the tracks in Audacity. I used the FFmpeg plugin with Audacity to import and export .aac. Then I remuxed the files using MyMP4Box Gui. But now the new mp4 has a different length and is out of sync.

    One possibly important thing I should mention is that the source mp4 file has a different duration in MPC and only MPC (28 min. 40 sec) compared to all other players. Every other player and video software I've tried -- VLC, KMPlayer, WMP, etc., Mediainfo and all video editors show the same time as each other (26 min 19 sec).

    After remuxing all players (including MPC) and video editors show the file as 31 min 33 sec.

    Just as a test I demuxed the files and then immediately remuxed them without making any alterations and the file still is 31 min and 33 secs in length and still out of sync.


    So what is going on here and how can I fix the file like I want?
    Quote Quote  
  2. Member DB83's Avatar
    Join Date
    Jul 2007
    Location
    United Kingdom
    Search Comp PM
    Anyone's guess but upload a mediainfo report of the original and the remuxed file as something sure has changed.
    Quote Quote  
  3. DECEASED
    Join Date
    Jun 2009
    Location
    Heaven
    Search Comp PM
    Just to be on the safe side...

    make sure the video stream doesn't have open GOPs, and also make sure you DON'T have an outdated version of MP4Box.exe

    http://forum.doom9.org/showthread.php?t=156110
    Quote Quote  
  4. Doh I should have compared both files in Mediainfo to begin with. The source file's FPS was 29.970 and the remuxed file's FPS was 25. In MyMP4Box the FPS option was set to "No Change" which I wrongly assumed would match whatever FPS the source file was. I changed it to 29.970 and now the file is the right duration and synced.

    Thanks.



    Originally Posted by El Heggunte
    Just to be on the safe side...

    make sure the video stream doesn't have open GOPs, and also make sure you DON'T have an outdated version of MP4Box.exe
    What are open GOPs and how do you check for them?
    Quote Quote  



Similar Threads