VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 31 to 56 of 56
Thread
  1. Lone soldier Cauptain's Avatar
    Join Date
    Jan 2006
    Location
    Brazil
    Search Comp PM
    Originally Posted by danswano View Post
    Thanks Cauptain, anyone here tried this codec before?
    Yes. Its work perfect with Virtualdub. But frameserver is more usefull to me.

    Another tip is look this page:
    http://budmansite.com/ , download virtualdub external codec config and contact Budman1 (videohelp user too) to any doubt.

    Its encode direct to MPEG2.





    Claudio
    Quote Quote  
  2. Thanks Cauptain, you mean i can save as mpeg directly instead of avi using external codec?
    Quote Quote  
  3. Lone soldier Cauptain's Avatar
    Join Date
    Jan 2006
    Location
    Brazil
    Search Comp PM
    Originally Posted by danswano View Post
    Thanks Cauptain, you mean i can save as mpeg directly instead of avi using external codec?
    YES!!!


    Click image for larger version

Name:	YUrOBWD.png
Views:	233
Size:	39.8 KB
ID:	19074

    Claudio
    Quote Quote  
  4. Oh, that's awesome dude, thank you, i will try that today.
    Quote Quote  
  5. Member
    Join Date
    Nov 2002
    Location
    United States
    Search Comp PM
    Here is a copy of my mpeg2 profile if you want to use it with the Virtualdub's external encoder. Just copy with notepad and save as mpeg2.vdprof. Place a copy of ffmpeg in C:\ and you won't have to change anything. I keep most of my encoders in C:\Tools. Place a copy of aften.exe in there if you want to encode ac3.

    Open Virtualdub and under Options > External Encoders > Configure external encoders... choose Import and select the vdprof file that you created (I keep everything in my Tools folder but you can keep them where you want. Maybe a Vdprof folder in VD).

    Code:
    {
        "description": "VirtualDub external encoder profile collection",
        "externalEncoders": {
            "sets": {
                "MPEG AC3": {
                    "videoEncoder": "MPEG-2",
                    "audioEncoder": "AC3",
                    "multiplexer": "MPEG Mux",
                    "description": "mpeg",
                    "extension": "mpeg",
                    "processPartial": false,
                    "useOutputAsTemp": false
                },
                "MPEG AC3 pass": {
                    "videoEncoder": "MPEG-2",
                    "audioEncoder": "ac3pass",
                    "multiplexer": "MPEG Mux",
                    "description": "mpeg",
                    "extension": "mpeg",
                    "processPartial": false,
                    "useOutputAsTemp": false
                }
            },
            "profiles": {
                "ffmpeg muxer": {
                    "name": "ffmpeg muxer",
                    "program": "C:\\ffmpeg.exe",
                    "commandArguments": "-i \"%(tempvideofile)\" -i \"%(tempaudiofile)\"  -vcodec copy -acodec copy \"%(outputname)\"",
                    "outputFilename": "%(outputname).audio",
                    "type": 2,
                    "inputFormat": 0,
                    "checkReturnCode": true,
                    "logStdout": true,
                    "logStderr": true,
                    "bypassCompression": false,
                    "predeleteOutputFile": true
                },
                "AC3": {
                    "name": "AC3",
                    "program": "aften.exe",
                    "commandArguments": "-b 192 - \"%(tempaudiofile)\"",
                    "outputFilename": "%(outputname).ac3",
                    "type": 1,
                    "inputFormat": 1,
                    "checkReturnCode": true,
                    "logStdout": true,
                    "logStderr": true,
                    "bypassCompression": true,
                    "predeleteOutputFile": false
                },
                "MPEG Mux": {
                    "name": "MPEG Mux",
                    "program": "C:\\ffmpeg.exe",
                    "commandArguments": "-i \"%(tempvideofile)\" -i \"%(tempaudiofile)\"  -vcodec copy -acodec copy -f mpeg \"%(outputname)\"",
                    "outputFilename": "%(outputname).audio",
                    "type": 2,
                    "inputFormat": 0,
                    "checkReturnCode": true,
                    "logStdout": true,
                    "logStderr": true,
                    "bypassCompression": false,
                    "predeleteOutputFile": true
                },
                "MPEG-2": {
                    "name": "MPEG-2",
                    "program": "C:\\ffmpeg.exe",
                    "commandArguments": "-f rawvideo -s %(width)x%(height) -r %(fpsnum)/%(fpsden) -i - -vcodec mpeg2video -bf 2 -b 6000k \"%(tempvideofile)\"",
                    "outputFilename": "%(outputname).m2v",
                    "type": 0,
                    "inputFormat": 0,
                    "checkReturnCode": true,
                    "logStdout": true,
                    "logStderr": true,
                    "bypassCompression": false,
                    "predeleteOutputFile": true
                },
                "ac3pass": {
                    "name": "ac3pass",
                    "program": "C:\\ffmpeg.exe",
                    "commandArguments": "-i - -acodec copy \"%(tempaudiofile)\"",
                    "outputFilename": "%(outputname).ac3",
                    "type": 1,
                    "inputFormat": 0,
                    "checkReturnCode": true,
                    "logStdout": true,
                    "logStderr": true,
                    "bypassCompression": false,
                    "predeleteOutputFile": false
                }
            }
        }
    }
    EDIT: Looks like I was too slow.

    I raised the bitrate to 6000 in the video encoder, 3000 was too low. You can raise the bitrate in Aften also depending on your source. Anytime I have AC3 as source, I just do passthrough with ffmpeg (ffmpeg will do mp3 passthrough also but no aac passthrough).
    Last edited by DarrellS; 28th Jul 2013 at 16:51.
    Quote Quote  
  6. Thank you DarrellS, i will try it.
    Quote Quote  
  7. I've imported your script but how to save as mpeg?
    Quote Quote  
  8. Member
    Join Date
    Nov 2002
    Location
    United States
    Search Comp PM
    You have to use the external encoder. Under File, choose Export > Using External Encoder. Select filename and location and click Save.
    Quote Quote  
  9. Got it, thank you very much.
    Quote Quote  
  10. Hey DarrellS,
    What to delete from your code so i keep the m2v and ac3 files in place instead of muxing them into one mpeg file?
    Quote Quote  
  11. Member
    Join Date
    Nov 2002
    Location
    United States
    Search Comp PM
    Under the Encoder Sets Tab in the Exteranal Encoder Configuration window, under Multiplexor, choose none. You could create a new encoder set there called MPEG2 Streams (or something similar) instead and use the same video and audio encoders in the other encoder set but don't use a multiplexor. That way you still have the other encoder sets encase you need to use them. I believe that under file description and file extension, you leave them blank. That way you get the streams with the correct extension. You could also tick the "Process partial output when render is aborted so the streams aren't accidentally deleted.

    I'll check my other encoders and make sure.
    Quote Quote  
  12. The whole movie 1h:53min output size is around 2 G.B, how to increase the output size?
    Quote Quote  
  13. Originally Posted by danswano View Post
    The whole movie 1h:53min output size is around 2 G.B, how to increase the output size?

    filesize = bitrate * running time

    so increase the bitrate
    Quote Quote  
  14. it was 3000k, increased it to 9000k and it only increased 200 m.b
    Is it safe to use for example 100000k ?
    Quote Quote  
  15. Originally Posted by danswano View Post
    it was 3000k, increased it to 9000k and it only increased 200 m.b
    which encoder are you using ? what settings ?



    Is it safe to use for example 100000k ?
    not for DVD
    Quote Quote  
  16. I'm using external mpeg2 encoder for VD
    Here is the mepg 2 part of the code:
    "MPEG-2": {
    "name": "MPEG-2",
    "program": "C:\\ffmpeg.exe",
    "commandArguments": "-f rawvideo -s %(width)x%(height) -r %(fpsnum)/%(fpsden) -i - -vcodec mpeg2video -bf 2 -b 9000k \"%(tempvideofile)\"",
    "outputFilename": "%(outputname).m2v",
    "type": 0,
    "inputFormat": 0,
    "checkReturnCode": true,
    "logStdout": true,
    "logStderr": true,
    "bypassCompression": false,
    "predeleteOutputFile": true
    },
    Quote Quote  
  17. 1) You need to use DVD-complaint MPEG2 encoding settings for ffmpeg . Things like buffer settings, bframes, gop size are adjusted to be DVD-compliant when you use these following presets: Use -target ntsc-dvd if it's interlaced NTSC DVD and , -target film-dvd if it's 24p , -target pal-dvd if it's a PAL dvd

    2) ffmpeg isn't a very good MPEG2 for DVD encoder . Quality is quite poor. I would consider using something else like HCEnc (maybe frameserve to HCEnc)
    Quote Quote  
  18. Originally Posted by danswano View Post
    it was 3000k, increased it to 9000k and it only increased 200 m.b
    You sure you didn't increase just the max bitrate, and not the avg bitrate? If not, then you're doing something very wrong. Even a 3000 average bitrate makes (with the audio and muxing overhead) something close to 3GB, not the 2GB you say you're getting.

    And as pdr suggests, use a better encoder.
    Quote Quote  
  19. Originally Posted by manono View Post
    Originally Posted by danswano View Post
    it was 3000k, increased it to 9000k and it only increased 200 m.b
    You sure you didn't increase just the max bitrate, and not the avg bitrate? If not, then you're doing something very wrong.

    And as pdr suggests, use a better encoder.
    Not sure what you mean, here is the full code:
    {
    "description": "VirtualDub external encoder profile collection",
    "externalEncoders": {
    "sets": {
    "MPEG AC3": {
    "videoEncoder": "MPEG-2",
    "audioEncoder": "AC3",
    "multiplexer": "MPEG Mux",
    "description": "mpeg",
    "extension": "mpeg",
    "processPartial": false,
    "useOutputAsTemp": false
    },
    "MPEG AC3 pass": {
    "videoEncoder": "MPEG-2",
    "audioEncoder": "ac3pass",
    "multiplexer": "MPEG Mux",
    "description": "mpeg",
    "extension": "mpeg",
    "processPartial": false,
    "useOutputAsTemp": false
    }
    },
    "profiles": {
    "ffmpeg muxer": {
    "name": "ffmpeg muxer",
    "program": "C:\\ffmpeg.exe",
    "commandArguments": "-i \"%(tempvideofile)\" -i \"%(tempaudiofile)\" -vcodec copy -acodec copy \"%(outputname)\"",
    "outputFilename": "%(outputname).audio",
    "type": 2,
    "inputFormat": 0,
    "checkReturnCode": true,
    "logStdout": true,
    "logStderr": true,
    "bypassCompression": false,
    "predeleteOutputFile": true
    },
    "AC3": {
    "name": "AC3",
    "program": "aften.exe",
    "commandArguments": "-b 192 - \"%(tempaudiofile)\"",
    "outputFilename": "%(outputname).ac3",
    "type": 1,
    "inputFormat": 1,
    "checkReturnCode": true,
    "logStdout": true,
    "logStderr": true,
    "bypassCompression": true,
    "predeleteOutputFile": false
    },
    "MPEG Mux": {
    "name": "MPEG Mux",
    "program": "C:\\ffmpeg.exe",
    "commandArguments": "-i \"%(tempvideofile)\" -i \"%(tempaudiofile)\" -vcodec copy -acodec copy -f mpeg \"%(outputname)\"",
    "outputFilename": "%(outputname).audio",
    "type": 2,
    "inputFormat": 0,
    "checkReturnCode": true,
    "logStdout": true,
    "logStderr": true,
    "bypassCompression": false,
    "predeleteOutputFile": true
    },
    "MPEG-2": {
    "name": "MPEG-2",
    "program": "C:\\ffmpeg.exe",
    "commandArguments": "-f rawvideo -s %(width)x%(height) -r %(fpsnum)/%(fpsden) -i - -vcodec mpeg2video -bf 2 -b 9000k \"%(tempvideofile)\"",
    "outputFilename": "%(outputname).m2v",
    "type": 0,
    "inputFormat": 0,
    "checkReturnCode": true,
    "logStdout": true,
    "logStderr": true,
    "bypassCompression": false,
    "predeleteOutputFile": true
    },
    "ac3pass": {
    "name": "ac3pass",
    "program": "C:\\ffmpeg.exe",
    "commandArguments": "-i - -acodec copy \"%(tempaudiofile)\"",
    "outputFilename": "%(outputname).ac3",
    "type": 1,
    "inputFormat": 0,
    "checkReturnCode": true,
    "logStdout": true,
    "logStderr": true,
    "bypassCompression": false,
    "predeleteOutputFile": false
    }
    }
    }
    }
    Quote Quote  
  20. Originally Posted by poisondeathray View Post
    1) You need to use DVD-complaint MPEG2 encoding settings for ffmpeg . Things like buffer settings, bframes, gop size are adjusted to be DVD-compliant when you use these following presets: Use -target ntsc-dvd if it's interlaced NTSC DVD and , -target film-dvd if it's 24p , -target pal-dvd if it's a PAL dvd

    2) ffmpeg isn't a very good MPEG2 for DVD encoder . Quality is quite poor. I would consider using something else like HCEnc (maybe frameserve to HCEnc)
    How to use HC with VD?
    Quote Quote  
  21. Originally Posted by danswano View Post
    Not sure what you mean...
    Oh right. Now see it, the 9000 I meant. But I haven't a clue about any of that (and have no desire to learn), so I hand it back to anyone that wants to work with you with frameserving out of VDub. Good luck.
    Quote Quote  
  22. You can either use a lossless intermediate or vdub frameservet. Personally I don't like vdub frameserve , because it frameserves RGB. (you want to avoid unecessary colorspace conversions). But if you used some vdub RGB filters, then it doesn't matter

    See this guide for frame serving
    https://www.videohelp.com/oldguides/virtualdubframeserve

    HCEnc requires avisynth input. So you have to create a simple avs script . See this post
    https://forum.videohelp.com/threads/306504-Frameserve-from-virtualdub-to-HC#1977050

    Or, you can probably use something like avs2dvd, which can use HCenc and can be set to output elementary streams
    Quote Quote  
  23. Thanks, i will try frameserving for now.
    Quote Quote  
  24. In TMPGEnc, what is the best rate control mode for best quality compared to the original DVD?
    Quote Quote  
  25. Member
    Join Date
    Mar 2008
    Location
    United States
    Search Comp PM
    If you're forced to use a low bitrate (for example, you have more that 90 minutes to fit) use 2-pass VBR.
    Try setting the max to about 9000 (this assumes your audio is compressed ie. ac3), minimum to about 500
    and average to your calculated bitrate.

    Which version of Tmpgenc are you using?
    Quote Quote  
  26. I'm using the one on VideoHelp, i need the best quality.
    Quote Quote  



Similar Threads