VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Page 4 of 4
FirstFirst ... 2 3 4
Results 91 to 113 of 113
Thread
  1. Because it takes longer to encode.
    Quote Quote  
  2. In my OP video I took screenshots of frame 37 when I did 8 passes in the avsi file. 8 passes seems best as it removes the most comets. 9 passes or more actually adds comets which I don't understand how that's possible!? I saw an extra comet between the middle and bottom turnbuckle.

    Anyway I'm happy with this. But if anyone knows how I can remove more comets without causing interlacing artifacts to appear then please let me know. In particular the interlacing artifacts are a problem in the 2nd video in my OP.
    Quote Quote  
  3. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    The video doesn't have "interlace" artifacts. It has horribly noisy edges from dot crawl, oversharpening, faulty tape playback, tape duping, re-encoding, over-filtering, and other careless processing, not to mention a tremendous loss of the original detail (what "detail" there is in VHS, anyway, which ain't much). It appears at some point to have been incorrectly deinterlaced for previous processing in some way, then re-interlaced. Or filtered as interlaced with filters that were designed for non-interlaced source. So those edge problems don't look like interlace artifacts IMO. They look like a lot of accumulated bad processing.
    Last edited by sanlyn; 21st Mar 2014 at 10:14.
    Quote Quote  
  4. OK fair enough for that video as it was really bad quality. But what about this video?: Without RemoveSpots. With RemoveSpots
    The video with the removespots script has interlacing artefacts on the crowd in the background when watching the Bluray on my TV. Why does that happen and how can I prevent that? Here's the original unmodified clip (uncompressed AVI) which is 16 seconds long

    For the video I removed the comets in I created an uncompressed AVI with the following script:

    Code:
    setmtmode(5,9)
    AVISource("E:\Raw December 06 1993 to AVI no script.avi")
    setmtmode(2)
    
    SeparateFields()
    Ev=SelectEven().RemoveSpotsMC8x()
    Od=SelectOdd().RemoveSpotsMC8x()
    Interleave(Ev,Od)
    Weave()
    Then I created a h264 file from the AVI with this script:

    Code:
    setmtmode(5,9)
    AVISource("E:\Raw December 06 1993 to AVI removespots.avi")
    setmtmode(2)
    
    McTemporalDenoise(settings="medium", interlaced=true) 
    
    AssumeTFF() QTGMC(Preset="Super Fast") 
    Vinverse() 
    SeparateFields() SelectEvery(4,0,3) Weave()  
    
    Tweak (Hue=0, Sat=1.3 , Bright=10, Cont=1.1, Coring=False) 
    
    ColorYUV(off_u=3, off_v=-0)  
    
    Crop(8,0,-14,-10) AddBorders(12,6,10,4, $000000)
    I also used the 2nd script to create the "without RemoveSpots file".
    Last edited by VideoFanatic; 17th Sep 2013 at 16:37.
    Quote Quote  
  5. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    OK, I'll bite.

    I don't see any interlace artifacts. Have you ever heard of the term "macroblocks"? They are usually low-bitrate compression artifacts.
    http://en.wikipedia.org/wiki/File:Macroblocking_error.png
    Last edited by sanlyn; 21st Mar 2014 at 10:14.
    Quote Quote  
  6. I have a different clip for you where it has obvious interlacing artefacts. I've uploaded it to Dropbox so everyone should be able to download it unlike on Mega.

    Uncompressed AVI clip. I've not done anything to this clip.

    h264 Clips

    h264 clip after Script 1 & 2
    Bluray of the above & also of just script 2 (no removespots)

    MPEG2 Clips

    MPEG2 clip after Script 1 & 2
    DVD clip of the above

    For some reason the interlacing artefacts do NOT show when watching the h264 video on a media player (PS3). Yet when I view the same clip on a Bluray in my PS3 you can see interlacing artefacts. I've tested the Bluray on 2 PS3s so it's not my PS3 that's the problem. I authored with MultiAVCHD and with TSMuxer and got the same result.

    Yet when I make an MPEG2 from my AVI file using the same script and burn it to a DVD I do NOT see interlacing artefacts except for some minor issues (you can see some lines on the top left in the crowd). So perhaps it's Simple x264 Launcher that's causing the problem? I don't see how as I always encode with the TFF option (interlaced). I've never had any problems except when using the RemoveSpots script.

    Is there any way to remove comets without causing interlacing artefacts to appear in the Bluray? I'm beginning to think it's not possible. I might have to resort to upscaling to 720p (I'm looking at THIS page since QTGMC then Nnedi3 looks worse than the original resolution) just to prevent interlacing artefacts from appearing unless anyone has any better suggestions?

    Here's the RemoveSpots.avsi file.

    Script 1
    Here's my RemoveSpots script. I use this to create an uncompressed AVI.

    Code:
    setmtmode(5,9)
    AVISource("E:\Raw December 06 1993 to AVI unedited.avi")
    setmtmode(2)
    
    SeparateFields()
    Ev=SelectEven().RemoveSpotsMC8x()
    Od=SelectOdd().RemoveSpotsMC8x()
    Interleave(Ev,Od)
    Weave()
    Script 2
    Then I created a h264 file from the lossless AVI with this script:

    Code:
    setmtmode(5,9)
    AVISource("E:\Raw December 06 1993 to AVI removespots.avi")
    setmtmode(2)
    
    McTemporalDenoise(settings="medium", interlaced=true) 
    
    AssumeTFF() QTGMC(Preset="Super Fast") 
    Vinverse() 
    SeparateFields() SelectEvery(4,0,3) Weave()  
    
    Tweak (Hue=0, Sat=1.3, Bright=10, Cont=1.1, Coring=False) 
    
    ColorYUV(off_u=3, off_v=-0)  
    
    Crop(8,0,-14,-10) AddBorders(12,6,10,4, $000000)
    If you use script 2 on the uncompressed AVI clip (i.e without the removespots script) you do NOT get interlacing artefacts on the Bluray.
    Last edited by VideoFanatic; 20th Sep 2013 at 14:34.
    Quote Quote  
  7. I think what you're seeing is poor deinterlacing on the part of some players. The fact that one player shows them problems and another doesn't is a very strong hint. Keep in mind that there is no perfect deinterlacing method, especially when it comes to realtime playback. That's why there are so many different deinterlacers. Different software/devices will give different results.

    And please don't make us search through 3600 frames looking for artifacts. Tell us the frame numbers or running time when you see them. And what do you mean by artifacts? Combing? Jagged edges?
    Last edited by jagabo; 20th Sep 2013 at 12:55.
    Quote Quote  
  8. The video is only 30 seconds long. I didn't expect you to manually look through all the frames in an editor. The clip was for viewing on a Bluray disc as that's the only place you'll see the interlacing. I appreciate you may not have a rewritable Bluray disc but there's nothing I can do about that as you only see the problem on a Bluray disc.

    Times you see the interlacing:
    0-1 secs
    4 secs
    9 secs = this is the worst of it.

    Example of interlacing I see. I'm not sure if this is the exact same issue of my video but it's similar:
    http://www.neuron2.net/LVG/inthead.jpg
    Quote Quote  
  9. Jagabo. I created a DVD and Bluray with the same scripts. I played the DVD and Bluray on the same PS3. The DVD shows negligible interlacing artefacts while the Bluray has major ones. I find that incredible!

    Here's a Bluray with 2 videos. With and Without the removespots script. Both videos have identical interlacing issues. So it looks like it's not the removespots script that's causing the problem and that's it's a hardware issue. I find that incredible because the PS3 is considered to be one of the best Bluray players on the market! It doesn't seem to like playing interlaced home recordings very much!


    I tried using a slower QTGMC setting but it made no difference. It seems to be a hardware issue. The only way I can prevent interlacing is by converting to 720p. I tried QTGMC then Nnedi3 double height then downscaled to 720p. It looks worse than the original resolution. So I'm looking at THIS page to see if it does better upscaling.
    Quote Quote  
  10. For upscaling try something along the lines of:

    Code:
    AssumeTFF()
    QTGMC()
    Sharpen(0.7, 0.0)
    nnedi3_rpow2(2, cshift="LanczosResize", fwidth=960, fheight=720)
    aWarpSharp(depth=7)
    AddBorders(160,0,160,0)
    You'll need some noise reduction in there too. Or:

    Code:
    AssumeTFF()
    QTGMC()
    BilinearResize(360,480)
    Sharpen(1.0, 0.0)
    nnedi3_rpow2(2, cshift="LanczosResize", fwidth=960, fheight=720)
    aWarpSharp(depth=7)
    AddBorders(160,0,160,0)
    Again, with some noise reduction somewhere.

    Even sharper:

    Code:
    AssumeTFF()
    QTGMC()
    BilinearResize(360,480)
    Sharpen(1.0, 0.0)
    nnedi3_rpow2(2, cshift="LanczosResize")
    Sharpen(0.5,0.2)
    nnedi3_rpow2(2, cshift="LanczosResize", fwidth=960, fheight=720)
    aWarpSharp(depth=5)
    But this one really needs deblocking and noise reduction before and after scaling. I really dislike this type of sharp scaling -- the sharp edges with lack of detail make it so obvious it was upscaled.
    Last edited by jagabo; 20th Sep 2013 at 22:42.
    Quote Quote  
  11. Thanks for the upscaling tips. They will be useful in future. However just now I'm going to keep it interlaced standard definition because within the PS3 Video menu there is a menu option called "BD/DVD Cinema Conversion". I changed the setting from Automatic to Video and all the interlacing artefacts are gone.


    Here's a description for what it does:


    Set the playback method of video content recorded in interlace format. Video content can include video material (shows or sports programming on TV), film material (movies) or animation material (cartoon programming on TV). Set for the type of video content to be played. In most cases, set to [Automatic].


    Automatic: Set to detect the difference between video, film and animation material automatically and to select the best conversion mode for each material.

    Video: Always play in video material conversion mode.

    Set when [Automatic] does not improve picture quality.

    Hint

    For Blu-ray Discs, this feature is only available when playing discs that are recorded in BDAV format. BDAV is a Blu-ray Disc video format. Generally, when video content is recorded on BD-R or BD-RE media using a Blu-ray Disc recorder, the content is recorded in BDAV format. You cannot use this feature on video content recorded in BDMV format, including most commercially available BD video software (BD-ROM) now on the market.
    Quote Quote  
  12. Not to insult you, but you did encode the material as interlaced, didn't you? Do you have a sample of the finished video we could look at to try and help determine why that automatic setting won't work?
    Quote Quote  
  13. Yes I encoded it as interlaced. See post 96 for all the samples.
    Quote Quote  
  14. Looks OK to me. Then I would guess it's a defect in the PS3 when playing DVD video authored as a Blu-Ray.

    I know some retail Blu-Ray extras are 720x480 and wonder if they would also play with the interlacing showing. But you might need a decent-sized collection of Blu-Rays and then spend some time looking for one to test. Do you or any friends have a standard Blu-Ray player with which to test? To find out if this is something peculiar to the PS3 or not? Or if the two authoring programs you used are somehow at fault?
    Quote Quote  
  15. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    From the "no script" avi sample I made 3 versions that had no problems on my HDTVs or BD players (although they all look kinda goofy in VLC player, but look OK elsewhere). Could use more color work in RGB, but I didn't go there. I managed to use RemoveSpotsMC without resorting to SeparateFields() -- especially since QTGMC was going to be used in all the previous scripts anyway, why bother? Basic method used:
    Code:
    a=last
    v1=RemoveSpotsMC2x(a.SelectEvery(3,0),6)
    v2=RemoveSpotsMC2x(a.SelectEvery(3,1),6)
    v3=RemoveSpotsMC2x(a.SelectEvery(3,2),6)
    Interleave(v1,v2,v3) 
    TurnRight()
    RemoveSpotsMC2x(last,6)
    TurnLeft()
    Got cleaner results resizing with the dither functions for the 1280x720 version:
    Code:
    #--- AVisynth plugins used:
    #- Dither.avsi
    #- mt_xxpand_multi.avsi
    #- avstp.dll
    #- dither.dll
    #- mt_masktools-26.dll (from the dither mod package)
    
    AviSource("path\to\avi\filtered.avi")
    Dither_convert_8_to_16 ()
    Dither_resize16 (1280, 720, kernel="spline36", cplace="MPEG2")
    DitherPost()
    return last
    The source isn't so great to begin with, but it's a shame to kill off so much video because of those comets. I still see a comet or two.

    The bitrates in the O.P.,'s ".ts" and other samples are too low for action video IMHO.
    Image Attached Files
    Last edited by sanlyn; 4th Oct 2013 at 09:17.
    Quote Quote  
  16. The old script works fine by the way once I changed a setting on the PS3 to prevent interlacing artefacts from appearing. The script removes almost all the comets. I finally got some time to try your latest script. Could you clarify the correct usage of your script please. I did the old script as follows:

    I created an uncompressed AVI in VirtualDub:

    Code:
    SeparateFields()
    Ev=SelectEven().RemoveSpotsMC8x()
    Od=SelectOdd().RemoveSpotsMC8x()
    Interleave(Ev,Od)
    Weave()
    Then I used the following 2nd script to make a h264 file from the AVI (I need to do this script seperately as it crashes VirtualDub and is very slow when used with the removespots script):

    Code:
    McTemporalDenoise(settings="medium", interlaced=true) 
    
    AssumeTFF() 
    QTGMC(Preset="Super Fast") 
    Vinverse() SeparateFields() SelectEvery(4,0,3) Weave()
    Latest script

    Code:
    QTGMC(preset="very fast") 
    a=last 
    v1=RemoveSpotsMC2x(a.SelectEvery(3,0))
    v2=RemoveSpotsMC2x(a.SelectEvery(3,1))
    v3=RemoveSpotsMC2x(a.SelectEvery(3,2)) 
    Interleave(v1,v2,v3)  
    TurnRight() 
    RemoveSpotsMC2x() 
    TurnLeft()
    Is the above what I should use for creating the AVI? I tried it without QTGMC and it gave motion problems in the OP video. With QTGMC doesn't work either. It does work but when I use the 2nd script (without the red line as QTGMC was already used in the 1st script) I get interlacing artefacts. So I thought I should maybe not reinterlace in the 1st script then in the 2nd script have interlaced=false for McTemporalDenoise then reinterlace afterwards but that creates a juddery video. It seems that if you want to use McTemporalDenoise and QTGMC then QTGMC must be used after McTemporalDenoise otherwhise you get problems. So for that reason I can't use your script as I quoted it above (if that was the correct usage?).

    Also in the OP video I had to do 4 passes with your new script to get approximately the same effect as the old script. I can remove more comets than the old script by doing 6 passes. 8 passes completely removes all the comets. Either way the new script is a lot slower than the old one.
    Quote Quote  
  17. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    Glad you gave it a try. But why omit essentials parts? I'm afraid you don't understand the script anyway, any more than you understand your own.

    You use QTGMC in your own script for no apparent reason, but you left it out of mine and made absurd complaints about the "Select" statements not working. Please note the following sentence, and read carefully: THE "SELECT" STATEMENTS IN THE LATER SCRIPT DIDN'T USE SEPARATE FIELDS(). Can you guess why those statements work in my script but not in yours? The answer is in the top line of the portion of my script that you posted above, under the heading "Later Script". The complete script, which you didn't use, is attached at the bottom of post #105 as .txt file. That attached script outputs a progressive, non-interlaced AVI at 59.94 fps.

    I don't see any interlace "artifacts" in any of my deinterlacing players, including VLC (with deinterlacing turned on), MPC-BE, MPC, WMP, PotPlayer, nor in my 3 tv's, nor on any of my four DVD/BD players. In fact, I don't see any "interlace artifacts" in your final video, either. Your clip does have a handful of comets that don't appear in mine. However, if what you did was run some of your previous script and then use the same output to run a cut-up portion of my script while cutting out important parts about which you were clueless, then I will be emailing scripts to interested readers from now on, rather than have you criticize something that you screwed up without the slightest idea about what you're doing.
    Last edited by sanlyn; 21st Mar 2014 at 10:16.
    Quote Quote  
  18. Originally Posted by sanlyn View Post
    Glad you gave it a try. But why omit essentials parts? I'm afraid you don't understand the script anyway, any more than you understand your own.

    You use QTGMC in your own script for no apparent reason, but you left it out of mine and made absurd complaints about the "Select" statements not working. Please note the following sentence, and read carefully: THE "SELECT" STATEMENTS IN THE LATER SCRIPT DIDN'T USE SEPARATE FIELDS(). Can you guess why those statements work in my script but not in yours? The answer is in the top line of the portion of my script that you posted above, under the heading "Later Script". The complete script, which you didn't use, is attached at the bottom of post #105 as a .txt file. That attached script outputs a progressive, non-interlaced AVI at 59.94 fps.

    I don't see any interlace "artifacts" in any of my deinterlacing players, including VLC (with deinterlacing turned on), MPC-BE, MPC, WMP, PotPlayer, nor in my 3 tv's, nor on any of my four DVD/BD players. In fact, I don't see any "interlace artifacts" in your final video, either.

    Tell you what, you seem a concientious individual but unfortunately you don't understand your own scripts, much less a script from others. Suggestion: forget that no-separate-fields idea entirely. It's purely of academic interest for those who would like to try something different. You would be better off using your same script and your same four plugins for every video, no exceptions. If that script doesn't get what you want, run the same script again 3 or 4 times (or more) until the results look better to you.

    Originally Posted by VideoFanatic View Post
    Is the above what I should use for creating the AVI? I tried it without QTGMC and it gave motion problems in the OP video. With QTGMC doesn't work either. It does work but when I use the 2nd script (without the red line as QTGMC was already used in the 1st script) I get interlacing artefacts. So I thought I should maybe not reinterlace in the 1st script then in the 2nd script have interlaced=false for McTemporalDenoise then reinterlace afterwards but that creates a juddery video. It seems that if you want to use McTemporalDenoise and QTGMC then QTGMC must be used after McTemporalDenoise otherwhise you get problems. So for that reason I can't use your script as I quoted it above (if that was the correct usage?).

    Also in the OP video I had to do 4 passes with your new script to get approximately the same effect as the old script. I can remove more comets than the old script by doing 6 passes. 8 passes completely removes all the comets. Either way the new script is a lot slower than the old one.
    Not only did you not use the idea correctly, but at this point you're incoherent. Next time, don't blame someone else for something you ****ed up yourself. Sorry I mentioned the idea. But others might profit from it, so I'm leaving it posted.
    Calm down mate, you've blown this out of proportion.

    The average person does not understand "code". However I understand the effect that my scripts have fine otherwise I wouldn't use them. McTemporalDenoise removes picture noise, the removespots script removes comets, etc. I use QTGMC because it removes interlacing artefacts, does a little anti-aliasing and it does cleanup that McTemporalDenoise can't do. I have seen the results with and without QTGMC on test videos long ago and QTGMC DOES do something even when I re-interlace after QTGMC.

    In the original post 105 you made before you edited the post, where you provided the scripts, you never mentioned anywhere in your post that the actual script I should be using was in the attachments. So naturally I tested the first script I saw at the top of your post which was this:

    Code:
    QTGMC(preset="very fast") 
    a=last v1=RemoveSpotsMC2x(a.SelectEvery(3,0)) 
    v2=RemoveSpotsMC2x(a.SelectEvery(3,1)) 
    v3=RemoveSpotsMC2x(a.SelectEvery(3,2)) 
    Interleave(v1,v2,v3) 
    TurnRight() 
    RemoveSpotsMC2x() 
    TurnLeft()
    I never said anything about the "Select" statements not working. I simply gave you the results of using the above script. Everything I said about the results of the above script are true. I thought I was pretty clear in my explanation of the results I saw so I don't know how you can say I was incoherent.

    I appreciate all your work however I said in post 101 that I was keeping my video interlaced. Regardless of whether I keep it interlaced or not the script you posted in the attachments would not be of use to me because as you know I always use McTemporalDenoise and QTMC in my scripts and using McTemporalDenoise after QTGMC causes picture problems as I mentioned (even if I have nothing in my scripts apart from those two plugins). I can't use McTemporalDenoise & QTGMC in the same script (when making a video in VirtualDub) because together they crash VirtualDub (at least when in Multithreaded mode which is a necessity for those slow plugins).

    I didn't blame you for anything, you gave me a script so I tested the results and shared them with you. At what point did I tell you off for mentioning your idea?

    Maybe it doesn't seem like it to you but I've learned a lot from you (and others on this forum) and I'm always grateful for your help.

    I'm quite happy with the old seperatefields comet removal script and doing the 8 passes in the avsi file. The picture quality is great and it removes nearly all the comets. It would be great if I could get a different script that removes more comets but if not, I'm quite happy with the script I already have. I'm making 720 x 480 interlaced videos.
    Quote Quote  
  19. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    Originally Posted by VideoFanatic View Post
    Calm down mate, you've blown this out of proportion.

    The average person does not understand "code".
    Well, thanks for the vote of confidence. But...the "average person" who comes to a forum such as this usually begins to understand code once they start dealing with it. You've been using code for quite a while, but it's frustrating to see you doing odd things like thinking QTGMC at "super fast" is denoising. Look at the QTGMC table of values for the various preset modes and you'll see that most of the denoising isn't turned on at fast presets. Again, throwing MCTD at everything in sight whether it needs it or not in just copying for no particular reason. Turning RemoveSpots onto a video 16 times or more might be necessary, but running MCTD with 16-plus runs of RemoveSpots() at the same time is like chopping a tree repeatedly: in effect, they're both doing the same thing -- which is what I mean by copying code without understanding it. You might try bypassing MCTD sometime and using QTGMC by itself at slower modes. You'll find that using both is seldom necessary. You also don't seem to understand that you can deinterlace with QTGMC and then run umpteen filters afterwards if you want to because most plugins that you're using will work better with deinterlaced video -- afterward, you can reinteelace if necessary. But you seem tied down to "copyjng code" and to thinking that has you can only use QTGMC one way: QTGMC + vinverse + reinterlace. That's not at all true. Anyway, in this case Vinverse was just marking time: there was nothing for it to do.

    I don't know what interlace artifacts you keep talking about. If you run that video deinterlaced and without vinverse, there is no combing. Period. Try it and see. And with 16-plus repetitions of RemoveSpots, there was no need for MCTD.

    Originally Posted by VideoFanatic View Post
    In the original post 105 you made before you edited the post, where you provided the scripts, you never mentioned anywhere in your post that the actual script I should be using was in the attachments.
    Okay, if you need a special invitation that a script is posted, I guess I'll have to include a specific notice.

    Originally Posted by VideoFanatic View Post
    I never said anything about the "Select" statements not working. I simply gave you the results of using the above script. Everything I said about the results of the above script are true. I thought I was pretty clear in my explanation of the results I saw so I don't know how you can say I was incoherent.
    Didn't seem coherent to me. You ran something different than the full script. It seems you were either incoherent or just confused; saying that your script removed almost all the noise is true, but it also removed almost everything else. Perhaps you need better viewing equipment or something, because there is a big difference between results from the two scripts. And I still don't know what "interlace artifact" means, especially since one of the vids I posted was not interlaced.

    Originally Posted by VideoFanatic View Post
    I appreciate all your work however I said in post 101 that I was keeping my video interlaced. Regardless of whether I keep it interlaced or not the script you posted in the attachments would not be of use to me because as you know I always use McTemporalDenoise and QTMC in my scripts and using McTemporalDenoise after QTGMC causes picture problems as I mentioned (even if I have nothing in my scripts apart from those two plugins).
    Thank you again, but...Always? Why always? Once you run QTGMC, why not run MCTD while the clip ia still deinterlaced instead of using interlaced=true or SeparateFields()? MCTD and most filters of its kind get better results from deinterlaced video. There's nothing wrong with doing somwthing like this:
    QTGMC
    MCTemporalDenoise
    ChromaSHift
    DeBlock_QED
    LSFMod
    GradFun2DBmod
    ...then reinterlace.

    Originally Posted by VideoFanatic View Post
    I can't use McTemporalDenoise & QTGMC in the same script (when making a video in VirtualDub) because together they crash VirtualDub (at least when in Multithreaded mode which is a necessity for those slow plugins).
    I don't run them together either. Too slow.

    Originally Posted by VideoFanatic View Post
    I didn't blame you for anything, you gave me a script so I tested the results and shared them with you. At what point did I tell you off for mentioning your idea?

    Maybe it doesn't seem like it to you but I've learned a lot from you (and others on this forum) and I'm always grateful for your help.
    Again, thank you. So I'll have to ease up, I guess. It's like pulling hen's teeth to persuade you that the same code doesn't work for any and all videos, and there is such a thing as overkill.

    Originally Posted by VideoFanatic View Post
    I'm quite happy with the old seperatefields comet removal script and doing the 8 passes in the avsi file. The picture quality is great and it removes nearly all the comets. It would be great if I could get a different script that removes more comets but if not, I'm quite happy with the script I already have. I'm making 720 x 480 interlaced videos.
    I'm glad you're happy with it, but I don't think it looks "great". It's certainly an improvement, but the filtering was overkill and the results look that way, IMO -- but as everyone knows, that's a subjective call. The 720x480 clips I posted are interlaced. The 1280x720 HD is not. That's why the script didn't reinterlace. After running that script I had two different resize routines, one interlaced and one not. There's nothing that says you can't reinterlace in a different step. But if you're just copying code and procedures, you wouldn't realize it.

    Okay, have at it and keep going. As long as you're happy with what you get. I'll just have to be more patient.

    BTW, there are a few remaining tiny comets in some corners here and there on all the posted videos, yours and mine. There's no way you'll get rid of all of them without working frame by frame, nor should there be any need for doing something like that.
    Last edited by sanlyn; 21st Mar 2014 at 10:16.
    Quote Quote  
  20. Originally Posted by sanlyn View Post
    You've been using code for quite a while, but it's frustrating to see you doing odd things like thinking QTGMC at "super fast" is denoising. Look at the QTGMC table of values for the various preset modes and you'll see that most of the denoising isn't turned on at fast presets. Again, throwing MCTD at everything in sight whether it needs it or not in just copying for no particular reason. Turning RemoveSpots onto a video 16 times or more might be necessary, but running MCTD with 16-plus runs of RemoveSpots() at the same time is like chopping a tree repeatedly: in effect, they're both doing the same thing -- which is what I mean by copying code without understanding it. You might try bypassing MCTD sometime and using QTGMC by itself at slower modes. You'll find that using both is seldom necessary.
    I said this
    I use QTGMC because it removes interlacing artefacts, does a little anti-aliasing and it does cleanup that McTemporalDenoise can't do.
    It does do those things even at SuperFast - even general denoising. I just test a test on the OP video using just QTGMC at SuperFast and it removed picture noise.

    I'm doing 8 passes (in the avsi file) with the removespots script not 16.

    Please note that I'm encoding several videos per day 24 hours per day. I don't have time to analyze each video to see if it needs more or less filters, etc. I only fix obvious things which I can see like comets, noise, screen shake, etc. My videos have a lot of noise in and other issues and I find that McTemporalDenoise at medium & QTGMC at SuperFast does fix most of the issues. I find that both are needed as each fixes issues that the other can't fix. For that reason I can't solely use QTGMC even at slower modes.

    Vinverse may or may not be needed but it does no harm and doesn't seem to increase the encoding time so I always use it.

    Originally Posted by sanlyn View Post
    You also don't seem to understand that you can deinterlace with QTGMC and then run umpteen filters afterwards if you want to because most plugins that you're using will work better with deinterlaced video -- afterward, you can reinteelace if necessary. But you seem tied down to "copyjng code" and to thinking that has you can only use QTGMC one way: QTGMC + vinverse + reinterlace. That's not at all true. Anyway, in this case Vinverse was just marking time: there was nothing for it to do.
    I don't where you got that from, I understand that fine! Quite often I use QTGMC then I use other filters while in progressive then I reinterlace afterwards.

    Originally Posted by sanlyn View Post
    Once you run QTGMC, why not run MCTD while the clip ia still deinterlaced instead of using interlaced=true or SeparateFields()? MCTD and most filters of its kind get better results from deinterlaced video. There's nothing wrong with doing somwthing like this:
    QTGMC
    MCTemporalDenoise
    ChromaSHift
    DeBlock_QED
    LSFMod
    GradFun2DBmod
    ...then reinterlace.
    Because as I said before when I use QTGMC then McTemporalDenoise I get picture problems. For example I created an AVI in VirutalDub with nothing except this script using the OP video as the source:

    Script 1
    Code:
    QTGMC(Preset="Super Fast")
    At this point the video is progressive. I can then create a h264 file using 1 of the scripts below using the output from script 1 as the source video:

    Script 2A

    Code:
    McTemporalDenoise(settings="medium", interlaced=false)  
    SeparateFields() SelectEvery(4,0,3) Weave()

    Script 2B


    Code:
    SeparateFields() SelectEvery(4,0,3) Weave()
    
    McTemporalDenoise(settings="medium", interlaced=true)


    Results
    (I viewed these videos on a Bluray disc on my TV)

    Script 2A: Gives a juddery framerate
    Script 2B: Gives a juddery framerate and interlacing artefacts (lines over the whole picture)

    You've said that you can use QTGMC before McTemporalDenoise. But my test showed me that it's not a good idea to do so as it gives problems. If I've done something wrong here then please let me know because if there's a correct way to use QTGMC before McTemporalDenoise then I'd like to know.
    Last edited by VideoFanatic; 5th Oct 2013 at 10:49.
    Quote Quote  
  21. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    If you like what you get, keep doing it. IMO QTGMC at super fast followed or preceded by MCTD is a waste of time for anything but the most horrible source. Why you get judder from either of those scripts might have something to do with the stingy bitrate you use to encode fast-action low-quality video -- which will never work. But suit yourself.
    Last edited by sanlyn; 21st Mar 2014 at 10:16.
    Quote Quote  
  22. That's just not true. The sources ARE horrible! They have a bitrate of between 3 - 4.5 Mbps. I don't set a specific bitrate in my encoder when re-encoding with Avisynth. I set a quality setting. I set it as low as possible where I can't see a difference in quality between that and the next highest setting. So for example the bitrate I get in the final h264 video is 3.5 Mbps and there's no macroblocking. That's the equivalent of 7 Mbps in MPEG2 which is plenty. I know it's plenty because I just encoded it at a higher quality setting which gave a bitrate of 6 Mbps (12 Mbps MPEG2 equivalent) and it looked the same as the 3.5 Mbps video. Both videos have judder.

    So is it actually possible to use QTGMC before McTemporalDenoise without getting that judder problem? If it is then please let me know how.
    Quote Quote  
  23. Banned
    Join Date
    Oct 2004
    Location
    New York, US
    Search Comp PM
    Originally Posted by VideoFanatic View Post
    I don't set a specific bitrate in my encoder when re-encoding with Avisynth.
    Avisynth does not encode. It's output is decoded, uncompressed AVI. It's your software app that encodes, not Avisynth. My encoders are stand-alone apps that let me set a great many options, none of which is called "quality" but are far more precise.

    Originally Posted by VideoFanatic View Post
    So is it actually possible to use QTGMC before McTemporalDenoise without getting that judder problem? If it is then please let me know how.
    I don't kno where you're getting judder. The plugins as you have posted them should not be causing it. My encoders are, among others, HCenc, TMPgenc Plus 2.5, TX264, X264 Encoder, and TMPGenc Mastering Works. None of them give me problems unless I make an error with my own settings. Some of them will give warning messages if I do something stupid, some of them will not allow me to make certain settings in conjunction with others, and some let me mistakes at will.
    Last edited by sanlyn; 21st Mar 2014 at 10:16.
    Quote Quote  



Similar Threads