VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 2 of 4
FirstFirst 1 2 3 4 LastLast
Results 31 to 60 of 95
Thread
  1. It works fine here in winamp (vdub => file => save wav) . Note , ConvertAudioTo16Bit() is required for vdub

    Code:
    vid= ffvideosource("audio.mxf") 
    aud= ffaudiosource("audio.mxf")  
    
    left = GetChannel(aud, 1) 
    right = GetChannel(aud, 2)  
    
    both=mergechannels(left, right)  
    
    audiodub(vid,both)
    
    ConvertAudioTo16Bit()
    Image Attached Files
    Quote Quote  
  2. Originally Posted by poisondeathray View Post
    For the vdub error, add to the end of the script

    ConvertAudioTo16Bit()
    This do a big difference: with this line the output .wav file is openable but I hear a jerky audio.

    I attach it [output.wav]
    Image Attached Files
    Quote Quote  
  3. maybe is a question linked to the interleaving settings?
    Quote Quote  
  4. Originally Posted by poisondeathray View Post
    It works fine here in winamp (vdub => file => save wav) . Note , ConvertAudioTo16Bit() is required for vdub

    Code:
    vid= ffvideosource("audio.mxf") 
    aud= ffaudiosource("audio.mxf")  
    
    left = GetChannel(aud, 1) 
    right = GetChannel(aud, 2)  
    
    both=mergechannels(left, right)  
    
    audiodub(vid,both)
    
    ConvertAudioTo16Bit()
    at the moment I don't have install it, however Vdub don't get me any error.
    But if you give me your exactly ConvertAudioTo16Bit I can install as plugin.

    I open your .wav but my winamp get me an error and don't open it.

    While my output.wav is jerky
    Quote Quote  
  5. Did you forget to disable the vdub audio filters from the last run ?

    (make sure you use the .avs script only, don't do the downsample in vdub audio filters)

    But if you give me your exactly ConvertAudioTo16Bit I can install as plugin.
    It's an internal filter, comes with standard avisynth install
    Quote Quote  
  6. I uploaded the wrong file above; that was a 32 bit per sample (without ConvertAudioTo16Bit)

    This is the correct one. If you compare the waveforms in audacity, your audio looks different (looks choppy on the Left audio channel)

    If you are using vdub to output audio, audio=>direct stream copy will disable the filters
    Image Attached Files
    Quote Quote  
  7. Originally Posted by poisondeathray View Post
    Did you forget to disable the vdub audio filters from the last run ?
    mmm, there is not the flag on the "use advanced filtering" [see: AUset.bmp attached]
    so I think Virtualdub don't use audio-filter. Or not? I'm not practically of vdub

    Originally Posted by poisondeathray View Post
    (make sure you use the .avs script only, don't do the downsample in vdub audio filters)
    so exactly what I have to do do disable the audio filters?

    Originally Posted by poisondeathray View Post
    But if you give me your exactly ConvertAudioTo16Bit I can install as plugin.


    It's an internal filter, comes with standard avisynth install
    Analysing your code:

    audiodub(vid,both)

    ConvertAudioTo16Bit()


    is there a way to do this functions with SounOut?
    Image Attached Thumbnails Click image for larger version

Name:	AUSET.BMP
Views:	202
Size:	369.4 KB
ID:	17962  

    Quote Quote  
  8. Originally Posted by Selur View Post
    doesn't
    Code:
    SoundOut(output = "wav", filename="c:\outputFile.wav", atype=1, format=0, autoclose=true, showprogress=true, overwritefile="yes")
    work ?
    it returns this error:
    Image Attached Thumbnails Click image for larger version

Name:	SOUT.BMP
Views:	194
Size:	157.2 KB
ID:	17963  

    Quote Quote  
  9. To disable audio processing, Audio=>direct stream copy in vdub

    Yes soundout works for me too; just add soundout() to the script. If you use default values a popup dialog will open up with options
    Quote Quote  
  10. SoundOut(output = "wav", filename="c:\outputFile.wav", atype=1

    Sorry but sometimes I'm a [pc.bmp]

    but with type=1 this is the results:

    [winamp.bmp]

    but maybe SoundOut is the solution
    Image Attached Thumbnails Click image for larger version

Name:	WINAMP.BMP
Views:	257
Size:	373.4 KB
ID:	17965  

    Last edited by marcorocchini; 20th Jul 2017 at 04:00.
    Quote Quote  
  11. a fast look at the documentation would have shown,... typo: atype=1 -> type=1
    congratulation you found it
    Quote Quote  
  12. Originally Posted by poisondeathray View Post
    To disable audio processing, Audio=>direct stream copy in vdub

    Yes soundout works for me too; just add soundout() to the script. If you use default values a popup dialog will open up with options
    Also I have try to use the "Direct stream copy" option but the outputted files remains jerky.

    Is there a way to use SoundOut in the script so it generate directly a .wav stereo PCM 16bit 48Khz file, without the gui interface?
    Quote Quote  
  13. disable the progress.
    Quote Quote  
  14. vid= ffvideosource("v:\automazioneclip\input\audio.mxf" )
    aud= ffaudiosource("v:\automazioneclip\input\audio.mxf" )

    left = GetChannel(aud, 1)
    right = GetChannel(aud, 2)

    both=mergechannels(left, right)

    audiodub(vid,both)

    ConvertAudioTo16Bit()

    SoundOut(output = "wav", filename="c:\outputFile.wav", type=1, format=0, autoclose=true, showprogress=true, overwritefile="yes")

    =
    [winamp.bmp]

    ... type=1 and format=0 what means?
    Image Attached Thumbnails Click image for larger version

Name:	WINAMP.BMP
Views:	203
Size:	373.4 KB
ID:	17966  

    Quote Quote  
  15. Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post
    To disable audio processing, Audio=>direct stream copy in vdub

    Yes soundout works for me too; just add soundout() to the script. If you use default values a popup dialog will open up with options
    Also I have try to use the "Direct stream copy" option but the outputted files remains jerky.

    Is this the exact same audio.mxf clip ?

    Was this the exact same script used ?

    I don' t know how it's possible? Maybe you have a buggy ffms2 build ? If you preview the .avs script in vdub or mpc, does audio "sound" ok ?
    Quote Quote  
  16. Originally Posted by poisondeathray View Post
    Originally Posted by marcorocchini View Post
    Originally Posted by poisondeathray View Post
    To disable audio processing, Audio=>direct stream copy in vdub

    Yes soundout works for me too; just add soundout() to the script. If you use default values a popup dialog will open up with options
    Also I have try to use the "Direct stream copy" option but the outputted files remains jerky.

    Is this the exact same audio.mxf clip ?

    Was this the exact same script used ?




    I don' t know how it's possible? Maybe you have a buggy ffms2 build ? If you preview the .avs script in vdub or mpc, does audio "sound" ok ?

    vid= ffvideosource("v:\automazioneclip\input\audio.mxf" )
    aud= ffaudiosource("v:\automazioneclip\input\audio.mxf" )

    left = GetChannel(aud, 1)
    right = GetChannel(aud, 2)

    both=mergechannels(left, right)

    audiodub(vid,both)

    ConvertAudioTo16Bit()




    But result remains the same [outputfile.wav]: is jerky
    Image Attached Files
    Quote Quote  
  17. If even the preview of the script is bad (play the .avs script in a media player or vdub), then it's more likely a decoding issue, not an ENcoding issue.

    Which version of ffms2 are you using ?

    Try changing FFMS2 builds, try vanilla, 32bit 2.17
    http://code.google.com/p/ffmpegsource/downloads/detail?name=ffms-2.17.7z
    Quote Quote  
  18. Originally Posted by poisondeathray View Post

    Try changing FFMS2 builds, try vanilla, 32bit 2.17
    http://code.google.com/p/ffmpegsource/downloads/detail?name=ffms-2.17.7z

    Quote Quote  
  19. Originally Posted by marcorocchini View Post


    ?????
    Was that the one you were using already ?

    or does it work ok now ?
    Quote Quote  
  20. Originally Posted by poisondeathray View Post

    Try changing FFMS2 builds, try vanilla, 32bit 2.17
    http://code.google.com/p/ffmpegsource/downloads/detail?name=ffms-2.17.7z

    Last edited by marcorocchini; 20th Jul 2017 at 04:00.
    Quote Quote  
  21. Originally Posted by poisondeathray View Post

    Try changing FFMS2 builds, try vanilla, 32bit 2.17
    http://code.google.com/p/ffmpegsource/downloads/detail?name=ffms-2.17.7z
    it work perfectly
    Quote Quote  
  22. btw. I asked about ffms2 in post 20
    Quote Quote  
  23. Thanks to all
    Quote Quote  
  24. btw.: Why not simply use ffmpeg for the whole thing?
    Code:
    ffmpeg -i h:\AUDIO.MXF -vn -filter "channelmap=1|2:channel_layout=stereo" h:\out.wav
    see: http://www.ffmpeg.org/ffmpeg-filters.html#Audio-Filters

    seems to work fine here:
    Code:
    Input #0, mxf, from 'h:\AUDIO.MXF':
      Metadata:
        uid             : 38d41b00-3164-05c1-0270-08004602023b
        generation_uid  : 38d41b00-3164-05c2-0270-08004602023b
        company_name    : SONY
        product_name    : Opt
        product_version : 1.41
        product_uid     : 060e2b34-0401-0103-0e06-012002010300
        modification_date: 2013-05-19 20:15:46
        timecode        : 00:46:20:01
      Duration: 00:00:06.68, start: 0.000000, bitrate: 62578 kb/s
        Stream #0:0: Video: mpeg2video (4:2:2), yuv422p, 720x608 [SAR 152:135 DAR 43], 25 fps, 25 tbr, 25 tbn, 50 tbc
        Stream #0:1: Audio: pcm_s24le, 48000 Hz, 4.0, s32, 4608 kb/s
    Output #0, wav, to 'h:\out.wav':
      Metadata:
        uid             : 38d41b00-3164-05c1-0270-08004602023b
        generation_uid  : 38d41b00-3164-05c2-0270-08004602023b
        company_name    : SONY
        product_name    : Opt
        product_version : 1.41
        product_uid     : 060e2b34-0401-0103-0e06-012002010300
        modification_date: 2013-05-19 20:15:46
        ISMP            : 00:46:20:01
        ISFT            : Lavf55.7.100
        Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 48000 Hz, stereo, s1, 1536 kb/s
    Stream mapping:
      Stream #0:1 -> #0:0 (pcm_s24le -> pcm_s16le)
    Press [q] to stop, [?] for help
    size=    1253kB time=00:00:06.68 bitrate=1536.1kbits/s
    video:0kB audio:1252kB subtitle:0 global headers:0kB muxing overhead 0.007797%
    Cu Selur
    Quote Quote  
  25. Originally Posted by Selur View Post
    btw.: Why not simply use ffmpeg for the whole thing?
    Code:
    ffmpeg -i h:\AUDIO.MXF -vn -filter "channelmap=1|2:channel_layout=stereo" h:\out.wav
    see: http://www.ffmpeg.org/ffmpeg-filters.html#Audio-Filters

    seems to work fine here:
    Code:
    Input #0, mxf, from 'h:\AUDIO.MXF':
      Metadata:
        uid             : 38d41b00-3164-05c1-0270-08004602023b
        generation_uid  : 38d41b00-3164-05c2-0270-08004602023b
        company_name    : SONY
        product_name    : Opt
        product_version : 1.41
        product_uid     : 060e2b34-0401-0103-0e06-012002010300
        modification_date: 2013-05-19 20:15:46
        timecode        : 00:46:20:01
      Duration: 00:00:06.68, start: 0.000000, bitrate: 62578 kb/s
        Stream #0:0: Video: mpeg2video (4:2:2), yuv422p, 720x608 [SAR 152:135 DAR 43], 25 fps, 25 tbr, 25 tbn, 50 tbc
        Stream #0:1: Audio: pcm_s24le, 48000 Hz, 4.0, s32, 4608 kb/s
    Output #0, wav, to 'h:\out.wav':
      Metadata:
        uid             : 38d41b00-3164-05c1-0270-08004602023b
        generation_uid  : 38d41b00-3164-05c2-0270-08004602023b
        company_name    : SONY
        product_name    : Opt
        product_version : 1.41
        product_uid     : 060e2b34-0401-0103-0e06-012002010300
        modification_date: 2013-05-19 20:15:46
        ISMP            : 00:46:20:01
        ISFT            : Lavf55.7.100
        Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 48000 Hz, stereo, s1, 1536 kb/s
    Stream mapping:
      Stream #0:1 -> #0:0 (pcm_s24le -> pcm_s16le)
    Press [q] to stop, [?] for help
    size=    1253kB time=00:00:06.68 bitrate=1536.1kbits/s
    video:0kB audio:1252kB subtitle:0 global headers:0kB muxing overhead 0.007797%
    Cu Selur

    ffmpeg -i v:\automazioneclip\input\AUDIO.MXF -vn -filter "channelmap=1|2:channel_layout=stereo" c:\out.wav

    =

    [FFerr.bmp]
    Image Attached Thumbnails Click image for larger version

Name:	FFERR.BMP
Views:	224
Size:	106.6 KB
ID:	17969  

    Quote Quote  
  26. Poison is there a way to generate directly the output.wav file by launching the script?

    e.g.

    VirtualDub.SaveWAV("o:temp.wav");
    Quote Quote  
  27. you are getting a virtual dub error when using ffmpeg -> you are doing something wrong,..
    attached the out.wav that was created,... by the ffmpeg call,..
    Quote Quote  
  28. Originally Posted by Selur View Post
    you are getting a virtual dub error when using ffmpeg -> you are doing something wrong,..
    shure, but is possible I don'have installed FFMPEG module in avisynth?
    Quote Quote  
  29. nice selur - I think that is fairly new in ffmpeg . Audio handling used to be pitiful in ffmpeg

    But there is still some audio difference? Compare with ffms2 and avisynth stereo mix

    It shouldn't be, because ffms2 is based on ffmpeg....

    I'm not expert on audio, but the avisynth mixed sounds "fuller" ?? There are waveform difference in audacity as well
    Quote Quote  



Similar Threads