VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Page 11 of 13
FirstFirst ... 9 10 11 12 13 LastLast
Results 301 to 330 of 390
Thread
  1. Originally Posted by Selur View Post
    are these the images from before or after avisynth?
    I took those screenshots using avspmod.
    Quote Quote  
  2. Some of the restored footage in The Good, the Bad, and the Ugly was taken from moldy old prints.
    Quote Quote  
  3. Looks like mostly blue channel affected. How many frames are affected, and what is the distribution / pattern ? If it's just this one scene , can you upload the clip ?

    This looks like it will be tough to do a good job without manual work & masks, but there might some tricks you can use depending on the pattern
    Quote Quote  
  4. For a few frames here and there you can try replacing them with motion interpolated from the frames before and after.

    https://forum.videohelp.com/threads/352741-Frame-interpolation?p=2226119&viewfull=1#post2226119

    For example, InsertFramesMC(100,2) will replace frames 100 and 101 with motion interpolated from frames 99 and 102.
    Quote Quote  
  5. I can't get that clip (even after remuxing) to play (or otherwise decompress) properly in any player or editor:
    Click image for larger version

Name:	bad.jpg
Views:	162
Size:	240.5 KB
ID:	19312
    Quote Quote  
  6. seems like the file is missing some headers otherwise at least mediainfo should show resolution&co,..
    -> without a proper source, nothing to do
    Quote Quote  
  7. MediaInfo shows the properties:

    Code:
    General
    Complete name                            : D:\Downloads\sdsd.vc1
    Format                                   : VC-1
    File size                                : 25.4 MiB
    Duration                                 : 375ms
    Overall bit rate                         : 569 Mbps
    
    Video
    Format                                   : VC-1
    Format profile                           : Advanced@L3
    Duration                                 : 375ms
    Width                                    : 1 920 pixels
    Height                                   : 1 080 pixels
    Display aspect ratio                     : 16:9
    Frame rate                               : 23.976 fps
    Chroma subsampling                       : 4:2:0
    Bit depth                                : 8 bits
    Scan type                                : Progressive
    Compression mode                         : Lossy
    But I've tried several VC1 decoders and none of them gets a clean video.
    Quote Quote  
  8. doh used 'save as' instead of following the link (ffplay works fine)
    Quote Quote  
  9. works ok here

    mkvtoolnix , ffvideosource()
    Quote Quote  
  10. I used DGIndexNV to trim the source.
    Quote Quote  
  11. raw +
    avisynth + DGSource works fine
    avisynth + FFVideoSource shows only a single frame
    avisynth + LWLibavVideoSource -> crash

    remuxed to mkv
    + mplayer: broken
    + DirectShow based player with Hardware decoder: everything is fine
    seems like libav has some problems with the stream depending on the used version
    Quote Quote  
  12. Since only the blue channel is affected, ideally you want to limit repairs to blue channel.

    1) One approach: The distribution of the artifacts means some of the yellow spots are amenable to heavy dirt removal plugins by applying to blue channel (basically cleaning the blue channel). You need to ConvertToRGB (709) in order to showblue(), ConvertToYV12(709) to use the dirt removal plugins, convert back to RGB, then mergeRGB (r,g, fixed blue) . The problems with this: a) not perfect; will miss some areas - depends on what filter stack / combo used b) false positives will make blue spots

    2) Another method : you can attempt reconstruct the blue channel by manipulating R,G , but the colors will be "off". You would need to do big time color corrections and rotoscope some ares back in (some areas are supposed to be "yellow", like the yellow cape, yellow sergeant stripes etc... those will be faded unless you mask/layer them back in) . Something like colourlike() may help if you're not good with color correcting
    Quote Quote  
  13. A simple MergeChroma(McTemporalDenoise(settings="very high")) will pretty much eliminate the yellow spots. It's very slow though.

    <edit>
    Toward the end there is just too much of the yellow discoloration for MCTD.
    </edit>
    Image Attached Files
    Last edited by jagabo; 11th Aug 2013 at 20:03.
    Quote Quote  
  14. Does the OS affect the encoding speed?
    Quote Quote  
  15. Originally Posted by x264 View Post
    Does the OS affect the encoding speed?
    Only by a few percent.
    Quote Quote  
  16. is it necessary to call the selecteven() after using QTGMC or should i leave it at 60 fps?
    Quote Quote  
  17. Only by a few percent.
    32bit vs. 64 bit does 10-15% for me,...
    Linux vs. Windows are normally en par unless different decoders/filters are used.
    Mac was always slower than Windows and Linux for me.
    Quote Quote  
  18. Originally Posted by x264 View Post
    is it necessary to call the selecteven() after using QTGMC or should i leave it at 60 fps?
    What are you deinterlacing? What do you mean by "necessary"? What QTGMC() settings did you use?
    Quote Quote  
  19. Image
    [Attachment 25781 - Click to enlarge]


    Avisynth script

    DGSource("C:\Users\Abhijith Nair\Desktop\1.dgi")
    QTGMC(preset="Very Slow")
    Dither_convert_8_to_16()
    Dither_resize16nr(720,480)
    Dither_quantize(bitdepth=10, reducerange=true, mode=6)


    Sample

    http://www.mediafire.com/download/73tgfn9iac59dwo/VTS_01_1.m2v
    Last edited by x264; 17th Jun 2014 at 12:48.
    Quote Quote  
  20. Originally Posted by x264 View Post
    is it necessary to call the selecteven() after using QTGMC or should i leave it at 60 fps?
    It was shot using video cameras so 60p is fine although it kind of depends on what you want to do with it. For example, YouTube will remove every other frame to make it 30fps so you might as well do it yourself, perhaps with some motion blur added to keep movement looking more smooth.
    Quote Quote  
  21. I agree with manono. If you want to keep full motion smoothness and your playback devices support 60p don't decimate. If your playback devices don't support 60p decimate to 30p.

    Keep in mind that, outside of computers, very little supports 10 bit h.264.
    Quote Quote  
  22. I got this error when i tried to encoding using x264 10 bit.

    Click image for larger version

Name:	Capture.PNG
Views:	186
Size:	13.7 KB
ID:	25884
    Quote Quote  
  23. Did you load the DGDecode.dll? Did you make a D2V project file? What's the complete script you're using?
    Quote Quote  
  24. Yes, i did all that.

    MPEG2Source("C:\Users\Abhijith Nair\Desktop\VTS_01_1.d2v", cpu=0)
    QTGMC(preset="Placebo")
    Dither_convert_8_to_16()
    Dither_resize16nr(720,480)
    Dither_quantize(reducerange=true, bitdepth=10)
    Dither_Out()
    Quote Quote  
  25. Is DGDecode.dll in AviSynth's plugins folder? It should autoload if it is. Otherwise you need to explicitly import it into your script:

    Code:
    LoadPlugin("C:\Path\To\DGDecode.dll")
    Mpeg2Source(...)
    etc.
    Quote Quote  
  26. I have the DGDecoide.dll in the avisynth+ plugins folder. The error appears only with the 64bit build and not the 32 bit build.
    Last edited by x264; 23rd Jun 2014 at 03:57.
    Quote Quote  
  27. 32 bit editors/encoders/players require 32 bit AviSynth and 32 bit filters. 64 bit editors/encoders/players require 32 bit AviSynth and 64 bit filters. You can't mix and match 32 bit and 64 bit components.
    Quote Quote  



Similar Threads