VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date
    Mar 2013
    Location
    Australia
    Search PM
    Hi all. I have been playing some .mts files from a Canon Legria HFG10 that report as 1920x1080 and I have a computer screen the same size. Using VLC Media Player 2.0.5 Twoflower. In the menu Video -> Zoom -> 1:1 I would have expected it to fill the screen entirely seeing the file and screen resolution match. It only fills the screen about 95%. If I push the full-screen button it works fine.

    What I want to know is, is 1:1 by the menu actually running 1:1 and the file is not actually 1920x1080, or is full screen really 1:1 and the menu 1:1 not quite so?
    Quote Quote  
  2. With VLC running in Windowed mode you cannot get a 1:1 display because the program has to draw the window borders around the video. You have to use full screen mode to eliminate the window borders and get 1:1 mapping of source to screen pixels.
    Quote Quote  
  3. The 1:1 option probably only works when the video resolution is lower than the monitor resolution. Once they're the same (or close to), in order to account for the navigation/menu bars, VLC probably needs to resize the video down a little otherwise it'd have to stretch it in order for the video to fill the VLC window.
    So along the lines of what jagabo said, if the menu and navigation bars are taking up 5% to 10% of the screen, then the video needs to be resized down by 5% to 10% so the height fills what's left of the VLC window, which means you end up with black bars down the sides.

    The alternative is to disable the "always fit window" option under the view menu, and the sides of the video will then fill the entire width of the VLC window (I think, I don't use VLC much myself), but at the same time I think you'll lose some of the top and bottom of the video (effectively under the menu and navigation bars) until you change to full screen mode.
    Quote Quote  
  4. Member
    Join Date
    Mar 2013
    Location
    Australia
    Search PM
    Cool. thanks, guys. That does sound pretty reasonable that it would force the window borders if it was not in full screen mode. Now I can sleep.
    Quote Quote  
  5. Member
    Join Date
    Apr 2015
    Location
    Christchurch, New Zealand
    Search PM
    I had a similar problem with VLC Player 2.2.1 ... could not seem to get the video movie file to fill my 1600X900 res LCD monitor.. What I finally discovered is that I had to select video mode from the menu, come down to aspect ratio make sure that was in the DEFAULT and THEN come on down just below that to the CROP selection and change that to 1.85:1 ... in order to do that you must have a video file mounted into the VLC player. Other wise it is greyed out. out of FULL screen mode the cropped looks like its not wide enough but when you click the full screen mode.... works like a champ!!! so this CROPPING feature worked for me. Just played around with it. Trial and error.
    Quote Quote  



Similar Threads