VideoHelp Forum


Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. Hello all, it is good to be here.

    Please read this post thoroughly prior to making a reply.

    PROBLEM:
    Video file has two audio tracks, and the wrong one is the primary.(file details below)

    LIMITATIONS:
    NO V/Dub Mod.

    Computer details:
    New and kick-ass. Win7Ultimate-32/8GB RAM(4 usable)/30 TB RAID/Core i7/Nvidia Tesla x2 in SLI

    File details from G-Spot:
    Click image for larger version

Name:	JimDeanGSpotOutput.jpg
Views:	1335
Size:	133.8 KB
ID:	15505

    File has Portuguese as primary audio track. English is secondary.

    DESIRED OUTCOME:
    English audio track is primary/singular.

    Suggestions, please.

    Thank you.
    Image Attached Thumbnails Click image for larger version

Name:	JimDeanGSpotOutput.jpg
Views:	1263
Size:	113.9 KB
ID:	15504  

    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    Try avimuxgui.
    Quote Quote  
  3. use AviMux-Gui:
    1. start AviMux-Gui
    2. drag&drop the file into it
    3. select you video in AviMux-Gui
    4. press 'generate data source from files'
    5. remove the check mark before the audio stream you don't want
    6. press start, enter a new name for the file
    Quote Quote  
  4. This program must be run in compatibility mode for WinXPSP3 to work in Win7-32----just a note
    Quote Quote  
  5. Followed process exactly, except for the drag-and-drop thing....had to use the RC dialog under win 7....did not work. Output file has same characteristics as original. (at least, the same undesirable characteristic) Side note: After opening the file and generating source, path to file is in blue text. Once the audio track is deselected, the path text turns red.
    Quote Quote  
  6. Strange,.. thought that I used it on Win7 a few days ago, just tested got the same problem here,...
    Another option would be AviDemux:
    1. Start it
    2. load your source
    3. select the audio you want to keep under Audio->MainTrack
    4. Save the Audio under a new name
    Quote Quote  
  7. Member hech54's Avatar
    Join Date
    Jul 2001
    Location
    Yank in Europe
    Search Comp PM
    I must be either blind or I haven't used GSpot for a long time.....where in those screenshots does it show/prove that this file has two audio tracks?
    Quote Quote  
  8. Got it to work, thank you. Here's how:

    1. start AviMux-Gui in compatibility mode for WinXP-SP3
    2. Right-click in Open Files field.
    3. select your video in AviMux-Gui
    4. press 'generate data source from files'
    5. Uncheck "All Audio Streams" and "All Subtitles"
    6. remove the check mark before the audio stream you don't want
    7. press start, enter a new name for the file

    Thank you very much for all your help. Cheers!
    Quote Quote  
  9. Originally Posted by hech54 View Post
    I must be either blind or I haven't used GSpot for a long time.....where in those screenshots does it show/prove that this file has two audio tracks?

    It doesn't. It just shows the codec/container and such. I think we can take my word for it that the problem I signed up for an account to post about is really happening! LoL. Just taking the piss out of you, mate.
    Quote Quote  
  10. Incidentally, I was also able to figure it out with AVIDemux. Here's how:

    1. Start it
    2. load your source
    3. Nav Audio>Select Track
    4. In dropdowns for audio tracks, set the top one as track 1, and the bottom as track 0.
    4. Save the file under a new name

    Using this method, it was not even necessary to remove the Portuguese track. Thank you very much.
    Quote Quote  



Similar Threads